Nextcloud-Collabora: no option to select template

Hello All,

I have set up a new Nextcloud on Debian: version 17.0.3.
For testing purposes I also have Collabora CODE edition: version 4.2.0.1

When opening a new file, I never see the option to create the file from template.
In settings - Collabora Online I have no option to select a template directory.
I cannot find any app I can enable in order to work with templates.

I did upload .ott files to
~/appdata/richdocuments/templates an ran:
occ files:scan-app-data

That did not help.

Can anyone offer some advise?
Many thanks, J.

Hello All,

no takers for this question; thanks to every one who took the time to have a look at the post any way.
Could someone tell me if something extra needs to be installed or should this just work after installing Nextcloud / Collabora?

Greetings, J.

I added an .ott template file in the richdocuments settings (as administrator) and now when I create a new document I can choose which template to use (empty or the one I added).

Hello,

thanks for your answer.
The problem is, I think, that I 'm not seeing richdocuments settings.
Under Settings - Collabora Online there is nothing related to richdocuments or templates.

Greetings, J.

When I visit xxx.xxx.xxx/nextcloud/index.php/settings/admin/richdocuments as administrator I see a section ‘Global templates’.

I get there by logging in as administrator, click on avatar at top/right and choose settings, then in left column under ‘Administration’ on ‘Collabora Online Development Edition’ .

Hello,

I don’t have the “Global templates” section.
So I guess that’s the problem.

greetings, J.

Hello,

I have found the sollution here:

I had to add these two lines to /etc/apache2/sites-available/my-domain–le-ssl.conf:

ProxyPass /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities retry=0
ProxyPassReverse /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities

I then restarted apache and loolwsd.
All the above was done on the Collabora server .

Now in Nextcloud settings, " collabora online" changed to " Collabora online development edition" and I now have the Global Templates section.

Greetings, J.