Nextcloud client for raspberry pi



I don’t find any raspberry pi version for nextcloud client, i’m not even sure of its existence. The appimage file does nothing.

Can you help me ?



For the nextcloud CLIENT visit:

Choose Linux Appimage.


That is the Server, the Client is using the first link …


There are several ways for syncing, one of them is a plugin for the Browser Firefox i.e.
The other clients are different for your OS, the UBUNTU client is here, but it might also work on Debian.


Hi stemy2 - I haven’t found a precompiled RPI client yet either, but the good news is that der hess posted a step by step method to compile from source code that works spectacularly well:

I put together a bash file + a few file edits that does the job on the latest Raspbian ‘stretch’. Save it as and execute with the command: sh

sudo apt update
sudo apt dist-upgrade -y
sudo apt upgrade -y
sudo apt-get install build-essential git cmake openssl libssl-dev sqlite3 libsqlite3-dev qt5-default libqt5webkit5-dev qttools5-dev qttools5-dev-tools python-sphinx texlive-latex-base inotify-tools qt5keychain-dev -y
sudo apt-get install doxygen -y
sudo apt-get install extra-cmake-modules -y
sudo apt-get install kio-dev -y
cd /home/pi
git clone
cd client_theming
git submodule update --init
cd client
git submodule update --init
cd ..
mkdir build-1
cd build-1
cmake -D OEM_THEME_DIR=`pwd`/../nextcloudtheme ../client
sed -i 's/Icon=nextcloud/Icon=Nextcloud/g' src/gui/nextcloud.desktop
sed -i 's/Icon\[\(.*\)\]=nextcloud/Icon\[\1\]=Nextcloud/g' src/gui/nextcloud.desktop
sudo make install

Now you need to do 3 file edits, 2 of which create new files, add the line on the bottom.

sudo nano /etc/environment

sudo nano /etc/

sudo nano /etc/

sudo ldconfig
sudo reboot

This does take a while but I just checked it and it does work for the 2018-03-13-raspbian-stretch.img
Enjoy! Murphy


Just wanted to say thanks for bringing that article to our attention and for making that script! I’ve been casually looking for nextcloud clients on the pi for a while now, got serious about it today, so I can have it take pictures with the pi camera and then directly drop it into my nextcloud.I can confirm that building the client and editing those three files did work on the latest Stretch image, and on a raspi zero W at that.

Thanks again!


If you have client setup trouble, you could also mount the Raspberry Pi folders via webdav. Just to throw out a secondary option.


This step hangs for me.

pi@raspberrypi:~/Downloads $ git clone
Cloning into 'client_theming'...
remote: Counting objects: 1946, done.
remote: Total 1946 (delta 0), reused 0 (delta 0), pack-reused 1945
Receiving objects: 100% (1946/1946), 1.59 MiB | 626.00 KiB/s, done.
Resolving deltas: 100% (901/901), done.
pi@raspberrypi:~/Downloads $ cd client_theming/
pi@raspberrypi:~/Downloads/client_theming $ git submodule update --init
Submodule 'client' ( registered for path 'client'
Cloning into '/home/pi/Downloads/client_theming/client'...
{hangs indefinitely}

I notice that it’s using data from owncloud, which happens to have been updated on github 3 days ago, which happens to be around the last time these steps were reported working on this thread. Anyone else having trouble following these steps?


Anyone else having trouble following these steps?

Nope. Compiled and runs as expected for me on Raspbian 2018-04-18 edition.


I just followed these instructions today (27 May, 2018) without any issue. The cloning did take a while, but everything finished without error. Thanks!



I’m having troubles following these instructions.

cmake returns an error and i couldn’t find a way to make it work.

~/client_theming/build-1 $ cmake -D OEM_THEME_DIR=pwd/…/nextcloudtheme, …/client-- Build of crashreporter disabled.
– GIT_SHA1 57bc7918d7b0650c116f3512787f7677d4e5ab17
CMake Error at /usr/share/cmake-3.7/Modules/FindPackageHandleStandardArgs.cmake:138 (message):
Could NOT find OpenSSL, try to set the path to OpenSSL root folder in the
system variable OPENSSL_ROOT_DIR (missing: OPENSSL_LIBRARIES
OPENSSL_INCLUDE_DIR) (Required is at least version “1.0.0”)
Call Stack (most recent call first):
/usr/share/cmake-3.7/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.7/Modules/FindOpenSSL.cmake:385 (find_package_handle_standard_args)
CMakeLists.txt:156 (find_package)

– Configuring incomplete, errors occurred!
See also “/home/pi/client_theming/build-1/CMakeFiles/CMakeOutput.log”.




You can download now.

You need a QTWebEngine install.

$ git clone

$ cd qt5-qtwebengine-arm-bin

$ sudo ./

Download nextcloud client for arm to Home dir.
$ cd
$ wget

$ tar -zxvf nextcloud-desktop-client-v2.5.2-armv7-linux.tar.gz

$ cd nextcloud-desktop-client

Execute it
$ ./


Thanks for this post. I just tried to execute it and came till the “qmake -r” step. I got a dozen “not found. Using Chromium’s copies”, some “using internal copy” and “not enabled” messages. But also a dozen “unmet dependency” messages (for dbus-1, fontconfig, xcomposite, etcetera). End result: qtWebEngine will not be built.

Any clue which step i missed/should be added? Thanks.


Sorry. I edit my post. Now, You can download QtWebEngine arm binary.

Good luck!


That’s very fast :slight_smile: thanks.
All went well (and much faster!) until the last step. I got an error at line 9 … “./ line 9: /home/pi/nextcloud-desktop-client/bin/nextcloud: No such file or directory”. I guess the sub-directory “nextcloud-desktop-client” is missing after “/home/pi”.


It’s nice~.
Thank you for comment.
I modified the script to be flexible to the directory.
It will probably run without errors in the future.


Hi 11137,
I removed previous installation and started fresh over again. All went well until the last step … “./bin/nextcloud: error while loading shared libraries: cannot open shared object file: No such file or directory”
You have a clue what can cause this error? I couldn’t find a libminizip file. Thanks for helping out.


Dynamic libraries are too diverse.
For my rpi, I refer to the following minizip. => /usr/lib/arm-linux-gnueabihf/

Perhaps you should install the libminizip1 package with the following command:
$ sudo apt install libminizip1/stable

If you get an error due to another library, show me your shared library dependencies.
It can be confirmed with the following command.
$ ldd bin/nextcloud


Hi 11137,

Thanks. The installation of libminizip1 has fixed the problem. Nextcloud is starting up and connecting. Not yet tried the data synchronizing part.
ldd bin nextcloud comes up with a long list (see below). One i’m worried about … “ => not found”. You know whether this one will break nextcloud further on? Anything i can do to avoid this? Many thanks. (0x7ed2b000)
/usr/lib/arm-linux-gnueabihf/ (0x76b35000) => /usr/lib/arm-linux-gnueabihf/ (0x76a98000) => /usr/lib/arm-linux-gnueabihf/ (0x76a66000)
*** => not found*** => /home/pi/nextcloud-desktop-client/lib/arm-linux-gnueabihf/nextcloud/ (0x76988000) => /usr/lib/arm-linux-gnueabihf/ (0x76895000) => /usr/lib/arm-linux-gnueabihf/ (0x76f4b000) => /lib/arm-linux-gnueabihf/ (0x7686e000) => /usr/lib/arm-linux-gnueabihf/ (0x7680d000) => /usr/lib/arm-linux-gnueabihf/ (0x76637000) => /usr/lib/arm-linux-gnueabihf/ (0x7660b000) => /usr/lib/arm-linux-gnueabihf/ (0x765d9000) => /usr/lib/arm-linux-gnueabihf/ (0x7608b000) => /usr/lib/arm-linux-gnueabihf/ (0x73307000) => /usr/lib/arm-linux-gnueabihf/ (0x732ec000) => /usr/lib/arm-linux-gnueabihf/ (0x72fc8000) => /usr/lib/arm-linux-gnueabihf/ (0x72ba1000) => /usr/lib/arm-linux-gnueabihf/ (0x7286e000) => /usr/lib/arm-linux-gnueabihf/ (0x72712000) => /usr/lib/arm-linux-gnueabihf/ (0x722af000) => /usr/lib/arm-linux-gnueabihf/ (0x72167000) => /lib/arm-linux-gnueabihf/ (0x720e8000) => /lib/arm-linux-gnueabihf/ (0x720bb000) => /lib/arm-linux-gnueabihf/ (0x71f7c000)
/lib/ (0x76f24000) => /lib/arm-linux-gnueabihf/ (0x71f53000) => /lib/arm-linux-gnueabihf/ (0x71f00000) => /lib/arm-linux-gnueabihf/ (0x71eed000) => /lib/arm-linux-gnueabihf/ (0x71ed6000) => /usr/lib/arm-linux-gnueabihf/ (0x71ebc000) => /lib/arm-linux-gnueabihf/ (0x71db4000) => /usr/lib/arm-linux-gnueabihf/ (0x71d66000) => /usr/lib/arm-linux-gnueabihf/ (0x71c4f000) => /usr/lib/arm-linux-gnueabihf/ (0x71c1e000) => /usr/lib/arm-linux-gnueabihf/ (0x71bed000) => /usr/lib/arm-linux-gnueabihf/ (0x71bac000) => /usr/lib/arm-linux-gnueabihf/ (0x71b69000) => /usr/lib/arm-linux-gnueabihf/ (0x71ace000) => /usr/lib/arm-linux-gnueabihf/ (0x71a37000) => /usr/lib/arm-linux-gnueabihf/ (0x719fd000) => /usr/lib/arm-linux-gnueabihf/ (0x719b7000) => /usr/lib/arm-linux-gnueabihf/ (0x71894000) => /usr/lib/arm-linux-gnueabihf/ (0x71874000) => /usr/lib/arm-linux-gnueabihf/ (0x7185b000) => /usr/lib/arm-linux-gnueabihf/ (0x7183c000) => /usr/lib/arm-linux-gnueabihf/ (0x71827000) => /usr/lib/arm-linux-gnueabihf/ (0x7180e000) => /usr/lib/arm-linux-gnueabihf/ (0x717fb000) => /usr/lib/arm-linux-gnueabihf/ (0x7170e000) => /usr/lib/arm-linux-gnueabihf/ (0x716bb000) => /usr/lib/arm-linux-gnueabihf/ (0x716a8000) => /usr/lib/arm-linux-gnueabihf/ (0x71693000) => /usr/lib/arm-linux-gnueabihf/ (0x7167f000) => /usr/lib/arm-linux-gnueabihf/ (0x7161f000) => /usr/lib/arm-linux-gnueabihf/ (0x7148f000) => /usr/lib/arm-linux-gnueabihf/ (0x71447000) => /usr/lib/arm-linux-gnueabihf/ (0x71430000) => /usr/lib/arm-linux-gnueabihf/ (0x71416000) => /usr/lib/ (0x713ef000) => /usr/lib/arm-linux-gnueabihf/ (0x713c5000) => /usr/lib/arm-linux-gnueabihf/ (0x711b5000) => /usr/lib/arm-linux-gnueabihf/ (0x7104b000) => /usr/lib/arm-linux-gnueabihf/ (0x70fdd000) => /usr/lib/arm-linux-gnueabihf/ (0x70fb9000) => /lib/arm-linux-gnueabihf/ (0x70f3e000) => /usr/lib/arm-linux-gnueabihf/ (0x70f21000) => /usr/lib/arm-linux-gnueabihf/ (0x70ee8000) => /lib/arm-linux-gnueabihf/ (0x70e6f000) => /usr/lib/arm-linux-gnueabihf/ (0x70e5b000) => /usr/lib/arm-linux-gnueabihf/ (0x70e48000) => /lib/arm-linux-gnueabihf/ (0x70e16000) => /usr/lib/arm-linux-gnueabihf/ (0x70de3000) => /usr/lib/arm-linux-gnueabihf/ (0x70db2000) => /usr/lib/arm-linux-gnueabihf/ (0x6f525000) => /lib/arm-linux-gnueabihf/ (0x6f4f4000) => /lib/arm-linux-gnueabihf/ (0x6f4c1000) => /usr/lib/arm-linux-gnueabihf/ (0x6f4a0000) => /lib/arm-linux-gnueabihf/ (0x6f3cf000) => /usr/lib/arm-linux-gnueabihf/ (0x6f3c4000) => /usr/lib/arm-linux-gnueabihf/ (0x6f3af000) => /lib/arm-linux-gnueabihf/ (0x6f38d000) => /lib/arm-linux-gnueabihf/ (0x6f364000)



I thought it was a problem, but it was not.
My rpi was the same. And I am syncing well.

So I modified it to see the log window. I just added $1 to

$pwd/bin/nextcloud $1

You can download the tar.gz file again, but it is a simple way to modify the script file.

Now you can check the log window with the following command.

$ ./ --logwindow

I hope there is something that can be a clue to the log.