Nextcloud Box collabora

Based on the Demo located at I decided to spend the money to buy a Nextcloud Box and Raspberry Pi 2. All arrived today, connected everything, and fired it up. 10 minutes later, I have a perfectly functional Nextcloud install – without Collabora. Double checked the demo, it’s definitely there.

There are basically no installation instructions, and all the doc links go to the standard Nextcloud docs – nothing about how to add that functionality.

What am I missing?

Collabora is an addon, in that case you need a x86 comtainer/machine which can host that. Then you can connect the box with collabora.

So, you’re saying the demo for the Nextcloud Box on the site advertising the device is wrong? Seriously?

I don’t say anything, just collabora doesn’t run on an arm plattform. Where in the demo of the nc-box is collabora advertised?

If you visit – the Demo link is on the top right of the page. Use the “Instant Demo.” Once the demo is set up just log in, go to the Documents folder and click on the About.odt file – it will launch Collabora.

I’m starting to think I just wasted a bunch of money for the same functionality I already have…

ah ok, the demo is the normal x86-demo. Yes that is a failure by the devs. They should mention that collabora doesn’t work on arrm.

Thanks for the info. I bought this device because I’ve spent 4 or 5 days trying to get Collabora working (on an x86 machine) following the various instructions, and have been unsuccessful. Obviously it can work (as seen in the demo and elsewhere), but the instructions for getting it working have been unhelpful. If you know of a complete set of instructions (including which Linux distro/version, necessary packages, etc), I would be eternally grateful.

the issue with collabora is that, that it is changing every imageupdate that the last instruction may break.
Sometimes they forget an alias inside the dockercontainer or you need to alter the apacheconfig.
Nginx-proxy is atm not working at all.

How far did you come till you run into an error? I strongly recommend to use a recognized SSL Certificates,
selfsigned ones tend to break or won’t work at all.

The best I’ve gotten is to have it “almost” work – I’d click on a file, and it would open the Collabora interface, but then say it couldn’t access the file. Unfortunately, I’ve wiped the machine and restarted several times since then. I recall it involved adding several packages that weren’t listed in the official instructions. I was using Ubuntu Server 16.04LTS, docker, nginx, and php7. I don’t have the list of the additional packages I installed, but I recall there were a boat-load of them, mostly to enable aufs support. Like I said, it almost worked, but not quite.

I was using letsencrypt for both mycloud.mydomain and office.mydomain. That didn’t seem to be a problem.

It could be easier to have a VPS on your preferred hosting provider (OVH, DigitalOcean, AWS) build or install Collabora there and connect it to your Box.

That i think is the least painful way to go.

Or install it at home on a amd64/x86 VM/box.
Apache is working right with it so far.

Having somebody else host kind of defeats the purpose for me. I’ve got an i5 box just sitting here waiting, if I could get detailed instructions that worked, that would be all I need. But, either I’ve forgotten everything I know (possible!), I can’t actually read (also possible! :slight_smile: ) or there are steps / requirements missing from the instructions I’ve seen.

I’d strongly prefer to not use docker – and am happy to spend the hours compiling, but that didn’t work, either.

Why not?
What was the issue?

Because it was supposed to be “run these commands and ‘poof’ everything works” – but that never happened for me. So, I got frustrated, spent days pounding my head against technology I’m not familiar with, and that likely has jaded my opinion.

So, I guess it’s mostly because I’m not at all familiar with Docker - I have no experience with it. I’ll use it if necessary, or if there is an advantage that I’m not seeing. Again, without any experience with them (containerized systems), it seems like a kind of mini-VM that’s less flexible… however, if it will “just work” I’m willing to give it another go.

Well, it’s not really like a “just work” it requires some previous configuration.
I have no inclination. for any.

  • Docker is quicker to set up and comes with updates, but it is for small environments. (no more than 10 docs open simultaneously)
  • LibreOffice Online takes 4 to 8 hours to build, but virtually no limit, and comes without updates, you need to build each time.
  • Both are development tools, so in the long run you might expect some kind of bug, or you might not.

I’ve installed several instances and the only issues that i’ve found are when users have real enterprise firewall rules and horrific strict security.

I’m glad to know it’s possible! :smile:

Now, if you can provide me with some direction, or a single site with all the necessary info, I’d be eternally grateful! Here are some (by no means all) of the places I’ve been in search of instructions:

*HowTo:* Install Collabora Online on Ubuntu 16.04. (without Docker!) (thanks to Google Translate)

A little about me – I’ve been an IT professional for 25 years. Network tech, network admin, webmaster, web application developer, and now application development manager. I don’t code or troubleshoot any more (well, any more than necessary for my personal projects), though I’m not completely without skills – dated though they may be. I’m not afraid to dig and “play,” nor am I averse to learning new things – but I’m not into this to learn new skills. I just want to get a system set up for my personal use, preferably with as little hassle as possible.

Oh – and I sincerely appreciate any info, guidance, or direction I can get on this.

Check the Virtual Machine repo at GitHub

It’s a good place to start and contribuye.

1 Like

Additional to that, better use apache instead of nginx. Since collabora 2.0 as I read in the forums, still no one got it running with that.

I am looking for further information to firewall rules for both installation types.
Maybe you can help?

Sorry, but i don’t find firewall rules amusing.
Have a look on the documentation and run tests, you’ll find much of what you need to know there.


Thanks for that! Reviewing my notes to myself, it looks like I was using Apache when I got it almost working. I’ll start down that rabbit hole again. :slight_smile: