Nextcloud Bookmarks Clearout

Hi,

Does anyone know how to get rid of any/all db and file system traces of Nextcloud Bookmarks so I can give it a fresh start? Somehow it got corrupted, and if I reinstall it now, it crashes.

Hi @mercreh,
You are missing the required support template. Please fill this form out and edit into your post.

This will give us the technical info and logs needed to help you! Thanks.

Nextcloud version (eg, 26.0.1): 28.0.0
Operating system and version (eg, Ubuntu 22.04): RHEL 8.9
Apache or nginx version (eg, Apache 2.4.25): httpd-2.4.37-62
PHP version (eg, 8.1): 8.0.30
Database (sqlite or MariaDB or Postgres) MariaDB 10.5.22
Docker (compose) No
Snap No
Is this the first time you’ve seen this error? No

I should add, I got in a mess with the Bookmarks app, and tried to delete related tables from MariaDB a few versions ago, to give myself a clean slate with it. I somehow need to clear out anything to do with it to be able to try it again, without affecting the rest of my Nextcloud install which is fine.

If I renable the Bookmarks app maybe, then select it, then upload logs would that help? Which logs would be best, Nextcloud log, apache log?

The bookmarks app is still missing support for nextcloud 28. You likely just need to wait for the next release.

Aaah, okay, I didn’t know about that! Thanks mate.

the new release is out now

Oh right, I installed it again, and it still throws an internal error :frowning:

So the log has this in it …

“An exception occurred while executing a query: SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘nextcloud.oc_bookmarks_folders’ doesn’t exist”,“exception”:{},“CustomMessage”:“An exception occurred while executing a query: SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘nextcloud.oc_bookmarks_folders’ doesn’t exist”}}

I deleted the tables trying to clear out a broken config, looks like when I readd the App, it doesn’t try to create them again. Is there some way to get it to try?

Try this: https://github.com/nextcloud/bookmarks/wiki/Removing-all-traces-from-DB

1 Like

Thanks mate, that looked promising, but it still seems to be trying to find that table. There must be some other config somewhere that makes it think its still set up, whether its in the DB somewhere, or in a config file I’m not sure :frowning:

Well, after removing everything from db you need to re-install the app. That will recreate everything

1 Like

Lovely thanks mate, that fixed it. I had to disable it, then under disabled apps you can remove it. Then I reinstalled it, and that got me a clean slate.

1 Like