Nextcloud Android App gets slower over time

Hi all,
I am using Nextcloud now for some time (running on Ubuntu 22.04.3, Nextcloud Version 27.1.5 on a Zotac ZBOX CI665 Nano with 32gb ram + SSDs).
The instance is running fine and fast. Only one problem is really annoying:
When I install the Nextcloud Android App on my Pixel7Pro and open a Folder with about 2500 pictures for the first time it takes about 18-19sec to open (Not talking about previews, just loading the file list… Previews get loaded fine+fast afterwards). That’s okay for me… But… After opening few other folders, opening folders get slower and slower…
Fresh installing the app or deleting all data (not just cache) fixes it for a short time.
For my tests I tried the same folder mentioned after opening like 10-15 other directories first: opening takes more than 2min now.

Trying the same using my IPhone SE (2022) does not show this problem. I can open folders continuously and it does not slow down.

I also tried others Pixel phones (Pixel 6 and 4a…I Do not have other android devices for testing.) and all of them are showing the slow down :frowning:

You guys have any idea what I could try to fix it?
(“Photos” app for android seems like a good alternative just to check pictures… But it is kind of slow when search through 100k+ pics)

Best wishes and thanks for your help!


Android App version: 3.26.0

system information

  • if you have systeminfo app installed you will find the required data on https://{your nextcloud}/settings/admin/serverinfo
  • collect anonymized system report using https://{your nextcloud}/settings/admin/support
Nextcloud version (eg, 26.0.1): 27.1.5 -
Operating system and version (eg, Ubuntu 22.04): Linux 5.15.0-91-generic #101-Ubuntu SMP Tue Nov 14 13:30:08 UTC 2023 x86_64
Apache or nginx version (eg, Apache 2.4.25): nginx/1.25.3 (fpm-fcgi)
PHP version (eg, 8.1): 8.1.2
Database (sqlite or MariaDB or Postgres) mysql 10.6.12
Docker (compose) no
Snap no
Is this the first time you’ve seen this error? no, for months

The issue you are facing:

  • Steps to replicate it:

1.create a testuser and copy 1 directory (2500~ files, some subdirs, for test subdir1 3500 files, subdir2 2300~ files, subdir3 400~ files); copy it 3 times to have 3 same dirs
2. delete all data from android app (app store version or dev doesn’t matter)
3. login fresh with testuser and open main testdir takes about 9-10sec; subdir1 16sec. keep on and open subdirs 2+3
4. close nextcloud app
5. reopen app and open maindir from copy 1: main testdir takes about 17sec to load, subdir1 28sec; keep on and open subdirs 2+3
6. close nextcloud app
7. reopen app and open maindir from copy 2: mein testdir takes about 60sec to load…

  • The output of your Nextcloud log in Admin > Logging:
Can only see my wrong logins here, no more entries there.
  • The output of your config.php file in /path/to/nextcloud**
    (use https://.../settings/admin/support which auto-removes identifying information!):
    "instanceid": "***REMOVED SENSITIVE VALUE***",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
    "datadirectory": "***REMOVED SENSITIVE VALUE***",
    "filesystem_check_changes": 0,
    "dbtype": "mysql",
    "version": "",
    "overwrite.cli.url": "REMOVED",
    "dbname": "***REMOVED SENSITIVE VALUE***",
    "dbhost": "***REMOVED SENSITIVE VALUE***",
    "dbport": "",
    "dbtableprefix": "oc_",
    "mysql.utf8mb4": true,
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "activity_expire_days": 14,
    "": true,
    "blacklisted_files": [
    "cron_log": true,
    "default_phone_region": "DE",
    "enable_previews": true,
    "enabledPreviewProviders": [
    "preview_imaginary_url": "http:\/\/",
    "filelocking.enabled": "true",
    "htaccess.RewriteBase": "\/",
    "integrity.check.disabled": false,
    "knowledgebaseenabled": false,
    "logfile": "\/var\/log\/nextcloud\/nextcloud.log",
    "loglevel": 2,
    "logtimezone": "Europe\/Berlin",
    "log_rotate_size": 104857600,
    "maintenance": false,
    "memcache.local": "\\OC\\Memcache\\APCu",
    "memcache.locking": "\\OC\\Memcache\\Redis",
    "memcache.distributed": "\\OC\\Memcache\\Redis",
    "overwriteprotocol": "https",
    "preview_use_imagick": true,
    "preview_max_x": "1024",
    "preview_max_y": "1024",
    "preview_max_scale_factor": 2,
    "jpeg_quality": "60",
    "redis": {
        "host": "***REMOVED SENSITIVE VALUE***",
        "port": 0,
        "timeout": 0
    "quota_include_external_storage": false,
    "share_folder": "\/Freigaben",
    "skeletondirectory": "",
    "theme": "",
    "trashbin_retention_obligation": "auto, 7",
    "": "stable",
    "mail_smtpmode": "smtp",
    "mail_smtpsecure": "ssl",
    "mail_sendmailmode": "smtp",
    "mail_from_address": "***REMOVED SENSITIVE VALUE***",
    "mail_domain": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpauthtype": "LOGIN",
    "mail_smtpauth": 1,
    "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpport": "465",
    "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
    "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
    "app_install_overwrite": [
  • for Docker/Podman list environment variables ( run “docker inspect {container name}”)**
not running docker/podman
  • The output of your Apache/nginx/system log in /var/log/____:
  • For Docker/Podman post STDOUT of the container (run docker logs {container name})
  • errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors.
no errors
  • loaded apps
 - activity: 2.19.0
 - admin_audit: 1.17.0
 - bruteforcesettings: 2.7.0
 - circles: 27.0.1
 - cloud_federation_api: 1.10.0
 - comments: 1.17.0
 - contactsinteraction: 1.8.0
 - dashboard: 7.7.0
 - dav: 1.27.0
 - duplicatefinder: 1.1.4
 - federatedfilesharing: 1.17.0
 - federation: 1.17.0
 - files: 1.22.0
 - files_pdfviewer: 2.8.0
 - files_reminders: 1.0.0
 - files_rightclick: 1.6.0
 - files_sharing: 1.19.0
 - files_trashbin: 1.17.0
 - files_versions: 1.20.0
 - flowupload: 1.1.3
 - hsts: 0.9.0
 - imageconverter: 1.3.5
 - logreader: 2.12.0
 - lookup_server_connector: 1.15.0
 - nextcloud_announcements: 1.16.0
 - notifications: 2.15.0
 - oauth2: 1.15.1
 - password_policy: 1.17.0
 - photos: 2.3.0
 - previewgenerator: 5.4.0
 - privacy: 1.11.0
 - provisioning_api: 1.17.0
 - recommendations: 1.6.0
 - related_resources: 1.2.0
 - richdocuments: 8.2.3
 - root_cache_cleaner: 0.1.6
 - serverinfo: 1.17.0
 - settings: 1.9.0
 - sharebymail: 1.17.0
 - spreed: 17.1.4
 - support: 1.10.0
 - suspicious_login: 5.0.0
 - systemtags: 1.17.0
 - text: 3.8.0
 - theming: 2.2.0
 - twofactor_backupcodes: 1.16.0
 - unsplash: 2.2.1
 - updatenotification: 1.17.0
 - user_status: 1.7.0
 - viewer: 2.1.0
 - weather_status: 1.7.0
 - workflowengine: 2.9.0
 - encryption
 - files_external
 - firstrunwizard: 2.12.0
 - officeonline: 2.0.3
 - survey_client: 1.11.0
 - twofactor_totp
 - user_ldap

  • Android App Log
Would like to, but it is to big for text and I am not allowed to upload a odt :( 

That’s really weird. Any chance you can try to reproduce the behavior in a recent Dev build? It has integrated debug logging (under Settings->Logs) and you can install it easily via F-Froid. It’ll install in parallel with your standard edition installation (just don’t configure any overlapping auto-upload folders in the two different parallel installations).

Alternatively you can get logs from your existing installation via adb. Instructions in the README at the android client app repository on GitHub.

Once you get logs, feel free to create an bug report (Issue) in repository (unless the logs turn up something that isn’t clearly isn’t a bug I guess).

Hi @enthilzar,
You are missing the required support template. Please fill this form out and edit into your post.

This will give us the technical info and logs needed to help you! Thanks.

Thank you.
I added as much as I could.
I would also like to provide the android app log, but I am not allowed to upload a file…

I can only post it in pieces if you like? (3-4 post)

Perhaps that helps eben if it’s not the complete log?
That is the part that gets slower and slower over time.

2024-01-06 17:18:33 D OwnCloudClient #4

REQUEST GET /ocs/v2.php/apps/files_sharing/api/v1/shares

2024-01-06 17:18:33 D RefreshFolderOperation


2024-01-06 17:18:33 D FileContentProvider

applied batch in provider


2024-01-06 17:17:49 D FileContentProvider

applying batch in provider FileContentProvider@637cf65 (temporary: false)

2024-01-06 17:17:49 D FileDataStorage Manager

Sending 2922 operations to FileContentProvider

In the newest dev App I can now see thousands of log messages like this:
08T20:30:51.183+0100;E;RefreshFolderOperation;DecryptedMetadata for file -1 not found!

2024-02-08T20:30:51.188+0100;E;RefreshFolderOperation;DecryptedMetadata for file -1 not found!

2024-02-08T20:30:51.194+0100;E;RefreshFolderOperation;DecryptedMetadata for file -1 not found!
2024-02-08T20:30:51.199+0100;E;RefreshFolderOperation;DecryptedMetadata for file -1 not found!

It seems like 1 message per file in this folder:
08T20:31:12.194+0100;E;RefreshFolderOperation;DecryptedMetadata for file 7693 not found!

After this files get shown normally.
(IPhone App still fast)