Nextcloud 22 - appstore is empty, no apps shown, cannot install further apps

Dear all

I am really getting frustrated, so I decided to open this topic after having searched the whole forum for a solution.

I installed NC 22 on a hosted server by the german provider domainfactory. The installation worked well.

But I cannot install any apps. When clicking the appstpre via admin>>apps there is no entry listed except of some standards, I guess. No category is displayed and even the standard-apps I chose to be automatically installed via the installation process (e. g. calendar) are not listed.

What can I do?


Nextcloud version (eg, 20.0.5): 22
Operating system and version (eg, Ubuntu 20.04): hosted server at domainfactory
Apache or nginx version (eg, Apache 2.4.25): I do not know
PHP version (eg, 7.4): 7.73

Is this the first time you’ve seen this error? no, it appears even after reinstalling

Steps to replicate it:

  1. login as admin
  2. go to +apps

The output of your Nextcloud log in Admin > Logging:

only a error at tempmanager.php - fail to open dir

Thanks in advance for any hint to a solution…

Perhaps your hosted server provider can assist you. (Just a thought) Good luck!

Searched that php error on the forum and see some possible solutions here and here

Related issues on nextcloud github server
Possible fix with unable to access appstore tempmanager.php on nc22

In the config/config.php file, you can set up a different temporary folder that is within your webspace:

It could be that it is using the system’s default temporary directory and the hoster has put on some restrictions to it.

Thank you so much, tflidd!
It indeed solved the problem with the tempmanager.
So thanks again.

Thank you, just, for you quick answer as well!

Well, after solving this I got another problem with my ssl-certificate (cURL error 60: SSL certificate problem) and the appstore is still not working.
But I guess there are some threads dealing with this…

1 Like