Nextcloud 21 - update needed

Hi everyone.

So I would be using the template here but it is so bizarre I don’t know how to fix it.

so exited for next cloud 21 I immediately got the new beta version as soon as I cloud. That was a mistake. I set the channel in next cloud to beta and I updated it threw the CLI. Now I got it out of maintenance mode but for some resin it says “update needed”, and it wont update with the usual command I use (sudo -u www-data php updater.phar) but every time is says its successful.

Please help I need this fixed,
Thank you in advance.

UPDATE:
When I run occ for anything I get “Killed”

Welcome to the user-forum of NC, @jon_will - and thanks for your first contribution on here.

Though your error sounds strange there’s no way to avoid needed/important information (which the template demands), I’m afraid… Because nobody on here would know about your instance and setup etc.

There are some issues during upgrade to the final version when you have not enabled apcu for the command line version (it was working before):

Though your error is a bit different. During my tests, I the process were killed once, so perhaps it’s the same for you. The update and occ commands, you can make them more verbose by adding -v or -vv.

@JimmyKater first thank you for responding and I apologize. It’s just hard figure out what is happening because I have never seen this from the first time I tried next cloud 3 years ago (about). in the future I will try to do my best to do what you ask. it was just overwhelming because I was trying to figured out what in the world happened.

but that aside

@tflidd I did what you asked and it is still not working. I also typed -W and -V and did nothing other what I had before. All it says is “Killed”. Don’t know what is happening but thank you for your help. Let me know if you have anymore ideas.

Thank you everyone

you have the logfiles as well. Either the native nextcloud logfile, in the data folder, there is as well a updater-something folder, there might be a logfile as well.

I see the data folder but not the updatewhatever in my next cloud folder.

In the data folder you have a nextcloud.log and there should be an updater.log. If there isn’t, this could be a hint that the update app doesn’t have the permission to create files and folders.

Oh. yha there is nothing in that folder! what do I have to do to fix this?

Set the right permissions for the user www-data (hope this is the right user?) on the folder.
And again:
We don’t know anything about your installation! Please get back to the template and provide the needed information…

@swindhab I will get to that but while I’m doing that how do I set the permissions. I’m not to fumier of the numbers of chown and chmod.

OK here. I filled out everything I could.
Nextcloud version _(eg, 21?(might be 20))
Operating system and version _(ubuntu 20.04)
Apache or nginx version _(eg, 2.4.41)
PHP version _(eg, 7.4)

The issue you are facing:

Is this the first time you’ve seen this error?(Y)

Steps to replicate it:

  1. set chanel to beta via the GUI
  2. upgrade vi the CLI
  3. now it should say update needed.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):
/var/www/nextcloud/config/config.php

<?php
$CONFIG = array (
  'passwordsalt' => '' => 
  array (
    0 => 'localhost',
    1 => '',
    2 => '',
    3 => '',
  ),
  'datadirectory' => '/mnt/ncdata',
  'dbtype' => 'pgsql',
  'version' => '20.0.8.0',
  'overwrite.cli.url' => 'https://nextcloud..io/',
  'dbname' => 'nextcloud_db',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'ncadmin',
  'dbpassword' => '',
  'installed' => true,
  'instanceid' => '',
  'upgrade.disable-web' => 'true',
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => 0,
  'log.condition' => 
  array (
    'apps' => 
    array (
      0 => 'admin_audit',
    ),
  ),
  'mail_smtpmode' => 'smtp',
  'remember_login_cookie_lifetime' => '1800',
  'log_rotate_size' => '10485760',
  'trashbin_retention_obligation' => 'auto, 180',
  'versions_retention_obligation' => 'auto, 365',
  'simpleSignUpLink.shown' => false,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.5,
    'dbindex' => 0,
    'password' => '',
  ),
  'logtimezone' => '',
  'appstoreenabled' => true,
  'htaccess.RewriteBase' => '/',
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'maintenance' => false,
  'encryption.legacy_format_support' => true,
  'encryption.key_storage_migrated' => false,
  'app_install_overwrite' => 
  array (
    0 => 'social',
    1 => 'drawio',
    2 => 'extract',
  ),
  'updater.release.channel' => 'beta',
);

Who is the owner of the nextcloud data-direction? What’s about Nextcloud log? And I guess I can’t get the problem… Nextcloud isn’t showing you the available update or isn’t installing the update it tells you is available? Did it tell you about an update to an rc-version? Did you do the update multiple times (like first to version 20.0.8rc1 and then to 21)? What version did your nextcloud have before trying to update? Did you switch off maintenance mode after the update was succesfull or before?

Btw. I can only guess, that you are using apache as webserver because I know 1.19 is the most recent version of nginx. So why don’t you tell us about your environment?

I think I MIGHT know the problem. for some resin I can’t run the occ file. Any ideas why?

would you like to check if it’s a glitch that might come with this setting from above?

what’s the exact place you try running it and whats the exact command?

  1. I tried your fist suggestion and it didn’t work.

  2. I mean I litterly can not run any command with that file I always get the out put “Killed”

Pleas help for this is very impotent to me. Thank you for you help.

all I could come up with is: check owership and premissions for your installing- (and data-)folders. they need to belong to your webuser (in most cases www-data)

I don’t see a installing folder but data is owned by www-data

depending on your installation you should look look for a folder called nextcloud. Sometimes you’ll find it under /var/www/nextcloud or /var/www/html/nextcloud

I know I’m looking under /var/www/nextcloud