Nextcloud 16.06 ->17.01 fails in web updater

Just got the update notification through on a small NC 16.06 installation - first stage completed fine, but going with the web based updater option failed, with a blank page displayed after clicking on “Go back to your Nextcloud instance to finish the update”.

Going in via SSH and running sudo -u www-data php ./occ upgrade completed the upgrade successfully.

Was in a hurry to get the update done, so didn’t get a chance to check logging at the time of the fail. There’s a log entry at about the right time stamp that might be related around “Could not find resource js/config.js to load”. Happy to investigate more with guidance for log entries to look for.

1 Like

Good to hear!

Same problem. This was logged:

{“reqId”:“fZuMudkICOlwGp15w4Ql”,“level”:3,“time”:“2019-11-16T15:19:16+00:00”,“remoteAddr”:“”,“user”:"–",“app”:“PHP”,“method”:“GET”,“url”:"/",“message”:“Undefined index: name at /opt/nextcloud/core/templates/update.admin.php#24”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0”,“version”:“”}
{“reqId”:“fZuMudkICOlwGp15w4Ql”,“level”:3,“time”:“2019-11-16T15:19:16+00:00”,“remoteAddr”:“”,“user”:"–",“app”:“PHP”,“method”:“GET”,“url”:"/",“message”:“Declaration of OCA\GroupFolders\Versions\VersionsBackend::getVersionFile(OCP\IUser $user, OCP\Files\FileInfo $sourceFile, int $revision): OCP\Files\File must be compatible with OCA\Files_Versions\Versions\IVersionBackend::getVersionFile(OCP\IUser $user, OCP\Files\FileInfo $sourceFile, $revision): OCP\Files\File at /opt/nextcloud/apps/groupfolders/lib/Versions/VersionsBackend.php#38”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0”,“version”:“”}

Ran “sudo -u www-data php occ db:add-missing-indices”, which was successful, but same error messages after returning to web updater.

Running occ upgrade worked.

Not working for me :frowning:
i’m using NextCloudPi

pi@nextcloudpi:~ $ sudo -u www-data php ./occ upgrade
Cannot load Zend OPcache - it was already loaded
Could not open input file: ./occ

still a blank page

works for me with:
sudo -u www-data php /var/www/nextcloud/occ upgrade

The same problem under Suse 15.0 and apache. The command sudo -u wwwrun php ./occ upgrade
fixes the problem.

Had the same issue after updating my Nextcloud instance on my Shared Webhosting.
Logged in with SSH and running

php72 ./occ upgrade

in my Nextcloud directory fixed this problem