Nextcloud 13 Beta: external SMB storage link broken when accessing through browser


I have upgraded to Nextcloud 13 beta 1. Things seem to working just fine, however, I can’t click on the SMB external storage link in home. Basically, the link to the external SMB storage won’t work anymore. I’ve tried removing and re-adding the external storage and I get the green sphere, so I know it’s working. Just can’t open the storage through the browser. This is on CentOS Linux release 7.4.1708, php 7.1 (RemI) and MariaDB 10.1

Is anyone else having this issue?



already open topic

its for external storage means including smb, hdd ,etc

Thanks, but it says I can’t see the topic.

@system any chance this topic could be unlocked for all?

i have already send invitation, but theres nothing right now to solve problem,
we hope this guys solve our problem

Strange, I can’t access it either. If something breaks in beta versions, don’t hesitate to post directly a bug report on

In my installation i can make a right click and select open in a new tab… So this will work, after all Links are ok…
It seems only on Home the Links are damaged (without function) ?

1 Like

Thanks, @Toddie. Right clicking to open the external storage in a new tab worked.

So i think a fix for that is not a big deal. But i’am not an Expert…
But i’am wondering that there is no reaction from Softwareteam.

They mainly work on github (especially the guys for external storage), therefore I wrote you should submit this there. There is also a issue template that will ask you all important things about your configuration that they can reproduce the error.

Same issue here… cant access SMB shares (or anyone, even local) with NC13.0.1. Cant get the post mentioned (no access to it). I whish to help tracking this error (i full manage the hosts, got full access) so, invite me to the post?

With my issue, it turned out to be a degrading of service on our storage system. Nextcloud was actually the proverbial “canary in the coal mine”. :slight_smile:

BTW, as complementary info… i have same setup in my lab in a test server (without HTTPS or public domain) and all external shares works! same versions of all…
Looks like somerhing is wrong in my HTTPS setup?
The ‘not working’ setup has a domain assigned and is HTTPS enabled.

As i say, i can do lot of tests, so we can track this issue.

Let’s close this here. The OP was related to the beta version of NC 13. If you have doubt about your configuration, please open a new topic.