Nextcloud 12.0.4 is here, time to upgrade!


#1

Originally published at: https://nextcloud.com/blog/nextcloud-12.0.4-is-here-time-to-upgrade/

After some serious testing, we’ve made new updates available for Nextcloud administrators. This release brings important stability and security improvements and we strongly recommend to apply it. As always, our focus has been on reliability rather than features so this should be a safe upgrade. If you are looking for more excitement, we recommend you help us test Nextcloud 13 Beta! Nextcloud 13 introduces some impressive performance improvements alongside a host of new features.

Read on to find out what’s new, check the full changelog or grab the latest version now!

Improvements

Maintaining a stable series means bringing fixes for small problems as well as security issues in so administrators can be sure that upgrades are safe and quick. For this update, nearly 60 changes were written, reviewed, tested and integrated into the server while several more were made for the various apps that are part of the core package.

The most notable improvements include:

  • Several Object Storage fixes
  • Better IPv6 handling
  • Allowing a quota of 0, don't reset quota
  • Improved browser support
  • Improve LDAP user cleanup
  • Style and translation improvements (contrast/readability, adding missing icons)
Users of our updater will see a notification over the coming days. As we do staged roll-out it can take some time!

Migration now possible

A change many ownCloud users were looking forward to is that we made it possible to upgrade from ownCloud 10.0.4 and older to this Nextcloud release. If you want more information about the migration path, you can read our post from last May on how to upgrade. Last but not least, for users of the Nextcloud Snap like those using the Nextcloud Box or using it on their own server, the Snap will be upgraded to Nextcloud 12 with this update!

A subset of the changes has been made available for Nextcloud 11 as part of Nextcloud 11.0.6. This release was also made compatible with PHP 7.1. See the changelog for details and download links.

As always a big thank you to everybody who helped make this release possible, including those who helped test the release candidate. Thanks to our community, we can test many more configurations than would be possible manually. If you, despite all this, encounter any problems, please report it and consider joining our testing efforts next time to ensure your use case is taken into account!


#2

Nextcloud version: 12.0.4
Operating system and version: U 14.04.5
Apache: Apache 2.4.7
PHP version (eg, 5.6): 5.6.32
Is this the first time you’ve seen this error?: Yes


Following up my own post:

After several hours the situations seems to have improved,
mysqld runs at 20 ~80 % CPU at the moment…

Cheers
Andreas


#3

Yay! Thanks for fixing that regression!


#4

Hi, I’m thinking about updating to this latest version, but first I would like to know if my installed applications will continue the same as the user registration app, I would like to know if the apps are fully compatible before updating and not lose anything, since I also have an important user base.

regards


#5

Hello,
I’ve tested the new version on my testinstallation. After a few hours of testing without any failures, I’ve decided to update the prod. installation. Everything works fine. Even the upload of large files (tested till 30 GB) on our own S3 Storage (Fujitsu) works.
Thanks to Nextcloud !


#6

Is migration from owncloud 10.0.3 is available yet? I still get the error after I wget index.php and put it in /updater.


#7

Something has been broken for me.

Update 12.0.3.3 -> 12.0.4

running on a current linux slackware 14.2 with php-5.6.32 and apache httpd-2.4.29, nextcloud is installed for a user using his public_html directory and ‘dbtype’ => ‘sqlite3’, it’s just a small installation

update stuck and never left the maintenance mode, had to use a manual install, works for me now

still have my backups/nextcloud-12.0.3.3 directory, shall I invest some more time and downgrade/upgrade again to repeat my error?

nevertheless, thanks for the great work and have a happy advent time


#8

ubuntu 16.04 lts
php 7
apache 2
mariadb

Maybe same problem, updated with button. Stuck @ Download, disabled maintainance mode, continued the update and then it worked.


#9

Same problem here, always the same.


#10

Debian 9 kernel 4.9 on raspberry pi 2
Php-fpm 7.0
MariaDB.
Nginx
Data folder on separate drive.

Everyting went smooth with the upgrade.


#11

So if you go from 12.0.3 to 12.0.4 it makes no difference. If you are on an older version, this app has you covered:
https://apps.nextcloud.com/apps/caniupdate

:wink:


#12

PHP 5.6? In theory, anything newer than Nextcloud 10 requires PHP 7 - I thought that this wouldn’t work at all :wink:


#13

If you can repeat it, we can try to find the cause and fix it…The setup of @ExaconAT seems terribly standard LAMP so it shouldn’t cause such issues.

Guys and girls - if you get stuck, but it works with manual upgrade help us try to track it down! Look in the logs, that might help. Maybe @MorrisJobke has other things that could help us find what is wrong…


#14

Running behind HAProxy


#15

Update stuck in web mode It said the d/l was bad left me stuck in
maintenance mode. (can we get a message to get out of maintenence mode with
a password on the web page when it is in maintenance mode) took it out of
maintenance via config.php. Tried again ok.


#16

To bad … Still no info what the logfiles say about it … No one whiling to try it with some debug infos on or sharing more infos then " it stucks" or behind a HA Proxy ?


#17

I tried upgrading from a pretty much fresh 12.0.0 install using the built-in upgrade button in the WebGUI. I got an error towards the end of the update (Something about not being able to remove some files), and got stuck in maintenance mode and a screen saying “Update in process”. Just plain text, no images or anything.

I attempted to restore from the backup that was made by the upgrader, but it couldn’t be found, so I did a manual upgrade to 12.0.4 over the console, copying over the config.php and data directory to my upgraded install from my original one.

I now have 12.0.4, but the “Update in process” page is still there when I try to connect to the server from a local computer… I’ve tried messing around a bit with the config.php, but nothing fixed my issue, so I suspect this is because Apache2 is still running some config/file that have the settings from the upgrade that got stuck…

Anyone have any tips on how to get rid of the “Update in process” page? I can’t use Nextcloud at all since it is the only one that’s loaded… :confused:


#18

In this post it says “we made it possible to upgrade from ownCloud 10.0.4 and older to this Nextcloud release.”

I am currently using 10.0.3 and tried to migrate to nextcloud… but it says it can not determine migration path to Nextcloud.

Is this not possible? I know in the post from may 2017 it does mention that it’s not possible from 10.0.1 and later yet… but this post says it is. I figured the old post was just old and incorrect? Is this a typo that 10.0.4 is able to migrate? Or am I doing something wrong?


#19

I have the same issue. I am curious too.


#20

If Nextcloud 12.0.4 says that a migration from Owncloud 10.0.4 is possible, but you’re using Owncloud 10.0.3, I would recommend to upgrade to Owncloud 10.0.4 first and then migrate to Nextcloud 12.0.4 :wink: