Nextcloud 10 PDF viewer doesn't work

I recently installed NextCloud and the PDFs worked initially but then they stopped working altogether. I have tested this on 2 Windows PCs and my Android browser. What happens is the page header loads (On this page it would be the blue bar), but then the rest of the page is blank. I also cannot view PDFs on “demo.nextcloud.com”. However, I am able to view files on “demo.owncloud.com”. I just installed a clean owncloud 9.1.0 and oddly enough I get the blank PDFs.

I am running a LetsEncrypt certificate and I also tried uninstalling all installed apps as well as multiple clean installs…

Edit:
Reformatted/rewrote my initial post.

Please check your server logfiles and also the web-console in your browser.

Log
Error files Could not find resource file “/apps/files/js/jquery.iframe-transport.js” 2016-09-11T08:12:00+00:00
Error PHP file_get_contents(/var/www/html/nextcloud/apps/files_pdfviewer/appinfo/signature.json): failed to open stream: No such file or directory at /var/www/html/nextcloud/lib/private/IntegrityCheck/Helpers/FileAccessHelper.php#39 2016-09-11T08:08:40+00:00 –
Error files Could not find resource file “/apps/files/js/jquery.iframe-transport.js” 2016-09-11T08:05:50+00:00
Error files Could not find resource file “/apps/files/js/jquery.iframe-transport.js” 2016-09-11T08:05:45+00:00
Error PHP Undefined index: dir at /var/www/html/nextcloud/apps/richdocuments/controller/documentcontroller.php#289 2016-09-11T07:41:57+00:00

The signature.json error is because I tried to manually re-install the pdfvewier.

Not sure how I fixed it, but I reinstalled LAMP (Apache, PHP, and MySQL) and the issue resolved itself.

I also did a fresh installation of Ubuntu 16.04 LTS and Nextcloud 10.0.1, but i can’t display any PDF files, for example “Nextcloud Manual.pdf”

Apache log says:

nextcloud.lan:443 172.16.16.2 - - [28/Nov/2016:23:49:42 +0100] "GET /index.php/apps/files_pdfviewer/?file=%2Fremote.php%2Fwebdav%2FNextcloud%2520Manual.pdf HTTP/1.1" 200 5398 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.99 Safari/537.36 OPR/41.0.2353.69"

Error code 200‽

Maybe some modules are missing but which one?

My PDF viewer doesn’t seem to be working either.
Nextcloud v11.0.0, PDF Viewer 1.0.1

My NC server is running on Ubuntu Server 16.04, with the file system on a network shared file server mounted via NFS.

Here are the two errors I got

Error core Error while running background job (Doctrine\DBAL\Exception\SyntaxErrorException): An exception occurred while executing ‘DELETE FROM oc_activity_mq WHERE amq_timestamp <= ? AND amq_affecteduser IN ()’ with params [1484168618]: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘)’ at line 1 2017-01-11T13:03:39-0800
Error PHP Uncaught Error: Access to undeclared static property: OC\Files\Filesystem::$normalizedPathCache in /var/www/html/nextcloud/lib/private/Files/Filesystem.php:806 Stack trace: #0 /var/www/html/nextcloud/lib/private/Files/View.php(2018): OC\Files\Filesystem::normalizePath(’/drew/files/amn…’) #1 /var/www/html/nextcloud/lib/private/Files/View.php(1156): OC\Files\View->unlockFile(’/amnav/50215-10…’, 1) #2 [internal function]: OC\Files\View->OC\Files{closure}() #3 /var/www/html/nextcloud/apps/files_external/3rdparty/icewind/streams/src/CallbackWrapper.php(109): call_user_func(Object(Closure)) #4 [internal function]: Icewind\Streams\CallbackWrapper->stream_close() #5 {main} thrown at /var/www/html/nextcloud/lib/private/Files/Filesystem.php#806 2017-01-10T14:23:30-0800

1 Like

how to fix this: idn_to_ascii() expects parameter 3 to be long, string given at /home/websiteo/public_html/client/lib/private/Mail/Mailer.php#212

Hi
My pdf viewer is working but it is not working on the android phone
how can i fix this?

Hello @m_j ,

you are replying to an 3 year old topic.

This category is not related to Android.

Please search the forum and/or open a new topic and add all necessary information to help you.

1 Like