Nextbackup is not showing in the backend

Hi I juste downloaded nextbackup from the apps menu but I don’t know where it is?

I copied manualy (drag and drop) the folder nextbackup from custom_apps to apps in my docker instalation folder on my nas. I know in the manual it should be done with the terminal but I don’t know how. I tried with the ssh and connect to may nas go to the location and do the copy but it did not work. I tried to go to the docker and open the terminal there and it also did not work.

After moving the folder to apps I still can’t see it.

What I’m I doing wrong?

thanks for the help

Is user www-data the owner of the folder for this App? If he is not the Adminpanel of Nextcloud will not show you the App. And take a look at all App packages and not only on the active ones.
sudo chown -R www-data:www-data /folder_nextbackup should bring the rights for www-data on you folder. Make sure to adjust it to your needs.

thanks for the help.

sorry but where should it be this user www-data? and in wich folder should I write this line? can I do it in the SSH of my nas?

You find it in “administration” -> “additional settings”.
Do not move the folder on your file system. Move it back.

It is better to use a better backup and restore concept.

backup:
https://docs.nextcloud.com/server/19/admin_manual/maintenance/backup.html

restore:
https://docs.nextcloud.com/server/19/admin_manual/maintenance/restore.html

Test your backup. Make a restore on a test sytem.

Ah I see now where it is.
What I don’t understand in the doc is, where do I have to put this line
$ sudo -u www-data php occ maintenance:mode --on

As SSH inon my Nas? In wich folder?

You must logon to your system with ssh or use OCC Web
https://apps.nextcloud.com/apps/occweb

Understand the command:

sudo -u www-data
execute the following command with user www-data (webserver and nextcloud user)
php
use php-cli
occ or /var/www/html/nextcloud/occ")
(perhaps you must use full path, test it, it is an nextcloud/ownclowd command)
maintenance:mode --on
occ-command

https://docs.nextcloud.com/server/15/admin_manual/configuration_server/occ_command.html

OCC won’t let me do the command

sudo -u www-data php occ maintenance:mode --on

Bei Occ Web nur:

maintenance:mode --on

hmm the sudo -u www-data php occ maintenance:mode --on didn’t work on occ.

What worked was maintenance:mode --on :slight_smile:

After putting myself out of my own system, I wen to the config.php and changed manually the the maintenance mode to false and uploaded the file back in the config folder.

Now I get a new message :frowning:

What can I do now?

I still don’t have the www-data user, wich I still don’t understand how and why I need it. Hope you can help me :wink:

how do I chnage it to root?


solved thisone by myself :slight_smile:

to come back to the initial problem. I would rather prefer to do it in the ssh.

But what I still do not understand is, what is that for a user? Do I have to creat it? And if yes how and where? if I execute that on my ssh I get this
Screen Shot 2020-06-09 at 22.17.30

chown www-data:www-data filename

I just read about it, I’m runing it in Docker and the line should look like this

docker exec --user www-data <nextcloud-container-name> php occ <your-command>

What is container name?

I do see the nextbackup setting as you said where it is.
I made a backup but it is not automaticly. Even if I switched to cron.

I made an other post, because my cron is not updating

How can I automate the backup system. In the manual it say it is automated, if so where can I check it and if not how is it done.

The guide is not helping me at all. :frowning: