New users unable to log in

Hi, I’m new to NextCloud, so this might be a dumb question, but I just set up a nextcloud server for my business. I am able to log in with the default ncadmin account, but no other users can log in, which means either I give my whole team the admin password (which for obvious reasons is not a good idea) or they are unable to log into the server. Does anybody know why this might be happening and what I can do to resolve the issue?

If it’s important, when creating the users, I inputted their name, username, and a default password, as well as I added them to the necessary groups and set their quotas to unlimited.

Hi @Craig_Sirota

Welcome to the Nextcloud forums :slight_smile:

I’m afraid we need a little more detail here…

Do the users get an error message? Are there any entries in the log? Have you tested this by yourself by creating a test user and log in with it? What exactley happens if you do so?

You can post a screenshot of the error message here if users want to log in.

When they try to log in they get this error. I’m sure there is a more detailed error report, but as I said, I’m new to NextCloud, so I’m not sure where to look for that. And I’ve verified that the username and password they are entering is what I entered when creating the users on the admin account.

Is the timezone and the time of your server correct?

Do you create the user accounts via web interface or via OCC command?

If you use the webgui, are you actually typing them in or are you doing some kind of copy&paste? Maybe there are blanks or hidden characters in it…?

Other than that I run out of ideas…

Maybe a search in the forum can point you in the right direction… I found this with a quick search

and this…

You could propably set the password of the user temporary to 11111111 and try again

I’ve created the accounts via the web interface. It seems like the UTC time of my server is correct, but it is in the wrong timezone. I’m not sure if that would prevent users from logging in, but I probably should fix it. Do you know how I would go about changing the timezone?

I’m pretty sure that tis fixes the issue. Make sure that also the logtimezone parameter in the config.php matches to the timezone of the system. Im not a sure how it all works in detail, but I think it has something to to with the bruteforce detection app, wich useses the Nextcloud log file and the timestampes in it do do it’s thing…