(RESOLVED) Correct password, authentication never works

Using nextcloudpi for ease of setup however I believe this problem is common as I’ve read around and is easy to replicate.

Nextcloud version 12.0.1
Operating system: Raspbian for raspberry pi 32-bit
Apache: Apache/2.4.25 (Raspbian)
PHP version : PHP 7.0.19-1 (cli)

Is this the first time you’ve seen this error?:

No, this was always present even with a fresh install.

Can you reliably replicate it? (If so, please outline steps):

  1. Log into admin account
  2. Go to users tab
  3. Do things like add user, change username, change password, etc and it will fail.
  4. The password prompt will be repeated indefinitely even if admin password is correct.

The issue you are facing:

The password prompt will be repeated indefinitely even if admin password is correct.

The solution is as I’ve read around is simple: simply change the date/time and make sure it is accurate. After changing date/time the authentication will work again.

However for me, this is not the case for whatever reason. I tried doing raspi-config and setting the timezone. Reboot, doesn’t work.
Tried also manually setting it with date --set="date time". Reboot, doesn’t work.

It worked for others facing the same problem, but it doesn’t work for me, what am I doing wrong?

Okay, can’t seem to get it to work.

I just settled down on using the occ command. It sucks this doesn’t work through the GUI though, I guess nextcloud is still too new and is buggy.

Is date/time accurate? Have you tried to set it up with ntpdate?

the command ntpdate does not exist on my system

EDIT: yes, date time is accurate, I set it with raspi-config and then choosing the correct timezone.

date returns correct date/time

It works now…for whatever reason didn’t worked before?..

Cool! Enjoy Nextcloud then. Maybe you can put a resolved flag in your topic title.