Network error 302, server replied: not found, Desktop client Windows


I am running NextcloudPi on an Odroid server with an external domain name. The syncing most of the time is going perfectly fine, but there is a rather persistent network 302 error when syncing small files, predominantly in Unity 3D projects. I added a screenshot of the error. When I login to Nextcloud via the browser, I see that the files that give the error are not uploaded. So somehow it doesn’t want to upload these small files.
The consequence that Nextcloud seems to be in this forever sync loop, without technically uploading anything. And using a lot of cpu by doing this. At least, that is how it seems like. Is there a way to solve this problem? I have been scratching my head on it for a couple of days now. Thanks in advance for your suggestions.

Screenshot 2023-09-28 153203

Server version?

Client version?

Server logs from period where an upload/sync is attempted?

Thank you for your reply. I hope this information tells a bit more.

Server version = NextcloudPi 27.0.1
Client version = 3.10.0 (windows)

Log snippet (replaced some paths with xxx/yyy/xxx/aaa):

2023-09-30 09:56:59:353 [ warning nextcloud.gui.activity C:\Users\sysadmin\AppData\Local\Temp\2\windows-17670\client-building\desktop\src\gui\tray\usermodel.cpp:873 ]: Item xxx/yyy/zzz/aaa/build/wp-content/plugins/updraftplus/vendor/autoload.php retrieved resulted in Network error: 302
2023-09-30 09:56:59:353 [ warning nextcloud.gui.activity C:\Users\sysadmin\AppData\Local\Temp\2\windows-17670\client-building\desktop\src\gui\tray\usermodel.cpp:835 ]: Item xxx/yyy/zzz/aaa/build/wp-content/plugins/updraftplus/vendor/autoload.php retrieved resulted in error Network error: 302
2023-09-30 09:56:59:354 [ info nextcloud.sync.propagator.bulkupload C:\Users\sysadmin\AppData\Local\Temp\2\windows-17670\client-building\desktop\src\libsync\bulkpropagatorjob.cpp:531 ]: Item completed xxx/yyy/zzz/aaa/build/wp-content/plugins/updraftplus/updraftplus.php OCC::SyncFileItem::NormalError CSyncEnums::CSYNC_INSTRUCTION_NEW Network error: 302
2023-09-30 09:56:59:354 [ warning nextcloud.sync.propagator C:\Users\sysadmin\AppData\Local\Temp\2\windows-17670\client-building\desktop\src\libsync\bulkpropagatorjob.cpp:713 ]: Could not complete propagation of xxx/yyy/zzz/aaa/build/wp-content/plugins/updraftplus/updraftplus.php by OCC::BulkPropagatorJob(0x25293484280) with status OCC::SyncFileItem::NormalError and error: Network error: 302
2023-09-30 09:56:59:354 [ info nextcloud.sync.propagator.bulkupload C:\Users\sysadmin\AppData\Local\Temp\2\windows-17670\client-building\desktop\src\libsync\bulkpropagatorjob.cpp:743 ]: modify final status NormalError OCC::SyncFileItem::NormalError OCC::SyncFileItem::NormalError

Were you able to figure this out? I seem to be having a similar issue.

The sync client gives me the same not found error, but my app log isnt giving me anything to go on.

if i try to upload the same file through the web UI it starts to upload, then just quietly dies, no error logged, no error displayed, the upload just goes away.

The weird thing here is, it only seems to be doing it on videos… or maybe large files. Ill give another large file a try.

yep, confirmed, seems to be size related. just tried uploading files of several different types and sizes, around 10mb they start exhibiting this behavior.

Hi Gangrif,

I still have the problem, but to me it seems that is shows these errors with files that are practically 0 kilobytes. So extremely small files. Unity3D projects are full of them. As I mentioned I only have this problem with my Unity3D projects. So the local files are 0 kilobytes and when it asks me to resolve the conflicts in wants me to replace the files with server versions that are always 8 kilobytes.

I have the same problem with big .zip files … it works perfect till 1-2 weeks ago. Always brings the “server replied not found” error.
Is there any support help from nextcloud or a solution?

Same problem here. Uploding larger (up to 8 GB) video files fails constantly. Same error: File not found. We are using a managed NC and I had a chat with the support of our hoster. His (honestly) answer: “There is nothing you can do, exept waiting for an update of the client. The problem is known.” He said, he is not able to tell when a fixed version will be rolled out. Could be weeks, could be month.

Uploding via browser fails in 50 %. Even if it is successful, the client is not able to sychronize the files.

Update to client 3.10.1 changed nothing.

Problem gets worse because the windows explorer (Win 11) freezes, when the client is unable to do his work.

Anyone able to solve this issue?. I am facing the same error

I have the same problem.
I tried to upload files to the other directory, but the problem didn’t solved.

Server version: 27.1.3
Client version: 3.10.50(windows)

I’ve been having the same issue and the only thing I found that helps is to remove the folder connect and re-add them but the issue eventually comes right back again after some time

Server version: 27.1.3
Client version: 3.10.1 (Windows 11)

Is there a link to the issue on the bugtracker?

Then it is easier to follow the status, if they fix something you can check if it fixes the issue for you etc.

Update server version to 27.1.4, then my files are uploaded successfully.

It does not appear to be fixed for me - running the docker version of 27.1.4 server and 3.10.1 macOS client and I’m getting this error for a 143MB zip file. I tried re-packing the zip on both windows and macOS and the issue persists.

I was able to upload via the webUI, but there are certain paths only available through webDAV (ie using a Cryptomator vault) that appear to be broken. This does appear to be a relatively new problem as I’ve uploaded very similar files through webDAV in the past without any issues.

Update, I was able to fix it on my end by running in shell:
php -f ./occ files:scan --all
as there seemed to have been some unscanned files in the external mounts that were tripping it up

formatting of said command may differ depending on the setup of your installation as mine is done through Truechart’s supported version in Truenas-Scale

Hi all,
My workaround has been quite similar. I connected the external nextcloud hard drive via USB to my laptop and copied the files manually. After that I connected the hard drive back to the next cloud server and did a scan --all command to add the files to the database. This works fine, but is still not a fix unfortunately.

I good idea. I will look it up.

Unfortunately the file scan doesn’t resolve the issue with uploading data through the desktop app. I can confirm that this issue persists with desktop 3.11.0 (apple silicon) and server 27.1.4 (docker)

For the original post, it was on an external drive and a manual file-scan can be used as workaround. You are on mac, on a different version, with the setup on docker not NextcloudPi. Not sure if the manual scan changes things for you.
Your symptoms might be the same, for such problems, there can be a lot of different things causing problems, starting from proxies, antivirus solutions, config issues, … If it is too far from the original topic, it’s better to open your own topic and provide more details.