Need help with NextCloudPi installation [Details inside]

ncp
nc14

#1

Hello,

Background information
I have used NextCloud in the past but never got very far with it.

I now have more experience of Linux and feel like it’s time I give NextCloud another try, but once again I am a little lost.

What I have done so far
I have downloaded NextCloudPi from this link https://ownyourbits.com/downloads/NextCloudPi_RPi_11-22-18/NextCloudPi_RPi_11-22-18.tar.bz2

I have extracted the .img file and burnt it to an SD card with etcher.

After the system has booted up I am shown the login prompt on the terminal.

I am then shown $pi@nextcloudpi at the terminal prompt.

I enabled shh using $ sudo raspi-config

Once I have done this I am back at the $pi@nextcloudpi command prompt.

My issue

At this point I think I am meant to type in USER but this gives me -bash: user: command not found

Adding sudo also gives me the same output.

I am also unable to access the web interface using https://“raspberryPiAddress”:4443

Can anyone suggest what to do next or guide me with this setup please?

If you need more details about anything please ask and I will reply.


#2

You should first visit https://“raspberryPiAddress”
and
take note of the generated passwords
activate your instance by hitting the activation button
this first run of init may take a while…(check the /var/log/ncp.log for …init done)
You will then be forwarded to the :4443 to further setup your instance, or you do this in the terminal by running sudo ncp-config .

The $pi@nextcloudpi is the Linux command line prompt
You log in with user pi an password raspberry initially
You can change the password with the passwd command


#3

Hi @OliverV - thanks for the reply

If I navigate to - https://192.168.x.x I get a message saying … Can’t connect to server / unable to connect

Can you suggest what the issue is and what I might try to fix it.

Thank you :slight_smile:


#4

If it is a fresh install and no risk of data loss

in terminal run

sudo ncp-config

use arrow keys to navigate to nc-init, use enter to select and run it.
then return to command line and run

sudo tail -f /var/log/ncp.log

and wait for … init done

q to quit

then reload activation page at https://nextcloudpi.local/

If this fails, you might try same thing again, but also run nc-nextcloud before nc-init, to make sure 14.0.4 gets installed properly. What model Pi are you using?


#5

Thanks again @OliverV

I ran both commands and they both seemed to run correctly

sudo tail -f /var/log/ncp.log - This showed various things as ‘enabled’

Navigating to - https://192.168.x.x I am still gettting a message … Can’t connect to server / unable to connect

Is there something else we can try next to fix this?


#6

Did it say

init done

too?


#7

I think it said,

init done

Should I run it again?

I am using a Raspberry Pi 2B+

Thank you for helping me with this.


#8

So first nc-nextcloud then nc-init

Sure, give it another go and copy/paste output of

sudo cat /var/log/ncp.log

here or on pastbin.com or the likes.
Also output of sudo dmesg might contain clues to what’s going wrong. Any i/o errors are signals towards bad or corrupt sd-cards or bad powersource(cable).

Also copy/paste output of nc-info


#9

@OliverV So I ran nc-nextcloud and then nc-init.

It says,

NC init done

at the very end,

Here is a link to the paste bin - https://pastebin.com/uTcn3GE2

Let me know if this is helpful and what you find.

Thank you :slight_smile:


#10

Thanks for reporting, its a bug, it will be fixed shortly…
Will let you know here when its patched.

You can then run

sudo ncp-update

which will load the fixed nc-init, so you can run it again.

BTW you can run nc-nextcloud and tell it install 14.0.4 (latest stable) instead of 14.0.3


#11

@OliverV

So just to check I run the following

$ncp-config

nc-nextcloud

Then set the install to 14.0.5

nc-init

Then run $ncp-update


#12

No 5 yet :wink:

14.0.4


#13

@OliverV

Yes 14.0.4 my mistake.

I have done all that but I am still getting,

Can’t connect to server / unable to connect.

Is there anything else we can do to troubleshoot this?


#14

The patch has been created, Might take 10 to 12 hrs before Nacho has a moment to commit the patch.

In meantime, if you dont want to wait, you can patch the script yourself by adding PHPVER=7.2 to nc-init

sudo nano /usr/local/etc/ncp-config.d/nc-init.sh

add PHPVER=7.2 somewhere at the top of the file
save, exit and run nc-init again.


#15

@OliverV

Thanks for letting me know about the patch.

I am going to try to do it manually.

Can you look at the image below and suggest the best place to ad in PHPVER=7.2?

(Right clicking ‘view image’ should let you see a slightly bigger version of the image).

Thank you


#16

Was not 100% sure about that myself.
In the proposed patch I added an extra line just below the comment line

#tmp upload dir

Just above the part where variable $PHPVER gets called
It should work anywhere above there too.


#17

@OliverV

Thanks for your help.

I have added in the extra line (see image below)

32

How do I test this is working?


#18

Just run nc-init again from ncp-config.
And visit activation page to activate :persevere:


#19

@OliverV

I ran ncp-config, then in my web browser I visited https://192.168.x.x

I am still getting a message … Can’t connect to server / unable to connect

Have I missed out a step?

Is there anything else I can try to make it work?


#20

Thanks @_1uke for hanging in there !
Could you please post (pastbin) output of

sudo cat /var/log/ncp.log

and

sudo /usr/local/bin/ncp-report

So Nacho can have look later, when he has a moment to spare.