Need help with NextCloudPi installation [Details inside]

ncp
nc14

#21

Paste bins are all done for you. See the two links below.

Can we make any more progress?

What can I try next?

sudo cat /var/log/ncp.log - see link below

https://pastebin.com/nJVC7FDb

sudo /usr/local/bin/ncp-report - see link below

https://pastebin.com/YeC5mg8d

Thank you @OliverV and @nachoparker for all your help with this! :slight_smile:


#22

From this log, it seems the patch didn’t work or was not applied, did you save the file nc-init.sh after editing it and check the content?

Otherwise nothing else to do, i can think of right now, but wait untill patch is checked and applied upstream and propagated to everyone using ncp with nc-autoupdate enabled.

Try running ncp-update later on tonight or tomorrow morning, if you get a new version you can run nc-init again, which should fix this.


#23

@OliverV

If I check

sudo nano /usr/local/etc/ncp-config.d/nc-init.sh

Can can see PHPVER7.2 is still showing (see image below).

08

I will try and run nc-autoupdate tomorrow.

Is it OK if I check back in on this thread with you to make sure I am doing everything correct.

Thank you for all your help today, it is really appreciated.

P.S. Are you one of the Devs for NextCloudPi ?


#24

nc-autoupdate is enable by default. You can run sudo ncp-update manually anytime you want tho

Please do :wink:

I try to contribute, mostly to wiki, but anyway I can. Helping others, helps me better understand what is needed in the NCP documentation. And this time your logs, helped me discover and patch a small :beetle:.


#25

@OliverV

I am so glad I could help, I am interested in open source software and want to contribute to help make it better, although I am not a very active contributor as I don’t have a very advanced skill set when it comes to Linux.

I am so glad I was able to help discover a bug and that it has been patched which will hopefully help users in the future :slight_smile:


#26

NextCloudPi is headless, which means that you won’t see anything out of the HDMI port. You are meant to access NextCloud over the network, not from a keyboard/mouse/monitor.

You’ll first need to figure out the IP of the NextCloud. I logged in to my DHCP server and looked at its leases to find its IP address. I’m guessing you don’t know how to do that, so we can skip to the shortcut: using a PC, Laptop, etc, open a command prompt (Windows) and give it the command:

ping nextcloudpi

You should get an IP address if it’s on your network and booted up. Next, put that IP address in your browser where you would normally type in the URL.

There are wizards that will take it from there, so just follow them.

I have no idea why you guys are doing stuff from the linux command line to try to update things… that’s like skipping step 0, 1, and trying to get to 1025.


#27

@OliverV

Thank you for all your help yesterday.

I have just run the update but I am still getting the message - Can’t connect to server / unable to connect

Please could you advise what to try next.

Thank you :slight_smile:


#28

Hi @_1uke,

Let us have output of ncp-report again please.

I’m in process of doing a fresh install on one of my spare Rpi’s, used for testing only, to see if I get the same error.
Thanks for your patience!


#29

@OliverV

Thank you for getting back to me :slight_smile:

Here is the link to my ncp-report - https://pastebin.com/3LSBXmWA

Please let me know what you find from the report.

Also looking forward to hearing what you find out when you test on your spare Pi

Thank you for all your support with this :+1:


#30

Thanks

Could please try once more with the latest image https://ownyourbits.com/downloads/NextCloudPi_RPi_11-22-18/

I noticed from your report you are using NextCloudPi_10-23-18

I finished a test install and cannot reproduce your error, using the latest. Quit a few changes and bugs fixes in between versions.

You could try following commands first @_1uke

sudo mkdir /var/www/nextcloud/data/tmp

sudo chown www-data:www-data /var/www/nextcloud/data/tmp

and then run init again

if it fixes it no need to get new image.


#31

Hello @OliverV,

I have tried the new image and when I navigate to https://192.168.x.x/activate/

I can see my NextCloud ‘user’ and ‘password’

Should I go ahead and click ‘activate’?


#32

Yes hit activate
After taking note of the two generated passwords.


#33

@OliverV

I hit activate but for the last half hour I can see the message

‘NextCloudPi not yet initialized, trying again in a few seconds …’ - There is a spinning disk / timer above the message.

But the screen has not advanced.

Should I give it more time or should it be doing something by now?

Thank you :slight_smile:


#34

Just wondering, on your rpi,
what is output of :

cat /proc/cpuinfo

Check the ncp.log with

tail -f /var/log/ncp.log

use ctrl+c to exit, after message init done


#35

My command line hasn’t got to a log in prompt.

It’s finished with the line

Raspbian GNU/Linux 9 nextcloudpi tty1

And I can’t log in with SSH as the connection is refused.

Should I restart my system or do I need to try something else?


#36

You lost me there!
Restart yes


#37

Hi @OliverV

I have restarted, then I ran ‘sudo ncp-update’ at the comment prompt, but I get the following out put…

Downloading update
Performing updates
apt is currently running. Try again later
$

Has the update worked?

Do I need to do something else?


#38

Hi @_1uke

It means apt is running. It is good !
unattended-upgrades are enabled by default, that is why.
Just wait a few minutes and try again.

Please post output of

cat /proc/cpuinfo


#39

@OliverV

Everything has updated fine after I waited a little while :slight_smile:

Below are the results from cat /proc/cpuinfo

https://pastebin.com/xY5gtEpR

Let me know what to do next - Thank you :slight_smile:


#40

First: Visit https://192.168.x.xx/ https://nextcloudpi.local/ (also https://nextcloudpi.lan/ or https://nextcloudpi/ on windows and mac)
to activate your instance of NC, and save the auto generated passwords. You may review or reset them
anytime by using nc-admin and nc-passwd (these are available in ncp-config and ncp-web:4443).

Note: You will have to add an exception, to bypass your browser warning when you
first load the activation and :4443 pages. You can run letsencrypt to get rid of
the warning if you have a (sub)domain available.
Login to NC and check the admin panel settings and log (scroll down in left side menu)

Second: Type ‘sudo ncp-config’ to further configure NCP, or access ncp-web on https://192.168.x.xx:4443/