NC Client 3.12.0 not recognizing file renaming in Windows

UPDATE below

Nextcloud version (eg, 20.0.5): 28.0.2
Operating system and version (eg, Ubuntu 20.04): Linux 5.19.17-2-pve
Apache or nginx version (eg, Apache 2.4.25): unknown
PHP version (eg, 7.4): 8.1.2

Is this the first time you’ve seen this error? Yes (since NC 28.0.2)

The issue you are facing:

When pasting a file into a Nextcloud folder on Windows 10 Pro (Desktop client v3.12.0) and then renaming it, two files appear shortly after: original file and new (renamed) file (see attached Video).

It seems the Desktop client or NC server do not always capture the renaming of a file which leads to creating a new identical file. Thus, downloading the “missing” old file which was actually renamed.
This issue did not happen before 28.0.2 or client 3.12.0. As both were updated quite at the same time I cannot figure out whether the server or desktop clients produce this error. I did not see this issue on the web interface so far, though.
Our NC is hosted at a specialized provider and they have been taking good care or all updates, issues and individual settings for us. In this case they could replicate the error (video) but have absolutely no indication in the logs what leads to it. Also, no other similar issues have been reported so far.
I also attached a screenshot of the Desktop client process:
File 045.jpg is pasted into the folder
Then renamed to 045NEU.jpg
A few seconds later the client downloads the 045.jpg from the database and does not indicate any renaming.
Both files are absolutely identical with different filenames.
nc1

Steps to replicate it:

  1. Paste testfile1.txt into a synced Nextcloud folder in Windows 10.
  2. Wait for it to upload/synchronize (green checkmark)
  3. Rename testfile1.txt to testfile2.txt
  4. Wait for it to upload/synchronize (green checkmark)
  5. testfile1.txt suddenly appears alongside with testfile2.txt

UPDATE
This issue occurs with GroupFolders and NC client 3.12.0.
Not an issue with NC server.
Downgrading to 3.11.x solves the problem for now.

1 Like

I also have the same issue. When syncing with the desktop client version 3.12.0 on my Nextcloud server versions 27.1.3 / 27.1.7 / 26.0.3 / 25.0.2, errors occur when creating or changing folders. The interesting point is that it only occurs in group folders. I downgraded the client to version 3.11.2 to resolve the problem. The problem has disappeared. It seems to be a bug in version 3.12.0.

1 Like

Same problem here - not 100% repeatable. Often occurs when creating a new folder - I think Windows creates it first as “New folder” and then instantly renames it. Nextcloud client seems to get in the middle.

You’re right, thanks!
It’s the combination of GroupFolders and Client 3.12.0.
Downgrading to Client 3.11.x fixes the issue.
I’ll update the thread.

1 Like

Client 3.12.1 has just been released.

Yeah, just saw the notification.
Did you happen to install it already?
All good and working?

I still have issues on both Windows and Mac. It seems like I’ll have to wait for the 3.12.2.

1 Like

Haven’t tried creating files and can’t right now - I’m trying to get Nextcloud to download a 4GB zip file but again, the client appears to have frozen. It just says “Preparing sync”, there is no associated disk activity on my PC or the Linux host. Not good. The latest versions have introduced some horrible faults that I’m afraid have dinted my client’s faith. We’re currently migrating to M365 ASAP :frowning: As I type, I’ve got clients chatting on IM saying “Nextcloud has crashed”. Last night I removed the pilot teams access to a handful of group folders we’ve migrated. All Nextcloud should do is remove the local copy but no, it’s crashed.

This issue will be resolved by updating to new version 3.12.3

2 Likes

Yes, fixed. Created lots of new folders and renamed them as fast as I could. All worked fine. Only quirk was this message about Temp and ignore list:

I had a quick scan through ignore files and Temp doesn’t appear to be in the list. It synchronises fine as well as files within it.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.

Newer versions seem to have a similar problem again, discussion continues here: