NC 22 nach Umzug: Anmeldung nicht möglich

Hallo Zusammen,

ich habe einen neuen Server in Betrieb genommen. Ich habe dafĂŒr das komplette /var/www/html 1:1 auf den neuen Server kopiert, die Caches neu eingerichtet und was sonst noch notwendig war.

Da der alte Server noch im Betrieb ist habe ich die Freigaben noch nicht umgetellt.
Das ganze funktioniert auch soweit gut, mit nur einer Ausname: Nextcloud (Version 22).

Auf dem neuen Server bekomme ich nach eingabe der Adresse fĂŒr Nextcloud die Anbmeldeseite angezeigt. Nach der Eingabe von Benutzerneme/Passwort und betĂ€tigung der Enter-Taste bekomme ich unten links nach 1-2 Sekunden die Meldung x.x.x.x gelesen und das war es dann. Es spielt keine Rolle ob ich mich als normeler Nutzer oder als Admin anmelden will, es ist immer dasselbe.

Auch das mittels “sudo -u www-data php /var/www/owncloud/occ user:resetpassword xxx” neu vergebene Passwort Hilft nicht weiter.

Alles andere funktioniert aber tadellos.

Was kann ich also tun?

Gruß
chralt

Du hast alles nur kopiert und zuvor kein nexcloud installiert?
Das könnte das Problem sein

Hallo JimmyKater,

ja so ist es. Also neu installieren und dann die bestehende Installation noch einmal kopieren?

Gruß
chralt

@chralt
Wirklich neu installieren musst du nicht. Am Ende handelt es sich um Nextcloud um eine Webservice (dafĂŒr hast du einen virtuellen Webserver), ein Verzeichnis (z. B. /var/www/nextcloud) und eine Datenbank wie MariaDB.

Lese Backup und Restore. Was hast du davon gemacht?

Hallo Zusammen,

eine komplette Neuinstallation habe ich durchgefĂŒhrt, aber ich habe immer noch dasselbe Problem wie oben beschrieben.

Ich habe nicht mit Backup und Restore gearbeitet sondern das komplette Verzeichnis /var/www/html auf den neuen Server kompiert. auf ein und demselben Serer habe ich das schon erfolgreich gemacht, daher ging ich davon aus (ja Annahmen sind eben keine Gewissheit) dem ist allerdings nicht so wie man sieht.

Ich werde also dann mal den Web ĂŒber Backup und Restore gehen.

Vilwn Dank und Gruß
chralt

Vielleicht hat der Server ja sonst ein Problem. Ein paar Logs wÀren ganz gut.

Hier mal eine kleinje Logdatei:

nextcloud.odt (42,4 KB)

Leider kann ich damit nicht viel anfangen. Ich finde die Logs sehr unĂŒbersichtlich sschon weil es fĂŒr eine Meldungskennumg eine Vielzahl von Zeilen gibt und die auch dann noch so lang sind das sie nicht vernĂŒnftig snzeigbar sine.

Gruß
chralt

zeig uns doch bitte auch mal deine config.php (ggf spÀter noch mehr) und sieh zu, dass du die secrets und andere wichtige infos unleserlich machst bzw ersetzt


Hallo Zusammen,

hier die config.php (als odt getarnt) ich hbe natĂŒrlich alles sicherheitsrelevante entsetzt/entfernt.

config.odt (12,2 KB)

Es ist die config.php die auf dem aktuell noch laufenden alten Server liegt. Ich habe sie 1:1 auf den neuen Server ĂŒbernommen und dabei nur die Adresse(n) des Servers angepasst, damit bekomme ich auch die Anmeldeseite der Nextcloud-Installation zu sehen. Meine Internetseite funktioniert auf dem neuen Server problemlos, einschließlich aller php-Abfragen. Insofern gehe ich eigentlich davon aus das es nicht am Server liegt.

Achtung: bitte nicht verwirren lassen das in in der config “owncloud” und nicht “nextcloud” steht: beim Umstieg von Own- auf Nextcloud habe ich das Verzeichnis nicht geĂ€ndert damit nicht alle Leute die die Nextcloud nutzen ihre Konten neu anmelden mussten. Ich hoffe und glaube nicht das das der Grund fĂŒr das fehlerhafte Verhalten ist, auf dem alten bisherigen Server funkioniert so ja auch alles reibungslos.

Gruß und Danke
chralt

also beim Blick in deine Fehlermeldungen (man sollte die hier auch so posten können) fiel mir auf, dass es ein paar seltsam formatierte Links gibt


zB http:///blablbla
und https:///blablabla

ich dachte, ich könnte im config.php erkennen, wie die zustande kommen aber es fiel mir nix ins Auge.
Musste ggf noch mal auf die Suche gehen, es sollte m.E. nur zwei Slashes folgen.

Hallo,

im aktuellen Log gibt es keinen 3-fachen Slach!?

Mittlerweile hat sich das Problem verlagert: ich soll ein Update von 2 “Apps” machen, bekomme dann aber die Meldung “Possible CSRF attack. Connection will be closed.” Beim erneuten
Aufruf bekomme ich wieder die Meldung zur erforderlichen Aktualisierung - Endlosschleife.

In dem Log habe ich allerdings eine IP-Adresse gesehen die ich nicht kenne und die auch nicht in der NezwerkĂŒbersicht des Routers angezeigt wird.

Ich werde jetz mal die beiden zu aktualisierenden NC-Apps herauskegeln und schauen was dann passiert.

Gruß
chralt

Zeile 3+4: "message":"Could not detect any host in http:///nextcloud/data/htaccesstest.txt"
Zeile 8+9: "message":"Could not detect any host in https:///nextcloud/data/htaccesstest.txt