Music App Error - Nextcloud will not upgrade - Not possible to access Nextcloud

When I try to login to my Nextcloud I get a message that an app needs to be updated and that it is the Music (music) app that needs it:


However, when I click “Update App” I get the following:

When I try to “occ upgrade” in terminal because they tell me that is another way of doing it, I get this error message:
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Setting log level to debug
Updating database schema
Updated database
Updating …
Doctrine\DBAL\Exception\InvalidFieldNameException: An exception occurred while executing ‘UPDATE oc_music_albums SET created = ? WHERE created IS NULL’ with params [“2021-08-30 07:13:32”]:

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘created’ in ‘where clause’
Update failed
Maintenance mode is kept active
Resetting log level

I would gladly remove the music app altogether but trying to disable it leaves me with this message:
occ app:disable music
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
An exception occurred while executing ‘UPDATE oc_appconfig SET configvalue = ? WHERE (appid = ?) AND (configkey = ?) AND ((configvalue IS NULL) OR (configvalue <> ?))’ with params [“no”, “music”, “enabled”, “no”]:

SQLSTATE[HY000]: General error: 4047 InnoDB refuses to write tables with ROW_FORMAT=COMPRESSED or KEY_BLOCK_SIZE.
Is there any way to solve this?

I tried to pull the nextcloud image again using the following commands and got subsequent messages:

docker-compose pull
Pulling mariadb … done
Pulling redis … done
Pulling nextcloud … done
Pulling coturn … done
Pulling collabora … done
WARNING: Some service image(s) must be built from source by running:
docker-compose build nextcloud

docker-compose build nextcloud
Building nextcloud
Traceback (most recent call last):
File “bin/docker-compose”, line 3, in
File “compose/cli/”, line 67, in main
File “compose/cli/”, line 126, in perform_command
File “compose/cli/”, line 302, in build
File “compose/”, line 468, in build
File “compose/”, line 450, in build_service
File “compose/”, line 1125, in build
File “docker/api/”, line 160, in build
File “docker/utils/”, line 30, in tar
File “docker/utils/”, line 49, in exclude_paths
File “docker/utils/”, line 214, in rec_walk
File “docker/utils/”, line 214, in rec_walk
File “docker/utils/”, line 184, in rec_walk
PermissionError: [Errno 13] Permission denied: ‘/home/nightramcobe/nextcloud/mariadb/nextcloud’
[3524686] Failed to execute script docker-compose
nightramcobe@nightcobe:~/nextcloud$ sudo docker-compose build nextcloud
[sudo] password for nightramcobe:
Building nextcloud
Step 1/2 : FROM nextcloud:apache
—> 10fa80752a04
Step 2/2 : RUN apt-get update && apt-get install -y procps smbclient && rm -rf /var/lib/apt/lists/*
—> Using cache
—> 3ba3e5ce8318

Successfully built 3ba3e5ce8318
Successfully tagged nextcloud:custom

sudo docker-compose up -d
[sudo] password for nightramcobe:
nextcloud-mariadb is up-to-date
nextcloud-redis is up-to-date
nextcloud-collabora is up-to-date
nextcloud-coturn is up-to-date
nextcloud is up-to-date

This looks quite alright to me.

I am able to exit Maintenance mode by running:
occ maintenance:mode --off

What can I do? I am basically stuck att the image at the top.

Thanks for any input!

Just for reference, this same issue has been handled in App Update Required - Music - Cannot login to Nextcloud server · Issue #889 · owncloud/music · GitHub. Long story short, there was a bug in Music v1.2.1 and v1.3.1 which has been fixed in v1.3.2.


But the problem seems to have been another one. I wasn’t able to fix the problem with the Music player the way the app developers tried to show me. There was something wrong with MariaDB

I got the solution here:

Yes, so in essence, you had two intertangled problems. The initial problem shown in the screen shots of this thread was caused by the Music bug. But then the MariaDB problem kicked in and prevented the straight forward recovery from the problem state.

Yes, I think you are right.