Multiple users on one computer syncing the same folder

Nextcloud version 20.0.0:
Server Operating system Ubuntu 20.04.3:
Apache version Apache 2.4.41:
PHP version 7.4.3:
Desktop client 3.3.6

My wife and I both use various Windows 10 desktops in the house each of us with our own user IDs. We sync our own “My documents” files and folders to the server under our own IDs and we also have a “Shared documents” folder on the PC accessible by both of us. I would like us both to be able to sync that folder to a Shared documents folder on the server where it is set up as a Group Folder to which we both have access.

I have set up the shared folder as a sync connection under my user ID but when I try to set up a sync connection for my wife’s ID syncing the same group folder on the server with the same folder on the PC, the desktop client wants to sync the data all over again - all 97GB of it, even though the files are already there and identical in both locations!

At least it looks like it is copying the data. I have paused the sync because I currently don’t trust what the desktop client is up to.

I can’t believe I’m the only one who wants to do this. I need the shared folder to sync when either of us (or indeed both of us) is logged on to the machine so that the folder is always up to date for whoever might need to use the shared files. I can’t have the sync connection only working under one user ID as one of us might not use a given computer for days.

Is this by design, or an oversight? Or am I doing something wrong? I’d be very grateful if anyone could shed some light on this

I am not sure if an extra sync point could help. Problem is that both need to use the same database that manages the synchronization. Not sure if that can work without conflicts, e.g. when both users are logged in.

The virtual file system could be an interesting option for you, it shows the whole structure but downloads files only on demand.

Using a windows service that does the sync would be another option. It is not supported by the software itself, but you can workaround that:
Nextcloud-Client as Service? (Windows) and also this blog post: ownCloud as Service « Notes from a Sysadmin

Hi thanks for the reply

I did a test setup with a lot fewer files to see if it worked and it seemed to work fine. I set up a new group folder on the server and alternately modified a few text files from my userID and my wife’s while both of us were logged in to the same computer and both of us with the desktop client running. Nextcloud didn’t bat an eyelid. Everything synced and updated as I would expect it to.

So I let the client run on my large shared documents folder and it took a while (I excluded a couple of big folders to save time) but everything seems to be fine. It is also not showing up any of the files as having been “updated” either.

So what I am thinking is happening is perhaps this. There seems to be two sets of database files in the hidden items in the folder that both of us sync - presumably one for each user. They seem to have different identifiers. Perhaps, when the second user sets up the sync, even though all the files are already there, the desktop client runs through all the files and does a bit by bit comparison to make sure that the files that look the same (same size, same name, same date) are indeed actually all the same. This is being done over a network so, for umpteen GB of data, that will take quite some time. GIven that the files are the same though, nothing actually gets changed. If I understand it correctly that’s exactly what happens if the Nextcloud desktop client ever loses its local database

I’d be interested to know if that is indeed what is happening. It would be useful to know, for example you wouldn’t want to do this over wifi in a hurry!

Perhaps at some point the client could be updated and be sophisticated enough to know that the database it already has is up to date and know that it doesn’t need to go through this process when a second user connects to an existing sync connection. One for page 2 of the to-do list?