Missing Sharing options

Hello everyone,

i have the following problem.
I’m new to nextcloud and i don’t know why the sharing permissions not show.

Can anyone help me pelase?

Best regards
Fabian

Nextcloud version :*15.0.2.0
Operating system and version : debian 9
Apache or nginx version (eg, Apache 2.4.25):
PHP version : 7.3.1

The issue you are facing: missing file sharing permissions after adding a user to share

Is this the first time you’ve seen this error? Y

1 2

1 Like

I have the same problem. I can’t share … i also don’t see the share with Email options (Link Teilen mit Passwort)

I can’t find the user I have shared a folder with and the options I have set previously. The Icon has the link sharing symbol on it but the settings (bearbeiten, etc.) don’t show up.

Have you the apps „social sharing by facebook/twitter/google+/email“ active?

Yes? Then disable the apps.

I’ve disabled social and email sharing. No change. Same problem as Max.

In the end i installed nextcloud from scratch and now everything work‘s.

core.js?v=53cc73f8-3:7 JQMIGRATE: Migrate is installed, version 1.4.0
merged-share-backend.js?v=53cc73f8-3:2521 Uncaught ReferenceError: link is not defined
at merged-share-backend.js?v=53cc73f8-3:2521
at Function.m.each.m.forEach (core.js?v=53cc73f8-3:18)
at child.each (core.js?v=53cc73f8-3:1157)
at child.render (merged-share-backend.js?v=53cc73f8-3:2519)
at child.render (merged-share-backend.js?v=53cc73f8-3:4455)
at child. (merged-share-backend.js?v=53cc73f8-3:3752)
at triggerEvents (core.js?v=53cc73f8-3:1441)
at triggerApi (core.js?v=53cc73f8-3:1426)
at eventsApi (core.js?v=53cc73f8-3:1225)
at child.Events.trigger (core.js?v=53cc73f8-3:1416)

I’ve got this javscript error.

[edited out by me]

Solutions:


Until this is integrated, disable all other sharing social sharing apps, and share via email apps.

Hello to All.
If you have same problem with Sharing Options please upgrade to 15.0.4 and all ptions came back.
I checked it right now.

Hello, are you using µBlock extension ? May be a solution here : https://help.nextcloud.com/t/sharing-option-is-missing-in-firefox-with-block/77932

2 Likes

Thanks for sharing this!

Hello!
As a beginner, I will insert my 5 cents. Sharing does not work for a single user - administrator. When I created a new user and logged in with it, everything worked!:wink:
Ha! I was wrong!) Public access does not work for users using the system, attention, Russian! French, Spanish, German work with public access without problems. This is probably the democrats tried?! O_o))

1 Like

Thanks very much! I keep looking this solving for issue with Russian language for a long time! =)