Sharing Option is missing in Firefox with µBlock

Hi Nextcloud Community,

thank you first of all for developing and enhancing nextcloud.

Can you provide any additional information, why the “sharing tab” dissappears if ublock is enabled although nothing seems to be filtered by ublock? If ublock is switched of for my nextcloud instance, everything is working alright.

Bildschirmfoto 2020-04-15 um 11.51.57

Nextcloud version: 18.0.3
Operating System: Ubuntu 18.04 LTS
NGINX 1.17.9
PHP 7.2.24

Firefox 75.0 @ MacOS

Thank you for any hint.

1 Like


hey… welcome to the forum and thanks for your very first participation…
you ask

wouldn’t that be a good qood question to the µ-block makers?

so why not just define an exclusion for your own server within µ-block to solve this problem yourself?

You are right - the creators of ublock might be the appropriate receipients of my questions. I already excempted my nextcloud instance in ublock but I was looking for an solution that I might have provided via github (alteration of nextcloud code).

However, the solution is very simple and I should have had a deeper look into the topic myself before opening the forum thread. I am very sorry :cry:

Therefore, I am providing additional information for documentation purposes (especially for other users who are looking for the same topic in the future):

  1. Actually, the sharing objects are provided correctly by nextcloud but they are not shown due to ublock:

  2. Why are the objects filtered? The solution is quite simply: A look in the ublock protocol shows that two sharing objects are being filtered as you (and I) intentionally configured ublock to do so:

Therefore, a solution might be, to rename the sharing objects to e.g. “scl-nc-shr” - however, as ublock is working as intended in my case, I will just continue to disable ublock on my nextcloud instance and not provide any code alteration proposal on github.

I hope that might help someone else.



thanks for sharing all these worthy insights here on the forum.

1 Like