Migrating Owncloud to Nextcloud -HTTP status code: 429


Problem with migrating from Owncloud to Nextcloud using Migration tool (https://nextcloud.com/migration/) - everything goes well up to that point:

“Downloading” step keeps spinning and Verifying Integrity message: Download failed - HTTP status code: 429 - URL: https://download.nextcloud.com/server/releases/nextcloud-12.0.12.zip

I have tried it over and over at different times - unlikely the solution is, “as Google says”, too many requests and try again afterwards.

My configuration is tricky - I only have FTP and web access; Also SSH access, but no sudo rights and no permission to stop web server via SSH etc (shared web server). Some previous upgrades have also got stuck via web brouser and needed manual occ upgrade.
What to try next? No clue…

1 Like

I got the same issue, after retrying sometimes the connection was even rejected. But the workaround is simple:

  • Download the required artifact manually (which worked fine from the browser
  • Put it in the $DATA_DIRECTORY/updater-{instanceid}/
  • Edit the update.php and comment out the function downloadUpdate()

Well, this doesn’t solve the root cause, but still you can install.

1 Like

This method is working well, thank you very much.

The updater file for nextcloud is updater/index.php
The folder for nextcloud zip is

It was necessary for me from nextcloud 10 to nextcloud 11 and 12.
After that, updater is working well.


Thank you for replies!
I got the migration done with this help!


Got the same problem, but when i comment this function downloadUpdate() out, i got some parsing error, as i “retry update”. is there any other way or should i completely install nexctloud from scratch, but how to import my existing owncloud users then ? can i just connect to the existing mariadb database ?

1 Like


i think you mean index.php (as that is where i find downloadUpdate() function, but when i put the zip in data folder and try what i think is commenting out the function, i get stuck at a page that says stuck at step 5 - refresh later

I am on shared hosting and I’ve migrated starting from OwnCloud 8.2.11 and have had this exact same problem for every update from OC 8.2.11 -> NC 9.0.58, NC 9.0.58 -> NC 10.0.6, NC 10.0.6 -> NC 11.0.8, and NC 11.0.8 -> 12.0.13.

However, there’s another “workaround” which I find easier. Simply go to the $DATA_DIRECTORY/updater-{instanceid}/ folder and if it doesn’t already exist, create a file “.step” with the following contents…


NOTE: For OC 8.2.11 -> NC 9.0.58 it was step 6, but for other updates it was step 5

After you refresh the updater web page, you will see “Continue Update” button with all steps completed before “Extract…”

Finally at update from NC 12.0.13 -> 13.0.12, the updater issue seems to be fixed, as I did not have this problem anymore.

Thanks a lot for the workaround! Another possibility is to comment out the line $updater->downloadUpdate(); as described in this migration blog article.

It looks like this is an issue with the updater/migration script itself. The download site seems to have a block for the specific user agent used by the migration tool (which is ironic, since it’s also by Nextcloud). The error message reads: “We noticed that you request many releases once every hour which stressed our download server quite hard. We blocked access for you for now. To resolve the issue and maybe improve the download scripts you can reach out to the Nextcloud team.”
I received this error message after attempting migration for the first time from my VPS, and downloading it via wget from the command line worked. Thus, it must be a user agent issue.
I think this should be handled as a bug.