Error while downloading -> http status 429

Hi, I’m having an issue update fom 12.0.0 to 13.0.12.

When running the updater I get:
image

Download failed - HTTP status code 429"

I can download the file manually - I’ve tried also an approach found here:

  • Download the required artifact manually (which worked fine from the browser
  • Put it in the $DATA_DIRECTORY/updater-{instanceid}/
  • Edit the update\index.php and comment out the function downloadUpdate()

Strangly I get the same message - even with the function commented out? Did I do something wrong here?
(I’ve just added /* at the start and */ at the end of the function)

public function downloadUpdate() {
/*
$this->silentLog(’[info] downloadUpdate()’);

$this->silentLog(’[info] end of downloadUpdate()’);
/*
}

Thanks in advance - Vanongart

I am on shared hosting and I’ve migrated starting from OwnCloud 8.2.11 and I had this exact same problem for every update from OC 8.2.11 -> NC 9.0.58, NC 9.0.58 -> NC 10.0.6, NC 10.0.6 -> NC 11.0.8, and NC 11.0.8 -> 12.0.13.

There is another “workaround” which I find easier. Simply go to the $DATA_DIRECTORY/updater-{instanceid}/ folder, and (if it doesn’t already exist) create a file named “.step” with the following contents…

{“state”:“end”,“step”:5}

NOTE: For OC 8.2.11 -> NC 9.0.58 it was step 6, but for remaining updates it was step 5

After you refresh the updater web page, you will see “Continue Update” button with all steps completed before “Extract…”

Finally at update from NC 12.0.13 -> 13.0.12, the updater issue seems to be fixed for me, as I did not have this problem anymore.