Method not allowed?

Not a power user here. I am using nextcloud as selfhosted on my web page and used it without trouble till a few days ago. Though I did not change anything, it does not synchronize files by “server replied: Method not allowed”. Tried to look for a solution on web but couldn’t find anything. Is this a very specific problem? What may be wrong?


Nextcloud version 15.0.7
Operating system and version: Debian Testing

Log says: You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /home2/xxxxxxx/xxxxx/xxxx/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18

Edit: Installed intl extension for php, still the same.

A bit of background:

Nextcloud uses a couple of these methods not only GET and PUT. For the properties there is PROPFIND and if the webserver blocks that, you have to fix this in the configuration. If it is hosted webspace, it’s not sure that you can change that and they could block this on purpose.

Thanks for the reply. Was not able to do this change in webspace regretfully. Deleted and reinstalled without much other options.

If you came across this post via google or like: you might want to check the firewall of your system, see Nextcloud on Plesk Obsidian ERROR PUT 405 "Method not allowed"