Nextcloud on Plesk Obsidian ERROR PUT 405 "Method not allowed"

When I try to load a file, apache returns a 405 error PUT method not allowed.
This problem occurs only with some files (for example: .dll, .ini files).

Nextcloud version : 19.0.2
Operating system and version: Plesk Obisidian on CentOS 8
Apache or nginx version: Apache 2.4.6
PHP version: 7.3.21

The output of your Nextcloud log in Admin > Logging:

{"reqId":"X1Nn49YO5W3u@UPk5poq4QAAAAw","level":0,"time":"2020-09-05T10:26:43+00:00","remoteAddr":"93.49.206.138","user":"admin","app":"serverDI","method":"GET","url":"/remote.php/webdav/file.dll","message":"The requested alias \"PreviewManager\" is depreacted. Please request \"OCP\\IPreview\" directly. This alias will be removed in a future Nextcloud version.","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.83 Safari/537.36","version":"19.0.2.2"}
{"reqId":"X1Nn49YO5W3u@UPk5poq4gAAAA4","level":0,"time":"2020-09-05T10:26:43+00:00","remoteAddr":"93.49.206.138","user":"admin","app":"serverDI","method":"PUT","url":"/index.php/apps/files/","message":"The requested alias \"PreviewManager\" is depreacted. Please request \"OCP\\IPreview\" directly. This alias will be removed in a future Nextcloud version.","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.83 Safari/537.36","version":"19.0.2.2"}
{"reqId":"X1Nn5LQtdN--rNDhXYIipwAAAI8","level":0,"time":"2020-09-05T10:26:44+00:00","remoteAddr":"93.49.206.138","user":"admin","app":"serverDI","method":"GET","url":"/index.php/apps/files/ajax/getstoragestats.php?dir=%2F","message":"The requested alias \"PreviewManager\" is depreacted. Please request \"OCP\\IPreview\" directly. This alias will be removed in a future Nextcloud version.","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.83 Safari/537.36","version":"19.0.2.2"}
{"reqId":"X1Nn5rQtdN--rNDhXYIiqAAAAIo","level":0,"time":"2020-09-05T10:26:46+00:00","remoteAddr":"93.49.206.138","user":"admin","app":"serverDI","method":"PROPFIND","url":"/remote.php/dav/files/admin/","message":"The requested alias \"PreviewManager\" is depreacted. Please request \"OCP\\IPreview\" directly. This alias will be removed in a future Nextcloud version.","userAgent":"Mozilla/5.0 (Windows) mirall/3.0.1stable-Win64 (build 20200828) (Nextcloud)","version":"19.0.2.2"}

The output of your config.php file in /path/to/nextcloud:

$CONFIG = array (
  'instanceid' => '***',
  'passwordsalt' => '***',
  'secret' => '***',
  'trusted_domains' => 
  array (
    0 => 'cloud.ghaudio.it',
  ),
  'datadirectory' => '/var/www/vhosts/ghaudio.it/cloud.ghaudio.it/data',
  'dbtype' => 'mysql',
  'version' => '19.0.2.2',
  'overwrite.cli.url' => 'https://cloud.ghaudio.it',
  'dbname' => '***',
  'dbhost' => '***',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'cloud',
  'dbpassword' => '***',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'cloud',
  'mail_domain' => 'ghaudio.it',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'ghaudio.it',
  'mail_smtpport' => '25',
  'mail_smtpname' => '***',
  'mail_smtppassword' => '***',
  'app_install_overwrite' => 
  array (
    0 => 'files_external_gdrive',
  ),
  'maintenance' => false,
  'updater.release.channel' => 'stable',
  'theme' => '',
  'loglevel' => 0,
  'mysql.utf8mb4' => true,
);

The output of your Apache/nginx/system log in /var/log/: NO ERROR

I solved the problem on: Firewall Application -> Web Application Firewall Mode -> set to off or detection only

1 Like

After some month of trouble shooting, this finally solved my 405 PUT Error: once I switched the Web Application Firewall Mode to “Off” for the nextcloud instance, the problem was resolved.

I solved it not by setting ModSecurity (Web Application Firewall) to off, but cits configuration to option “Tradeoff” insted of “Fast”. WIth it, it works perfect and security is not switched off.