Markdown app doesn't work after update to NC17

I have the issue that the markdown editor does not seem to work for me. I’m on the latest 17.0.0 with markdown editor version 2.1.0.
When I open or create an .md file I just get the normal view (from the Text app).

Am I doing something wrong? Thanks for anyone’s assistance.

Cheers.

Hi @smeijer

I just discovered something myself and maybe we have the same issue. Could you please check if you have the “Plain text editor” installed and enabled on your server? If you don’t find it in the web GUI and search for it on the filesystem, you would have to look out for “files_texteditor” in the folder nextcloud/apps/

Thanks for checking.

If you have the same issue, I can show you a solution to your problem.

Edit: moved this to a new issue

Hi @Schmu,

Thanks. I have checked for the “Plain text editor” app, but do not have this (checked in GUI as well as on OS).

Cheers.

Okay, thanks for checking. Meanwhile I found out the root cause. The app is no longer available in the NC app store. Therefore I opened an issue in the app’s repository:

While there is no way (or at least I couldn’t find any) to install the app from the GUI, there is only a manual way to get the app working again.

You can perform the following steps. Please make sure to change directory into the correct folder. I just used a placeholder. Furthermore make sure to use the correct user (web server user like “www-data” or “http”) for the chown command.
Easiest way is to run these commands as user root. If you don’t want to or can’t use sudo before these commands (sudo cd ...).

cd /path/to/nextcloud/apps
wget https://github.com/nextcloud/files_texteditor/archive/v17.0.0.tar.gz
tar -xzf v17.0.0.tar.gz
mv files_texteditor-17.0.0 files_texteditor
find files_texteditor/ -type f -print0 | xargs -0 chmod 640
find files_texteditor/ -type d -print0 | xargs -0 chmod 750
chown -R <webserver user>:<webserver user> files_texteditor
rm v17.0.0.tar.gz

Have installed the app via the manual steps and now I was able to enable the app via GUI. Unfortunately my original issue remains. Does that mean we are now in the situation you mentioned, you had a work-around for?

Actually this was the big workaround already :wink:

However, the issue you have is not a real issue, but rather a changed behavior since the release of the “Text” app which became the default app for text and markdown files.

With the texteditor app re-enabled you have two options now:

  1. use the option menu to make use of plain text app specifically:
    edit_in_plain_text_editor
  2. disable the app “Text”

We are getting closer :slight_smile:

I disabled the Text app and now the correct editor opens. On the right side however, I do not see the rendered version of the markdown text on the left.

Any ideas for this one?

The markdown app is still enabled, right?

Can you try to perform a full reload with:
CTRL + F5

Yes, app was still enabled. Cleared cache, forced reload via CTRL+F5, restarted Markdown App, used another browser where I never used the Markdown App. Issue remains.

This is not a shared file, right?

Could you provide the output from the browser console and the nextcloud log?

This is not a shared file. I tested with existing files, but also when creating new files (e.g. file.md).

Console output:

In the nextcloud log there are no messages written during the opening, editing and saving the file.

The browser console output looks okay so far - same for me.
I saw the following issue on Github and for these users the problem vanished after a few reloads or browser cache deletion:

Really difficult …
Could you check if there are any browser plugins interfering and blocking something?

Have cleared my Firefox cache, disabled all browser addons and tried over. This time I got more messages in the browser console.

The above screenshot shows the messages when I just open the Files App (not when opening an .md-file). When I do open an .md-file just the below messages appear:

image

Seems the damage is already done when the Files app is being opened?