Mail app is not connecting to mail account; Unexpected error during account creation

Hi,
Please help. Nextcloud version 20.0

I have installed the Mail app (Version 1.6) and I have tried to add the mail accounts but I get the error “Unexpected error during account creation.” Activated logs and this is the raw log below. I have sanitised the data by putting **:

{“reqId”:“X6sB0hFZCBcDq-E0D25NKwAATA8”,“level”:3,“time”:“2020-11-10T21:10:43+00:00”,“remoteAddr”:“4*.8*..”,“user”:“s",“app”:“mail”,“method”:“GET”,“url”:"/index.php/apps/mail/",“message”:{“Exception”:“OCA\Mail\Exception\ServiceException”,“Message”:“IMAP error: Error connecting to mail server.”,“Code”:11,“Trace”:[{“file”:"/home//public_html/checkmail.f.world/apps/mail/lib/Service/MailManager.php",“line”:127,“function”:“sync”,“class”:“OCA\Mail\IMAP\MailboxSync”,“type”:"->",“args”:[{“class”:“OCA\Mail\Account”},{“class”:“OC\AppFramework\ScopedPsrLogger”}]},{“file”:"/home//public_html/checkmail.f.world/apps/mail/lib/Controller/PageController.php",“line”:119,“function”:“getMailboxes”,“class”:“OCA\Mail\Service\MailManager”,“type”:"->",“args”:[{“class”:“OCA\Mail\Account”}]},{“file”:"/home//public_html/checkmail.f.world/lib/private/AppFramework/Http/Dispatcher.php",“line”:169,“function”:“index”,“class”:“OCA\Mail\Controller\PageController”,“type”:"->",“args”:[]},{“file”:"/home//public_html/checkmail.f.world/lib/private/AppFramework/Http/Dispatcher.php",“line”:100,“function”:“executeController”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Mail\Controller\PageController”},“index”]},{“file”:"/home//public_html/checkmail.f.world/lib/private/AppFramework/App.php",“line”:152,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Mail\Controller\PageController”},“index”]},{“file”:"/home//public_html/checkmail.f.world/lib/private/Route/Router.php",“line”:308,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:"::",“args”:[“OCA\Mail\Controller\PageController”,“index”,{“class”:“OC\AppFramework\DependencyInjection\DIContainer”},{“action”:null,"_route":“mail.page.index”}]},{“file”:"/home//public_html/checkmail.f.world/lib/base.php",“line”:1009,“function”:“match”,“class”:“OC\Route\Router”,“type”:"->",“args”:["/apps/mail/"]},{“file”:"/home//public_html/checkmail.f.world/index.php",“line”:37,“function”:“handleRequest”,“class”:“OC”,“type”:"::",“args”:[]}],“File”:"/home//public_html/checkmail.f.world/apps/mail/lib/IMAP/MailboxSync.php",“Line”:106,“Previous”:{“Exception”:“Horde_Imap_Client_Exception”,“Message”:“Error connecting to mail server.”,“Code”:11,“Trace”:[{“file”:"/home//public_html/checkmail.f.world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Socket.php",“line”:375,“function”:"_connect",“class”:“Horde_Imap_Client_Socket”,“type”:"->",“args”:[]},{“file”:"/home//public_html/checkmail.f.world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Base.php",“line”:838,“function”:"_login",“class”:“Horde_Imap_Client_Socket”,“type”:"->",“args”:["** sensitive parameters replaced "]},{“file”:"/home//public_html/checkmail.f.world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Base.php",“line”:1389,“function”:“login”,“class”:“Horde_Imap_Client_Base”,“type”:"->",“args”:["** sensitive parameters replaced "]},{“file”:"/home//public_html/checkmail.f.world/apps/mail/lib/IMAP/FolderMapper.php",“line”:60,“function”:“listMailboxes”,“class”:“Horde_Imap_Client_Base”,“type”:"->",“args”:["*",5,{“delimiter”:true,“attributes”:true,“special_use”:true}]},{“file”:"/home//public_html/checkmail.f.world/apps/mail/lib/IMAP/MailboxSync.php",“line”:103,“function”:“getFolders”,“class”:“OCA\Mail\IMAP\FolderMapper”,“type”:"->",“args”:[{“class”:“OCA\Mail\Account”},{“cacheFields”:{“1”:“HICstruct”,“8”:“HIChdrs”,“9”:“HICenv”,“10”:“HICflags”,“11”:“HICdate”,“12”:“HICsize”},“changed”:true,“statuscache”:true,“class”:“Horde_Imap_Client_Socket”}]},{“file”:"/home//public_html/checkmail.f.world/apps/mail/lib/Service/MailManager.php",“line”:127,“function”:“sync”,“class”:“OCA\Mail\IMAP\MailboxSync”,“type”:"->",“args”:[{“class”:“OCA\Mail\Account”},{“class”:“OC\AppFramework\ScopedPsrLogger”}]},{“file”:"/home//public_html/checkmail.f.world/apps/mail/lib/Controller/PageController.php",“line”:119,“function”:“getMailboxes”,“class”:“OCA\Mail\Service\MailManager”,“type”:"->",“args”:[{“class”:“OCA\Mail\Account”}]},{“file”:"/home//public_html/checkmail.f.world/lib/private/AppFramework/Http/Dispatcher.php",“line”:169,“function”:“index”,“class”:“OCA\Mail\Controller\PageController”,“type”:"->",“args”:[]},{“file”:"/home//public_html/checkmail.f.world/lib/private/AppFramework/Http/Dispatcher.php",“line”:100,“function”:“executeController”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Mail\Controller\PageController”},“index”]},{“file”:"/home//public_html/checkmail.f.world/lib/private/AppFramework/App.php",“line”:152,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Mail\Controller\PageController”},“index”]},{“file”:"/home//public_html/checkmail.f.world/lib/private/Route/Router.php",“line”:308,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:"::",“args”:[“OCA\Mail\Controller\PageController”,“index”,{“class”:“OC\AppFramework\DependencyInjection\DIContainer”},{“action”:null,"_route":“mail.page.index”}]},{“file”:"/home//public_html/checkmail.f.world/lib/base.php",“line”:1009,“function”:“match”,“class”:“OC\Route\Router”,“type”:"->",“args”:["/apps/mail/"]},{“file”:"/home//public_html/checkmail.f.world/index.php",“line”:37,“function”:“handleRequest”,“class”:“OC”,“type”:"::",“args”:[]}],“File”:"/home/*/public_html/checkmail.f.world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Socket.php”,“Line”:605},“CustomMessage”:“Could not load account mailboxes: IMAP error: Error connecting to mail server.”},“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36”,“version”:“20.0.0.9”,“id”:“5fab035498532”}

Are you sure the account settings are correct and your Nextcloud server is able to connect to the host and port? Do you use a self-hosted IMAP server with a self-signed certificate?

Thank you for the prompt reply.

When I do a test from https://mydomain/index.php/settings/admin , in the email server settings section and click on " Test email settings “Send email” button. It sends the mail as shown in the screenshot below.

The Nextcloud is on the goDaddy server (https://checkmail.blowfish.world) and the email server is goDaddy. It has handled the certificate.

If you’d lie

that setting has absolutely nothing to do with Mail. It’s nextcloud’s system mail setting. The other one is the account in the email app.

check the admin docs for troubleshooting help https://github.com/nextcloud/mail/blob/master/doc/admin.md

To be even more clear:

Host for nextcloud: Godaddy
Email host: Godaddy
OS: Debian
Apache2
Mysql

I have tried:

  1. Manual IMAP Settings and SMTP settings and have tried “none”, “SSL/TLS” & " StartTls"
  2. Activated error logs and from nextcloud.log i get this error (I have sanitized to hide sensitive info):

{“reqId”:“X6uToknLvQ1l4@o56rlxzQAAiA8”,“level”:3,“time”:“2020-11-11T07:32:56+00:00”,“remoteAddr”:"**.8*.98.13",“user”:"****",“app”:“mail”,“method”:“POST”,“url”:"/index.php/apps/mail/api/accounts",“message”:“Creating account failed: Error when communicating with the server.”,“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36”,“version”:“20.0.0.9”,“id”:“5faba05014550”}

and this error

[mail] Error: OCA\Mail\Exception\ServiceException: IMAP error: Error connecting to mail server. at <>

  1. /home/*****/public_html/checkmail.blowfish.world/apps/mail/lib/Service/MailManager.php line 127
    OCA\Mail\IMAP\MailboxSync->sync(OCA\Mail\Account {}, OC\AppFramework\ScopedPsrLogger {})
  2. /home/*****/public_html/checkmail.blowfish.world/apps/mail/lib/Controller/MailboxesController.php line 92
    OCA\Mail\Service\MailManager->getMailboxes(OCA\Mail\Account {})
  3. /home/*****/public_html/checkmail.blowfish.world/lib/private/AppFramework/Http/Dispatcher.php line 169
    OCA\Mail\Controller\MailboxesController->index(7)
  4. /home/*****/public_html/checkmail.blowfish.world/lib/private/AppFramework/Http/Dispatcher.php line 100
    OC\AppFramework\Http\Dispatcher->executeController(OCA\Mail\Control … {}, “index”)
  5. /home/*****/public_html/checkmail.blowfish.world/lib/private/AppFramework/App.php line 152
    OC\AppFramework\Http\Dispatcher->dispatch(OCA\Mail\Control … {}, “index”)
  6. /home/*****/public_html/checkmail.blowfish.world/lib/private/Route/Router.php line 308
    OC\AppFramework\App::main(“OCA\Mail\Cont … r”, “index”, OC\AppFramework\ … {}, {action: null,_r … "})
  7. /home/*****/public_html/checkmail.blowfish.world/lib/base.php line 1009
    OC\Route\Router->match("/apps/mail/api/mailboxes")
  8. /home/*****/public_html/checkmail.blowfish.world/index.php line 37
    OC::handleRequest()

GET /index.php/apps/mail/api/mailboxes?accountId=7
from 41.80.98.13 by *** at 2020-11-11T07:27:30+00:00

Raw error I will post below.

  1. In my config.php file I have
    ‘log_type’ => ‘file’,
    ‘logfile’ => ‘nextcloud.log’,
    ‘loglevel’ => 3,
    ‘logdateformat’ => ‘F d, Y H:i:s’,
    ‘app.mail.verify-tls-peer’ => false,
  2. The Nextcloud smtp settings (/index.php/settings/admin) the “Email server” settings for smtp works but the Mail App smtp does not work
  3. I have tested the GoDaddy mail settings with this site https://pingability.com/mailtest.jsp. It connects to my email.

PLEASE PLEASE help.

In the raw error log I have noticed “Caused by Horde_Imap_Client_Exception”

The raw error log is below:

{“reqId”:“X6uSYknLvQ1l4@o56rlxhgAAiCM”,“level”:3,“time”:“2020-11-11T07:27:30+00:00”,“remoteAddr”:“41.80.98.13”,“user”:“",“app”:“mail”,“method”:“GET”,“url”:"/index.php/apps/mail/api/mailboxes?accountId=7",“message”:{“Exception”:“OCA\Mail\Exception\ServiceException”,“Message”:“IMAP error: Error connecting to mail server.”,“Code”:11,“Trace”:[{“file”:"/home/ /public_html/checkmail. .world/apps/mail/lib/Service/MailManager.php",“line”:127,“function”:“sync”,“class”:“OCA\Mail\IMAP\MailboxSync”,“type”:"->",“args”:[{“class”:“OCA\Mail\Account”},{“class”:“OC\AppFramework\ScopedPsrLogger”}]},{“file”:"/home/ /public_html/checkmail. .world/apps/mail/lib/Controller/MailboxesController.php",“line”:92,“function”:“getMailboxes”,“class”:“OCA\Mail\Service\MailManager”,“type”:"->",“args”:[{“class”:“OCA\Mail\Account”}]},{“file”:"/home/ /public_html/checkmail. .world/lib/private/AppFramework/Http/Dispatcher.php",“line”:169,“function”:“index”,“class”:“OCA\Mail\Controller\MailboxesController”,“type”:"->",“args”:[7]},{“file”:"/home/ /public_html/checkmail. .world/lib/private/AppFramework/Http/Dispatcher.php",“line”:100,“function”:“executeController”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Mail\Controller\MailboxesController”},“index”]},{“file”:"/home/ /public_html/checkmail. .world/lib/private/AppFramework/App.php",“line”:152,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Mail\Controller\MailboxesController”},“index”]},{“file”:"/home/ /public_html/checkmail. .world/lib/private/Route/Router.php",“line”:308,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:"::",“args”:[“OCA\Mail\Controller\MailboxesController”,“index”,{“class”:“OC\AppFramework\DependencyInjection\DIContainer”},{“action”:null,"_route":“mail.mailboxes.index”}]},{“file”:"/home/ /public_html/checkmail. .world/lib/base.php",“line”:1009,“function”:“match”,“class”:“OC\Route\Router”,“type”:"->",“args”:["/apps/mail/api/mailboxes"]},{“file”:"/home/ /public_html/checkmail. .world/index.php",“line”:37,“function”:“handleRequest”,“class”:“OC”,“type”:"::",“args”:[]}],“File”:"/home/ /public_html/checkmail. .world/apps/mail/lib/IMAP/MailboxSync.php",“Line”:106,“Previous”:{“Exception”:“Horde_Imap_Client_Exception”,“Message”:“Error connecting to mail server.”,“Code”:11,“Trace”:[{“file”:"/home/ /public_html/checkmail. .world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Socket.php",“line”:375,“function”:"_connect",“class”:“Horde_Imap_Client_Socket”,“type”:"->",“args”:[]},{“file”:"/home/ /public_html/checkmail. .world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Base.php",“line”:838,“function”:"_login",“class”:“Horde_Imap_Client_Socket”,“type”:"->",“args”:[" sensitive parameters replaced "]},{“file”:"/home/ /public_html/checkmail. .world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Base.php",“line”:1389,“function”:“login”,“class”:“Horde_Imap_Client_Base”,“type”:"->",“args”:[" sensitive parameters replaced "]},{“file”:"/home/ /public_html/checkmail. .world/apps/mail/lib/IMAP/FolderMapper.php",“line”:60,“function”:“listMailboxes”,“class”:“Horde_Imap_Client_Base”,“type”:"->",“args”:["",5,{“delimiter”:true,“attributes”:true,“special_use”:true}]},{“file”:"/home/ /public_html/checkmail. .world/apps/mail/lib/IMAP/MailboxSync.php",“line”:103,“function”:“getFolders”,“class”:“OCA\Mail\IMAP\FolderMapper”,“type”:"->",“args”:[{“class”:“OCA\Mail\Account”},{“cacheFields”:{“1”:“HICstruct”,“8”:“HIChdrs”,“9”:“HICenv”,“10”:“HICflags”,“11”:“HICdate”,“12”:“HICsize”},“changed”:true,“statuscache”:true,“class”:“Horde_Imap_Client_Socket”}]},{“file”:"/home/ /public_html/checkmail. .world/apps/mail/lib/Service/MailManager.php",“line”:127,“function”:“sync”,“class”:“OCA\Mail\IMAP\MailboxSync”,“type”:"->",“args”:[{“class”:“OCA\Mail\Account”},{“class”:“OC\AppFramework\ScopedPsrLogger”}]},{“file”:"/home/ /public_html/checkmail. .world/apps/mail/lib/Controller/MailboxesController.php",“line”:92,“function”:“getMailboxes”,“class”:“OCA\Mail\Service\MailManager”,“type”:"->",“args”:[{“class”:“OCA\Mail\Account”}]},{“file”:"/home/ /public_html/checkmail. .world/lib/private/AppFramework/Http/Dispatcher.php",“line”:169,“function”:“index”,“class”:“OCA\Mail\Controller\MailboxesController”,“type”:"->",“args”:[7]},{“file”:"/home/ /public_html/checkmail. .world/lib/private/AppFramework/Http/Dispatcher.php",“line”:100,“function”:“executeController”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Mail\Controller\MailboxesController”},“index”]},{“file”:"/home/ /public_html/checkmail. .world/lib/private/AppFramework/App.php",“line”:152,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Mail\Controller\MailboxesController”},“index”]},{“file”:"/home/ /public_html/checkmail. .world/lib/private/Route/Router.php",“line”:308,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:"::",“args”:[“OCA\Mail\Controller\MailboxesController”,“index”,{“class”:“OC\AppFramework\DependencyInjection\DIContainer”},{“action”:null,"_route":“mail.mailboxes.index”}]},{“file”:"/home/ /public_html/checkmail. .world/lib/base.php",“line”:1009,“function”:“match”,“class”:“OC\Route\Router”,“type”:"->",“args”:["/apps/mail/api/mailboxes"]},{“file”:"/home/ /public_html/checkmail. .world/index.php",“line”:37,“function”:“handleRequest”,“class”:“OC”,“type”:"::",“args”:[]}],“File”:"/home/ **/public_html/checkmail.****.world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Socket.php”,“Line”:605},“CustomMessage”:“IMAP error: Error connecting to mail server.”},“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36”,“version”:“20.0.0.9”,“id”:“5faba1851cbd1”}

So I am having the above issues with the Mail app.

Nexcloud system email -> SMTP (email sending only)
Mail app -> IMAP (email retrival) + SMTP (email sending)

Due to the fact that the sendingof email works please provide DETAILED information how you’re trying to configure the mail account in the Mail app. It might be helpful if you post a screenshot of the setting dialog :wink:

Thank you for the prompt reply. So these are the screenshots:

  1. I try to connect and using the wrong SMTP password

Screenshot 2020-11-11 at 13.56.07

And in the logs there is an error of “authentication failed”. So seems like trying to connect is working:

  1. Now with the correct password:
    Screenshot 2020-11-11 at 13.58.38

I have put the security protocol none. In the logs it shows:

and formated log is:

[mail] Error: Creating account failed: Error when communicating with the server.

POST /index.php/apps/mail/api/accounts
from 41.80.98.13 by alkags at 2020-11-11T10:58:32+00:00

and full raw log is:

{“reqId”:“X6vD00nLvQ1l4@o56rl0YgAAhwU”,“level”:3,“time”:“2020-11-11T10:58:32+00:00”,“remoteAddr”:“41.80.98.13”,“user”:“alkags”,“app”:“mail”,“method”:“POST”,“url”:"/index.php/apps/mail/api/accounts",“message”:“Creating account failed: Error when communicating with the server.”,“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36”,“version”:“20.0.0.9”,“id”:“5fabc3d90730c”}

On the config file, the settings are:
Screenshot 2020-11-11 at 14.14.28

I hope this is helpful

As you can see on the screenshot and I already assumed, you’re having a problem with the IMAP configuration of the account (port 143/tcp) and NOT the SMTP configuration (port 587/tcp). Unfortunately you missed to provide these settings.

This screenshot, I purposely put incorrect (wrong) password to see if I get authentication failure from the mail server which I did.

Let me add, when I do auto smtp settings
Screenshot 2020-11-11 at 14.29.58

I get this error:

Notice the “Caused by Horde_Imap_Client_Exception:”

The raw error log:

OCA\Mail\Exception\ServiceException: IMAP error: Error connecting to mail server.

  1. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/apps/mail/lib/Service/MailManager.php - line 127:OCA\Mail\IMAP\MailboxSync->sync(OCA\Mail\Account {}, OC\AppFramew … {})
  2. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/apps/mail/lib/Controller/MailboxesController.php - line 92:OCA\Mail\Service\MailManager->getMailboxes(OCA\Mail\Account {})
  3. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/lib/private/AppFramework/Http/Dispatcher.php - line 169:OCA\Mail\Controller\MailboxesController->index(8)
  4. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/lib/private/AppFramework/Http/Dispatcher.php - line 100:OC\AppFramework\Http\Dispatcher->executeController(OCA\Mail\Con … {}, “index”)
  5. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/lib/private/AppFramework/App.php - line 152:OC\AppFramework\Http\Dispatcher->dispatch(OCA\Mail\Con … {}, “index”)
  6. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/lib/private/Route/Router.php - line 308:OC\AppFramework\App::main(“OCA\Mail\ … r”, “index”, OC\AppFramew … {}, { action: nu … "})
  7. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/lib/base.php - line 1009:OC\Route\Router->match("/apps/mail/api/mailboxes")
  8. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/index.php - line 37:OC::handleRequest()

Caused by Horde_Imap_Client_Exception: Error connecting to mail server.

  1. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Socket.php - line 375:Horde_Imap_Client_Socket->_connect()
  2. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Base.php - line 838:Horde_Imap_Client_Socket->_login("*** sensiti … *")
  3. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client/Horde/Imap/Client/Base.php - line 1389:Horde_Imap_Client_Base->login("*** sensiti … *")
  4. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/apps/mail/lib/IMAP/FolderMapper.php - line 60:Horde_Imap_Client_Base->listMailboxes("*", 5, { delimiter: … e})
  5. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/apps/mail/lib/IMAP/MailboxSync.php - line 103:OCA\Mail\IMAP\FolderMapper->getFolders(OCA\Mail\Account {}, Horde_Imap_C … e})
  6. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/apps/mail/lib/Service/MailManager.php - line 127:OCA\Mail\IMAP\MailboxSync->sync(OCA\Mail\Account {}, OC\AppFramew … {})
  7. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/apps/mail/lib/Controller/MailboxesController.php - line 92:OCA\Mail\Service\MailManager->getMailboxes(OCA\Mail\Account {})
  8. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/lib/private/AppFramework/Http/Dispatcher.php - line 169:OCA\Mail\Controller\MailboxesController->index(8)
  9. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/lib/private/AppFramework/Http/Dispatcher.php - line 100:OC\AppFramework\Http\Dispatcher->executeController(OCA\Mail\Con … {}, “index”)
  10. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/lib/private/AppFramework/App.php - line 152:OC\AppFramework\Http\Dispatcher->dispatch(OCA\Mail\Con … {}, “index”)
  11. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/lib/private/Route/Router.php - line 308:OC\AppFramework\App::main(“OCA\Mail\ … r”, “index”, OC\AppFramew … {}, { action: nu … "})
  12. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/lib/base.php - line 1009:OC\Route\Router->match("/apps/mail/api/mailboxes")
  13. /home/m702yh1eupv8/public_html/checkmail.blowfish.world/index.php - line 37:OC::handleRequest()

Again, testing SMTP isn’t the right way to find the root cause of your IMAP problem, because it is a different protocol and might require different settings. Please use the manual mode to configure the IMAP settings, because the automatic mode fails.

Thank you @j-ed but I did the manual mode, which I have listed the actions I did above including screenshots and the error logs

My glasses seem not to be the best but I can see SMTP settings only, the IMAP settings are still missing. To be clear it should look like this:

You can also enable debug mode temporarily, reproduce the issue and then you’ll find imap and smtp logs in data/horde*.log

Hi everyone,

I am having the same issue and already tried what you suggest, but having no results :confused:

In my case, i am trying to connect a Zoho Mail account, and also tried a Gmail one I got but returning the same: “Unexpected error during account creation”. In both cases, I’ve put the email address correctly in my personal data within the profile.

I’ve checked the data/horde that @ChristophWurst says, and it seems that the Gmail account could conect once, as I can read something in it, but never get anything in the platform.

Wed, 09 Dec 2020 23:02:24 +0000
Connection to: imap://imap.gmail.com:993/
Server connection took 0.1048 seconds.
S: * OK Gimap ready for requests from 185.253.155.236 s1mb72010708wrp
C: 1 CAPABILITY
S: * CAPABILITY IMAP4rev1 UNSELECT IDLE NAMESPACE QUOTA ID XLIST CHILDREN X-GM-EXT-1 XYZZY SASL-IR AUTH=XOAUTH2 AUTH=PLAIN AUTH=PLAIN-CLIENTTOKEN AUTH=OAUTHBEARER AUTH=XOAUTH
S: 1 OK Thats all she wrote! s1mb72010708wrp

Command 1 took 0.0285 seconds.
C: 2 AUTHENTICATE PLAIN [INITIAL CLIENT RESPONSE (username: myemailaccount@gmail.com)]
S: * CAPABILITY IMAP4rev1 UNSELECT IDLE NAMESPACE QUOTA ID XLIST CHILDREN X-GM-EXT-1 UIDPLUS COMPRESS=DEFLATE ENABLE MOVE CONDSTORE ESEARCH UTF8=ACCEPT LIST-EXTENDED LIST-STATUS LITERAL- SPECIAL-USE APPENDLIMIT=35651584
S: 2 OK myemailaccount@gmail.com authenticated (Success)

Command 2 took 0.4033 seconds.

horde_smtp.log doesn’t have nothing inside…

By the way, shouldn’t I get errors in the horde_imap.log?? I am quite confused now haha

…In automatic mode it returns: “Request failed with status code 500”.

The screenshots:

Screen Shot 2020-12-10 at 18.27.17



Last credentials I put my Zoho address, but I changed it for ****'s just to make the screenshot xD

I hope someone can give me a clue :smiley:

Thank you all

In your email server settings you try to send an email using port 465/tcp without having encryption enabled, although the given port only accepts encrypted connections. How should this work?

You are right @j-ed, maybe was a mistake when doing the screenshot.

Unlucky I am still having the same issue. I’ve done various tests double checking the configuration in the mail account app as well, so I guess it must be for another reason

I got a question (and sorry for my ignorance):

Do I have to put my server email configuration (where I’ve got installed the nextcloud) or I can use my Zoho mail account smtp config to send the emails instead?

Maybe it has something to do with my server/nextcloud configuration?

Thanks for helping


This is what I get from horde_imap.log, nothing from horde_smtp.log:

Mon, 14 Dec 2020 16:38:00 +0000
Connection to: imap://imap.zoho.eu:993/
Server connection took 0.0961 seconds.
S: * OK svwall.zoho.com IMAP4 Server (Zoho Mail IMAP4rev1 Server version 1.0)
C: 1 CAPABILITY
S: * CAPABILITY IMAP4rev1 UNSELECT CHILDREN XLIST NAMESPACE IDLE MOVE ID AUTH=PLAIN SASL-IR UIDPLUS ESEARCH LIST-EXTENDED LIST-STATUS WITHIN LITERAL- APPENDLIMIT=10485760 CONDSTORE
S: 1 OK CAPABILITY completed

Command 1 took 0.0315 seconds.
C: 2 AUTHENTICATE PLAIN [INITIAL CLIENT RESPONSE (username: myaccountname@zohomail.eu)]
S: * CAPABILITY IMAP4rev1 UNSELECT CHILDREN XLIST NAMESPACE IDLE MOVE ID AUTH=PLAIN SASL-IR UIDPLUS ESEARCH LIST-EXTENDED LIST-STATUS WITHIN LITERAL- APPENDLIMIT=20971520 CONDSTORE
S: 2 OK Success

Command 2 took 0.0459 seconds.
Slow Command: 5.002 seconds
C: 3 LOGOUT
S: * BYE IMAP4rev1 Server logging out
S: 3 OK Success

Command 3 took 0.0622 seconds.

I just also set up the next config:

‘debug’ => true,
‘mail_smtpdebug’ => true,
‘log_type’ => ‘file’,
‘logfile’ => ‘data/nextcloud.log’,
‘loglevel’ => 0,

What I get:

{
“reqId”:“FWcb7wGDE33K8Ea61oSx”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“contacts”,
“method”:“PUT”,
“url”:"/valpol/index.php/apps/user_status/heartbeat",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“FWcb7wGDE33K8Ea61oSx”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“richdocuments”,
“method”:“PUT”,
“url”:"/valpol/index.php/apps/user_status/heartbeat",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“FWcb7wGDE33K8Ea61oSx”,
“level”:0,“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“encryption”,
“method”:“PUT”,
“url”:"/valpol/index.php/apps/user_status/heartbeat",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“FWcb7wGDE33K8Ea61oSx”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“files_sharing”,
“method”:“PUT”,
“url”:"/valpol/index.php/apps/user_status/heartbeat",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“JZlKjYARrSpeju9HCZDL”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“contacts”,
“method”:“GET”,
“url”:"/valpol/ocs/v2.php/apps/user_status/api/v1/user_status",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“JZlKjYARrSpeju9HCZDL”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“richdocuments”,
“method”:“GET”,
“url”:"/valpol/ocs/v2.php/apps/user_status/api/v1/user_status",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“JZlKjYARrSpeju9HCZDL”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“encryption”,
“method”:“GET”,
“url”:"/valpol/ocs/v2.php/apps/user_status/api/v1/user_status",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“JZlKjYARrSpeju9HCZDL”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“files_sharing”,
“method”:“GET”,
“url”:"/valpol/ocs/v2.php/apps/user_status/api/v1/user_status",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“JZlKjYARrSpeju9HCZDL”,
“level”:3,“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX “,
“user”:“user”,
“app”:“PHP”,
“method”:“GET”,
“url”:”/valpol/ocs/v2.php/apps/user_status/api/v1/user_status”,
“message”:“You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /home/user/public_html/valpol/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”,
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“VyZ7sobc8WweB8xehKu0”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“contacts”,
“method”:“POST”,
“url”:"/valpol/index.php/apps/mail/api/accounts",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“VyZ7sobc8WweB8xehKu0”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“richdocuments”,
“method”:“POST”,
“url”:"/valpol/index.php/apps/mail/api/accounts",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“VyZ7sobc8WweB8xehKu0”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“encryption”,
“method”:“POST”,
“url”:"/valpol/index.php/apps/mail/api/accounts",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“VyZ7sobc8WweB8xehKu0”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“files_sharing”,
“method”:“POST”,
“url”:"/valpol/index.php/apps/mail/api/accounts",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“VyZ7sobc8WweB8xehKu0”,
“level”:1,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“mail”,
“method”:“POST”,
“url”:"/valpol/index.php/apps/mail/api/accounts",
“message”:“Setting up manually configured account”,
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,“version”:“20.0.3.2”
}
{
“reqId”:“VyZ7sobc8WweB8xehKu0”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“mail”,
“method”:“POST”,
“url”:"/valpol/index.php/apps/mail/api/accounts",
“message”:“Connecting to account myaccount@zohomail.eu”,
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“VyZ7sobc8WweB8xehKu0”,
“level”:0,
“time”:“December 14, 2020 17:56:11”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“PHP”,
“method”:“POST”,
“url”:"/valpol/index.php/apps/mail/api/accounts",
“message”:{
“Exception”:“Error”,
“Message”:“stream_socket_client(): unable to connect to ssl://smtp.zoho.eu:465 (Connection timed out) at /home/user/public_html/valpol/apps/mail/vendor/pear-pear.horde.org/Horde_Socket_Client/Horde/Socket/Client.php#293”,
“Code”:0,
“Trace”:[{“function”:“onAll”,
“class”:“OC\Log\ErrorHandler”,
“type”:"::",
“args”:[2,“stream_socket_client(): unable to connect to ssl://smtp.zoho.eu:465 (Connection timed out)”,
“/home/user/public_html/valpol/apps/mail/vendor/pear-pear.horde.org/Horde_Socket_Client/Horde/Socket/Client.php”,
293,
{
“host”:“smtp.zoho.eu”,
“port”:465,
“timeout”:5,
“secure”:“ssl”,
“context”:{
“ssl”:{
“verify_peer”:true,
“verify_peer_name”:true
}
},
“retries”:0,
“conn”:“ssl://smtp.zoho.eu:465”,
“error_number”:0,
“error_string”:""
}
]},
{
“file”:"/home/user/public_html/valpol/apps/mail/vendor/pear-pear.horde.org/Horde_Socket_Client/Horde/Socket/Client.php",
“line”:293,
“function”:“stream_socket_client”,
“args”:[“ssl://smtp.zoho.eu:465”,0,"",5,4,null]},
{“file”:"/home/user/public_html/valpol/apps/mail/vendor/pear-pear.horde.org/Horde_Socket_Client/Horde/Socket/Client.php",
“line”:106,
“function”:"_connect",
“class”:“Horde\Socket\Client”,
“type”:“→”,
“args”:[“smtp.zoho.eu”,465,5,“ssl”,{“ssl”:{“verify_peer”:true,“verify_peer_name”:true}}]},{
“file”:"/home/user/public_html/valpol/apps/mail/vendor/pear-pear.horde.org/Horde_Smtp/Horde/Smtp.php",
“line”:379,
“function”:"__construct",
“class”:“Horde\Socket\Client”,
“type”:“→”,
“args”:[“smtp.zoho.eu”,465,5,“ssl”,
{
“ssl”:{
“verify_peer”:true,
“verify_peer_name”:true
}
},
{
“debug”:{
“active”:true,
class”:“Horde_Smtp_Debug”
}
}
]
},
{
“file”:"/home/user/public_html/valpol/apps/mail/vendor/pear-pear.horde.org/Horde_Mail/Horde/Mail/Transport/Smtphorde.php",
“line”:160,
“function”:“login”,
“class”:“Horde_Smtp”,
“type”:"->",“args”:[“sensitive parameters replaced”]
},
{
“file”:"/home/user/public_html/valpol/apps/mail/lib/Account.php",
“line”:233,
“function”:“getSMTPObject”,
“class”:“Horde_Mail_Transport_Smtphorde”,
“type”:“→”,
“args”:[]
},
{
“file”:"/home/user/public_html/valpol/apps/mail/lib/Service/SetupService.php",
“line”:128,
“function”:“testConnectivity”,
“class”:“OCA\Mail\Account”,“type”:“→”,
“args”:[
{
“send8bit”:false,
“sep”:"\r\n",
class”:“Horde_Mail_Transport_Smtphorde”}
]
},
{
“file”:"/home/user/public_html/valpol/apps/mail/lib/Controller/AccountsController.php",
“line”:328,
“function”:“createNewAccount”,
“class”:“OCA\Mail\Service\SetupService”,
“type”:“→”,
“args”:[
“user”,
“myaccount@zohomail.eu)”,
“imap.zoho.eu”,
993,
“ssl”,
“myaccount@zohomail.eu)”,
“MYPASSWD”,
“smtp.zoho.eu”,
465,
“ssl”,
“myaccount@zohomail.eu)”,
“MYPASSWD”,
“user”
]
},
{
“file”:"/home/user/public_html/valpol/lib/private/AppFramework/Http/Dispatcher.php",
“line”:169,
“function”:“create”,
“class”:“OCA\Mail\Controller\AccountsController”,
“type”:“→”,
“args”:[
“user”,
“myaccount@zohomail.eu)”,
null,
“imap.zoho.eu”,
993,
“ssl”,
“myaccount@zohomail.eu)”,
“MYPASSWD”,
“smtp.zoho.eu”,
465,
“ssl”,
“myaccount@zohomail.eu)”,
MYPASSWD”,
false]},
{
“file”:"/home/user/public_html/valpol/lib/private/AppFramework/Http/Dispatcher.php",
“line”:100,
“function”:“executeController”,
“class”:“OC\AppFramework\Http\Dispatcher”,
“type”:“→”,
“args”:[{“class”:“OCA\Mail\Controller\AccountsController”},
“create”]},
{
“file”:"/home/user/public_html/valpol/lib/private/AppFramework/App.php",
“line”:152,
“function”:“dispatch”,
“class”:“OC\AppFramework\Http\Dispatcher”,
“type”:“→”,
“args”:[{“class”:“OCA\Mail\Controller\AccountsController”},
“create”]},
{
“file”:"/home/user/public_html/valpol/lib/private/Route/Router.php",
“line”:308,
“function”:“main”,
“class”:“OC\AppFramework\App”,
“type”:"::",
“args”:[“OCA\Mail\Controller\AccountsController”,
“create”,
{“class”:“OC\AppFramework\DependencyInjection\DIContainer”},{“action”:null,
“_route”:“mail.accounts.create”
}
]
},
{
“file”:"/home/user/public_html/valpol/lib/base.php",
“line”:1008,
“function”:“match”,
“class”:“OC\Route\Router”,
“type”:“→[
“super”,
“myaccount@zohomail.eu)”,
“imap.zoho.eu”,
993,
“ssl”,
“myaccount@zohomail.eu)”,
“MYPASSWD”,
“smtp.zoho.eu”,
465,
“ssl”,
“myaccount@zohomail.eu)”,
“MYPASSWD”,
“super”]
},
{
“file”:”/home/user/public_html/valpol/lib/private/AppFramework/Http/Dispatcher.php",
“line”:169,
“function”:“create”,
“class”:“OCA\Mail\Controller\AccountsController”,
“type”:“→”,
“args”:[
“super”,
“myaccount@zohomail.eu)”,
null,
“imap.zoho.eu”,
993,
“ssl”,
“myaccount@zohomail.eu)”,
“MYPASSWD”,
“smtp.zoho.eu”,
465,
“ssl”,
“myaccount@zohomail.eu)”,
“MYPASSWD”,
false
]
},
{
“file”:"/home/user/public_html/valpol/lib/private/AppFramework/Http/Dispatcher.php",
“line”:100,
“function”:“executeController”,
“class”:“OC\AppFramework\Http\Dispatcher”,
“type”:“→”,
“args”:[{“class”:“OCA\Mail\Controller\AccountsController”},
“create”
]
},
{
“file”:"/home/user/public_html/valpol/lib/private/AppFramework/App.php",
“line”:152,
“function”:“dispatch”,
“class”:“OC\AppFramework\Http\Dispatcher”,
“type”:“→”,
“args”:[{“class”:“OCA\Mail\Controller\AccountsController”},
“create”]},
{
“file”:"/home/user/public_html/valpol/lib/private/Route/Router.php",
“line”:308,
“function”:“main”,
“class”:“OC\AppFramework\App”,
“type”:"::",
“args”:[“OCA\Mail\Controller\AccountsController”,
“create”,
{
class”:“OC\AppFramework\DependencyInjection\DIContainer”},
{“action”:null,"_route":“mail.accounts.create”}]},
{“file”:"/home/user/public_html/valpol/lib/base.php",
“line”:1008,
“function”:“match”,
“class”:“OC\Route\Router”,
“type”:“→”,
“args”:["/apps/mail/api/accounts"]},
{“file”:"/home/user/public_html/valpol/index.php",
“line”:37,
“function”:“handleRequest”,
“class”:“OC”,
“type”:"::",
“args”:[]}],
“File”:"/home/user/public_html/valpol/lib/private/Log/ErrorHandler.php",
“Line”:98,
“CustomMessage”:"—"},
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“VyZ7sobc8WweB8xehKu0”,
“level”:3,
“time”:“December 14, 2020 17:56:11”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“mail”,
“method”:“POST”,
“url”:"/valpol/index.php/apps/mail/api/accounts",
“message”:“Creating account failed: Error connecting to SMTP server.”,
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“zIQtReceGZLn01Z4Oqk8”,
“level”:0,
“time”:“December 14, 2020 17:56:16”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“contacts”,
“method”:“GET”,
“url”:"/valpol/ocs/v2.php/apps/notifications/api/v2/notifications",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,“version”:“20.0.3.2”
}
{
“reqId”:“zIQtReceGZLn01Z4Oqk8”,
“level”:0,
“time”:“December 14, 2020 17:56:16”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“richdocuments”,
“method”:“GET”,
“url”:"/valpol/ocs/v2.php/apps/notifications/api/v2/notifications",
“message”:"/appinfo/app.php is deprecated,
use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“zIQtReceGZLn01Z4Oqk8”,
“level”:0,
“time”:“December 14, 2020 17:56:16”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“encryption”,
“method”:“GET”,
“url”:"/valpol/ocs/v2.php/apps/notifications/api/v2/notifications",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,“version”:“20.0.3.2”}
{
“reqId”:“zIQtReceGZLn01Z4Oqk8”,
“level”:0,
“time”:“December 14, 2020 17:56:16”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“files_sharing”,
“method”:“GET”,
“url”:"/valpol/ocs/v2.php/apps/notifications/api/v2/notifications",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,“version”:“20.0.3.2”
}
{
“reqId”:“zIQtReceGZLn01Z4Oqk8”,
“level”:3,
“time”:“December 14, 2020 17:56:16”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“PHP”,
“method”:“GET”,
“url”:"/valpol/ocs/v2.php/apps/notifications/api/v2/notifications",
“message”:“You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /home/user/public_html/valpol/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”,
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
} instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”}
{
“reqId”:“VyZ7sobc8WweB8xehKu0”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“encryption”,
“method”:“POST”,
“url”:"/valpol/index.php/apps/mail/api/accounts",
“message”:"/appinfo/app.php is deprecated,
use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}
{
“reqId”:“VyZ7sobc8WweB8xehKu0”,
“level”:0,
“time”:“December 14, 2020 17:56:05”,
“remoteAddr”:“XX.XXX.XXX.XX”,
“user”:“user”,
“app”:“files_sharing”,
“method”:“POST”,
“url”:"/valpol/index.php/apps/mail/api/accounts",
“message”:"/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.",
“userAgent”:“Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:84.0) Gecko/20100101 Firefox/84.0”,
“version”:“20.0.3.2”
}

Maybe it could help :confused:

Thanks!

Your internet connection (or the one of the server) is slow. Try increasing the timeouts: https://github.com/nextcloud/mail/blob/master/doc/admin.md#imap-timeout

1 Like