macOS Client can't connect

I just migrated my owncloud 8 server to nextcloud 9, and after that upgraded finally to nextcloud 11. Everything works (no errors on admin page) and all clients connect and sync fine (the previously installed owncloud client on this mac just started syncing on it’s own when the nextcloud 11 server was up), except the mac OS client.

I get this:

Any hints how to troubleshoot this?

I would look at the Apache log files, as well as the Nextcloud log file.

Have you tried from different mac computer? Also try typing the full site

I’m not shure that a cross update from NC 9 to 11 will work. I have in my mind that they have introduced that only since version 11, but correct me if i’m wrong.

I don’t think that’s the issue. I’m guessing typing the full URL didn’t work?

yes, same on different Mac and also on Win7 the same error. Already tried full site name.

It was not a cross update. I updated from NC9 to 10, and after that to 11.

I’m using nginx Server with a Gateway host. In the nginx log I have an error for the special routing to remote.php (but I think the remote.php is only used for calDAV/cardDAV access?). It shows no errors for reaching the status.php (which the Desktop-Client is trying to reach). Accessing the status.php from a webbrowser works too.

I got a similar error. Without the protocol it defaults to https did you try If you are not running SSL.

I’m running SSL (with valid certificate from Letsencrypt) and my Gateways host redirects all non-SSL requests (coming from Port 80) to SSL (port 443)

Did you set up Strict-Transport-Security?

Yes, HSTS is active, why?


I’ve got some stupid errors without that…

I just tested a bit around. The Windows-Client does the same error. Setting up the ownCloud Client on a new machine works just fine. So it must be something special in the nc client


I have tested your link.

My client don’t work too. But if I connect with my own server -> it works

What i found:
your link:
my link:

Maybe something in the .htaccess or Documentroot path

Apache or Nginx?


Interesting thought. The .htaccess is the one that came with the nextcloud-files, so what could be wrong in there?

The most reasonable culprit would be the virtual host configuration, however when I open the files in the main directory in a browser, I receive what I accessed.

Navigate to this page

type Ctrl-F in your browser and enter clean urls

1 Like

When I specify ‘htaccess.RewriteBase’ => ‘/’, I get a blank page when I open in browser

I also tried the other values under Proxy Configurations with the same result (I tested always only one of them, not all together)


I tryed it out. ‘htaccess.RewriteBase’ => ‘/’, in my case doesn’t work too.
In additional, I tried with .htaccess config. -> I let my installation on default.

Maybey a weird try, but with owncloud client Version 2.2.4 (build 3709) -> it works :slight_smile:
-> but i haven’t a user :wink:

yes I know, I’m currently using the owncloud-Client since this works fine. But I want to find the solution why the NC-Client does not work because my Cal/CardDAV access from MacOS doesn’t work too and I assume it’s for the same reason.

With the DAV-access I found a weird entry in nginx-log: The requested adress is: /var/www/index.php/

The NC-setup must have taken this piece of address ( from the previous owncloud-Installation (for this old installation that was the correct path, however my NC-Installation is /var/www without a subdirectory), however I have no idea where I can change this


Can you show us your nginx config-file? /etc/nginx/sites-available/ -> location

/var/www/ -> still exists?