Local storage Question

missing_information
nc14
local_storage
#1

Basic question, where on Nextcloud 14 would I find where the sync files are stored? NC is running on ubuntu. Thanks

0 Likes

#2

If not configured otherwise, all data files are store inside the data folder in your NC install folder - probably /var/www/…

0 Likes

#3

@budy
I have 6.2gb of data I want to keep in sync with NC After 2.5GB uploaded I get “Your storage is full files can not be updated or synced anymore!” When I acccess the path to the data on NC I get “ls cannot access var www netcloud No such file or directory” The nextcloud folder is there so i’m sure its just due to permissions.

My goal is to clean out all the user files and start clean. I have deleted everything from both the “Files” section and the “Deleted Files” sections of the NC UI so I cant see why after only 2.5GB I get this error.

My questions:
1)What minimum level of permissions shoud I change the netcloud folder too to be able to accomplish the cleaning?
2) Is deleteing the files is the best approach to solve this problem?

If there is an existing link please forward?

Thanks for taking the time to read my questions.

0 Likes

#4

I forgot to mention all users (3) have Unlimitied Quota set. Thanks again!

0 Likes

#5

That’s hard to say, without knowing your setup. You can find the actual path to your uploaded files in the config.php, which resides in the config folder in your nextcloud folder. Try this, while adjusting the path to your nextcloud installation folder accordingly:

grep -i datadirectory /var/www/nextcloud/config/config.php

This should print out the folder, where your files are stored. Once we get that, we can go from there.

1 Like

#6

Hi budy, getting back to this. This is what I get when I run the command grep: /var/www/nextcloud/config/config.php: Permission denied. I am logging in as ncadmin.

Thanks

0 Likes

#7

For whatever reasons, the permissions on your files are wrong, if you can access them even read-only. What’s the output of

ls -l /var/www/nextcloud/

0 Likes

#8

Stephan,

Here is what I get:

ncadmin@cloud:~$ ls -l /var/www/nextcloud/

ls: cannot open directory ‘/var/www/nextcloud/’: Permission denied

After the space issue, after logging in I now get:

0 Likes

#9

Then you will have to work your way up - and you will need to be able to become the root user, otherwise you won’t be able to change permissions, once you figured out, what went wrong.

Try these:

ls -l /var/
ls -l /var/www/
0 Likes

#10

Stephan,

For the ls -l /var/ command I get:

ncadmin@cloud:~$ ls -l /var/

total 64

drwxr-xr-x  2 root root   4096 Feb  9 06:25 backups

drwxr-xr-x 16 root root   4096 Nov 24 19:30 cache

drwxrwxrwt  2 root root   4096 Feb 12 07:40 crash

drwxr-xr-x 54 root root   4096 Nov 24 19:44 lib

drwxrwsr-x  2 root staff  4096 Apr 24  2018 local

lrwxrwxrwx  1 root root      9 Oct 16 11:55 lock -> /run/lock

drwxrwxr-x 14 root syslog 4096 Feb 12 07:40 log

drwxrwsr-x  2 root mail   4096 Nov 24 19:44 mail

drwxr-xr-x  4 root root   4096 Feb  8 22:19 NCBACKUP

drwxr-xr-x  5 root root   4096 Feb  8 22:19 NCBACKUP-OLD

drwxr-xr-x  2 root root   4096 Jul 24  2018 opt

lrwxrwxrwx  1 root root      4 Oct 16 11:55 run -> /run

drwxr-xr-x  3 root root   4096 Feb  8 22:31 scripts

drwxr-xr-x  2 root root   4096 Jul 19  2018 snap

drwxr-xr-x  6 root root   4096 Nov 24 19:44 spool

drwxrwxrwt  6 root root   4096 Feb 12 08:39 tmp

drwx------  3 root bin    4096 Feb  8 21:29 webmin

drwxr-xr-x  4 root root   4096 Feb  8 22:20 www
0 Likes

#11

How about to run this command instead:

sudo grep -i datadirectory /var/www/nextcloud/config/config.php

this will give you access to config file if it is in /var/www/nextcloud. Output will show you where is your data saved. Example:

 sudo grep -i datadirectory /var/www/nextcloud/config/config.php
'datadirectory' => '/var/www/nextcloud/data',

Did you install NC with snap, docker or manually?
I suppose you use snap, in this case if you run ps -ef | grep nextcloud command you will see similar output as in this comment: How to: change data directory in nextcloud snap. In this case your data folder is probably under: /var/snap/nextcloud/common/nextcloud/data.

0 Likes

#12

Stephan, I ran the command and get:
ncadmin@cloud:~$ sudo grep -i datadirectory /var/www/nextcloud/config/config.php
[sudo] password for ncadmin:
‘datadirectory’ => ‘/mnt/ncdata’,

the df command shows:

ncadmin@cloud:~$ df
Filesystem                     1K-blocks    Used Available Use% Mounted on
udev                             1977132       0   1977132   0% /dev
tmpfs                             401584    1284    400300   1% /run
/dev/mapper/nextcloud--vg-root  39990560 9435272  28494184  25% /
tmpfs                            2007904       8   2007896   1% /dev/shm
tmpfs                               5120       0      5120   0% /run/lock
tmpfs                            2007904       0   2007904   0% /sys/fs/cgroup
ncdata                           3378304 3378304         0 100% /mnt/ncdata
tmpfs                             401580       0    401580   0% /run/user/1000

This installation was a VM purchase from @enoch85. I though this would be the easiest way to get running for a Windows guy like me.

0 Likes

#13

Would it hurt to follow this link? I don’t think it will help with NC but good general practice?

Thanks!

0 Likes

#14

I have 6.2gb of data I want to keep in sync with NC After 2.5GB uploaded I get “Your storage is full files can not be updated or synced anymore!”

It might be that the appdata folder is very large, or that you (or your users) didn’t remove files stored in trashbin.

Set trashbin retention in config.php. You can find examples here: https://docs.nextcloud.com/server/15/admin_manual/configuration_server/config_sample_php_parameters.html#deleted-items-trash-bin

That’s a start at least.

0 Likes

#15

Hi Daniel,

Thanks for chiming in again!.. I will review the doc but have already ran:

sudo -u www-data /var/www/nextcloud/occ trashbin:cleanup --all-users

sudo -u www-data /var/www/nextcloud/occ versions:cleanup

and cleaned this up.

Am I missing something?

Thanks

0 Likes

#16

Sorry, I don’t know all the ‘occ’ commands from the top of my head, but you can always check the docs.

Also, when using the VM you can use ‘nextcloud_occ actual:command’ instead if writing the whole path. :slight_smile:

0 Likes

#17

So I was able to peck around the file system till i found where the data is kept. I thought there would be extraneous file not synced but its all good. I also searched around looking for appdata solutions. I came across this, Screwed up data/appdata_instanceid

Think following this will fix my issue? Right now my system is completely down :frowning:

Thanks!

0 Likes

#18

Is your problem in appdata directory? Run command to find out what is your biggest folder is (ask ubuntu):

du -ah --max-depth=1  /mnt/ncdata | sort -hr

than you can check what is the biggest folder under the biggest folder and decide what to do next.

0 Likes

#19

@gas85, Thanks for your help! I was about to give up. The output from the command is:

ncadmin@cloud:~$ sudo du -ah --max-depth=1  /mnt/ncdata | sort -hr
[sudo] password for ncadmin:
3.3G    /mnt/ncdata
2.6G    /mnt/ncdata/dtorres
633M    /mnt/ncdata/appdata_ocm2710gjvgh
11M     /mnt/ncdata/ncadmin
11M     /mnt/ncdata/jtorres
11M     /mnt/ncdata/datorres
213K    /mnt/ncdata/files_external
65K     /mnt/ncdata/nextcloud.log
4.5K    /mnt/ncdata/updater.log
4.5K    /mnt/ncdata/.htaccess
512     /mnt/ncdata/updater-ocm2710gjvgh
512     /mnt/ncdata/.ocdata
512     /mnt/ncdata/index.html

From what i know, I don’t see any problems with space. I am also now getting this error after logging in:

Internal Server Error
The server was unable to complete your request.
If this happens again, please send the technical details below to the server administrator.
More details can be found in the server log.
Technical details
Remote Address: XX.XX.XX.XX
Request ID: fWbbCMp5M41PsU7fz9k1

Ugh!! So frustrating!

0 Likes

#20

Update

I’m getting cert errors, due to network connection problems over port 80. Should be getting fixed very soon.

File sync is oddly working fine :slight_smile:

0 Likes