Local external storage not working


I try to setup an external local storage.
I add a “local” storage unter “/media/Daten/” … but if I try to generate a file, I get “file could not created” … and if I put a file with ssh … he don´t dislay it.

The path is correct … because when I set a wrong, he give me a red icon.
I also set the folder in Linux to 777 … but not able to use it in nextCloud

So how has I setup my folder in Ubuntu Server 16.x to get local access with nextCloud?

Thank you!


I was now able to setup a path which is working. I installed nextcloud with SNAP … so I add here a path:

here I can setup a SAMBA Share and add the folder to nextcloud.

Any file will be written as root … can I set in nextcloud which user/usergroup he take from Linux, when I add/modify files at a external storage?

Or is the problem, that I installed nextcloud as root user with SNAP?

Thank you!

Use the external storage plugin, and don’t create shares inside your Nextcloud data folder.


for external storage:
I tried to add a folder from “/daten” … icon goes red
I tried to add a folder from “/media/daten” icon goes gree,. but could nor read or write any file
I mount a folder in “/media/daten” and tried to add this as external storage … icon goes green, but not able to read/write a file

I just have success when I add a folder from /var/snap/nextcloud/common/nextcloud/data/

File permission for /daten or /media/daten are:

Maybe an apache permission problem?

Thank you!

I found now this:

The user in a snap is root, but your problem is that you’re probably trying to access data located outside of the snap, which is not allowed unless you run the snap in dev mode, which is not recommended.

Thats a problem … it means, I`m not able to access any folder/file outside my snap folder

Samba I was not able to use in a snap installation

I don’t think that’s the problem, and I’d lean more on the permissions, but as I’m not sure I’ll ping @kyrofa

I’m not 100% sure what you’re trying to do here, but a few thoughts:

  1. Samba is not yet supported in the snap (armhf keeps breaking, we’re working on it)
  2. If you’re using a location out of the snap, you need to connect the right plug. More info here.
1 Like

Looks to me like accessing data with the external storage plugin on the local machine…
It’s not clear where SAMBA comes into it though, beyond creating shares from within the data folder (please don’t do this).