Linux packages status


#44

The link is leading to 404.
Please change it to https://uappexplorer.com/snap/ubuntu/nextcloud


#45

Thank you, we updated the link.


#46

We just added an app image for Linux to our download page by default. It requires nothing to install so it seems the solution for those who don’t have a distribution with packages.


#47

The above instructions worked for me where morph027’s did not (it installed without error but trying to run resulted in this error: “nextcloud: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21’ not found (required by nextcloud)”).

I definitely prefer a package manager to an app image, and perhaps the instructions there using ivaradi’s repositories on opensuse could be made the recommended instructions for Debian.

Here they are as i used them, for Debian 8 (the version of Debian for Linux Mint Debian Edition 2), slightly modified to use sudo rather than requiring switching to the root user:

echo 'deb http://download.opensuse.org/repositories/home:/ivaradi/Debian_8.0/ /' | sudo tee /etc/apt/sources.list.d/nextcloud-client.list
wget -q -O - http://download.opensuse.org/repositories/home:/ivaradi/Debian_8.0/Release.key | sudo apt-key add -
sudo apt-get update
sudo apt-get install nextcloud-client

#48

I think the first post should better distinguish between client and server packages and between Ubuntu and Debian. For example, the launchpad repo only seems to provide Ubuntu packages? Also the client Xenial package from @morph027 seems not to work for under Debian either. So I was using the packages from @ivaradi but really wanted to have Dolphin integration. Unfortunately the AppImage did not work either under Debian (maybe someone else can test it before I file a bug about this?) and maybe it neither provides the integration…

When the opensuse download server went down a few days ago I took the occasion to learn and built my own packages for Debian 9 Stretch. They are available at https://m4lvin.github.io/nextcloud-client-debian-packaging/ without any warranty :wink: but full transparency because build and deployment happens publicly on travis-ci.org.


#49

@m4lvin you’re entirely correct, part of the problem is that I don’t know exactly what is where etc. Would you be willing to make a little piece of text that describes the situation correctly for debianites & Ubuntians which I can put in the first post?


#50

The Nextcloud client is now also available as a flatpak package: Desktop client is now available on flathub

@jospoortvliet It would be great if you could also add that to the first post.


#51

Here is an attempt at summarizing the state of Debian and Ubuntu packaging.


#52

I’ve updated the first post with your info, thanks a LOT!

You just helped literally thousands of users who will be clicking those links the coming weeks :wink:


#54

@James_Hogarth was wondering about the Fedora EPEL state - the package there is at 10.0.4, that is rather horribly outdated :wink: any problems we should know about or help with and should we even still point people there?


#55

Note that sudo snap install nextcloud-client should work these days as well. By default, confinement doesn’t allow access to the keyring, so you’ll need to connect that interface if you want it to save passwords in your login keyring:

$ sudo snap connect nextcloud-client:password-manager-interface

#56

I guess the first post needs to be updated again. @morph027 seems to no longer supply server packages and I couldn’t find any client package for debian, either.


#57

Huh … still serving my repo. But as pointed out already, it’s basically a re-pack of the tgz, no fancy elves inside. Just uploaded 12.0.3


#58

The server packages are still there as @morph027 wrote, what exactly made you think they are gone?

For client packages, not that currently @morph027 only has packages for Ubuntu, and afaik they do not work on Debian. See the packages by ivaradi or mine (just updated to 2.3.3).


#59

I think I see my error - I clicked on the link, saw a “Debian” link, thought that contain everything related to to Debian and ignored the “nextcloud” tab I already was on.

Dang, do I feel stupid now…
(Sorry for any confusion I may have caused.)


#60

Hello m4lvin,

i use your howto and repo
But i got errors on installing / upgrade my nextcloud client:

root@nas:/$ env -u LANGUAGE LC_ALL=C aptitude upgrade
Resolving dependencies...
The following packages will be upgraded:
  nextcloud-client
1 packages upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/1980 kB of archives. After unpacking 7006 kB will be used.
Do you want to continue? [Y/n/?]
Reading changelogs... Done
(Reading database ... 182528 files and directories currently installed.)
Preparing to unpack .../nextcloud-client_2.3.3-m4lvin-201711161810_amd64.deb ...
Unpacking nextcloud-client (2.3.3-m4lvin-201711161810) over (2.3.2-20170823.130651) ...
dpkg: error processing archive /var/cache/apt/archives/nextcloud-client_2.3.3-m4lvin-201711161810_amd64.deb (--unpack):
 trying to overwrite '/etc/Nextcloud/sync-exclude.lst', which is also in package libnextcloudsync0 2.3.2-20170823.130651
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/nextcloud-client_2.3.3-m4lvin-201711161810_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@nas:/$

I have try to rename the file, the same. Using apt-get -f install no change.
System is Debian 9.2 64bit (up to date).

Ah, i see, i have mixed the repos, first i use the ivaradi repo. Just remove the repo from m4lvin.

Sorry, but i think, the repo from m4lvin is MUCH better documented. @ivaradi a normal user cant find your mirror.


#61

Sorry for the late answer, I am not here that often and the forum did not notify me…

Your aptitude log looks like you first should remove the packages from the other repository.

In my repository there is only one package called nextcloud-client which contains everything. In others repositories some things are split into a libnextcloudsync0 package. So if you (or others reading this…) want to install my package you should apt-get remove --purge libnextcloudsync0 before.

(If I understand correctly, a better solution would be to list libnextcloudsync0 in the Provides or Conflicts field of my package. I might fix this with the next release.)


#62

Hey I tried the snap install for nextcloud on linux mint 18.3 and everything seemed to install. However, I can’t seem to get it running… is there a newbe step-by-step that might help? At this point a I installed apache2 with mysql using bitnami and it works - but, there is no package for “nextcloud”. I’ve tried downloading and installing separately but I can’t get past the user access permissions issues event though I go a root in the terminal and assign 775, etc

Any ideas to get nextcloud working?


#63

@donshepard please log an issue here if you need help with the snap.


#64

The Debian client repository at http://download.opensuse.org/repositories/home:/ivaradi/ does not seem to work for me on Raspberry Pi 2 (with Rasbian-jessie). I used the instructions for Debian 8 given on https://software.opensuse.org//download.html?project=home%3Aivaradi&package=nextcloud-client and I got the same error as reported in Nextcloud client on Raspbian.

I did successfully install nextcloud client on Raspberry Pi 2 using the build instructions at https://github.com/nextcloud/client_theming#building-on-debian .