Link Freigabe http/https

Hallo zusammen,
ich habe einen Nextcloud 11.0.1 Server und einen Nexcloud 2.2.4 Client. Wenn ich über den Explorer per Rechtsklick - Kontextmenü - “via Nexcloud teilen” einen Link aus dem Nextcloud Verzeichnis freigebe, dann enthält der Link nur http, gebe ich den Link über die Nextcloud WebUI frei, dann steht da ein https davor. Ich würde aber gerne über den Client auch ein https stehen haben.
An welcher Schraube muss ich denn hier drehen?
Danke im Voraus.

Gruß

Michael

Hat niemand eine Idee, warum im Client nur http steht? :sweat:

poste mal deine config.php

<?php

$CONFIG = array (
‘instanceid’ => ‘xxxxxxxxxxxxxxxxxxx’,
‘passwordsalt’ => ‘xxxxxxxxxxxxxxxxxxx’,
‘secret’ => ‘xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx’,
‘trusted_domains’ =>
array (
0 => ‘10.132.2.18’,
1 => ‘sub.domain.de’,
2 => ‘132SRV18’,
3 => ‘132SRV18.domain.local’,
4 => ‘132srv18’,
5 => ‘132srv18.domain.local’,
),
‘datadirectory’ => ‘/var/www/nextcloud/data’,
‘overwrite.cli.url’ => ‘http://10.132.2.18/nextcloud’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘11.0.2.7’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘localhost’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘admin’,
‘dbpassword’ => ‘keines’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
‘ldapIgnoreNamingRules’ => false,
‘mail_from_address’ => ‘Nextcloud’,
‘mail_smtpmode’ => ‘smtp’,
‘mail_domain’ => ‘domain.de’,
‘mail_smtphost’ => ‘10.132.2.3’,
‘mail_smtpport’ => ‘25’,
‘updater.release.channel’ => ‘stable’,
‘maintenance’ => false,
‘loglevel’ => 2,
‘ldapProviderFactory’ => ‘\OCA\User_LDAP\LDAPProviderFactory’,
‘updater.secret’ => ‘xxxxxxxxxxxxxxxxxxxxxxxxxxxxx’,
);

ändere mal

in
'overwrite.cli.url' => 'https://10.132.2.18/nextcloud',

und füge das hier noch hinzu:
'overwriteprotocol' => 'https',

1 Like

Vielen Dank für die Hilfe. Das hat funktioniert!! Auch wenn ich den Zusammenhang nicht wirklich verstehe. Im WebUI hat es ja schon vorher funktioniert, nur eben im Cliet nicht!?
Wurscht. Jetzt geht es. Nochmals vielen Dank!!!

siehe: https://docs.nextcloud.com/server/11/admin_manual/configuration_server/config_sample_php_parameters.html

'overwrite.cli.url' => ' ',
Use this configuration parameter to specify the base URL for any URLs which are generated within Nextcloud using any kind of command line tools (cron or occ). The value should contain the full base URL: https://www.example.com/nextcloud

'overwriteprotocol' => ' ',
When generating URLs, Nextcloud attempts to detect whether the server is accessed via https or http. However, if Nextcloud is behind a proxy and the proxy handles the https calls, Nextcloud would not know that ssl is in use, which would result in incorrect URLs being generated.
Valid values are http and https

Markiere doch bitte die obere Antwort als Lösung, damit man gleich sieht, dass dein Problem damit gelöst wurde. :wink:

1 Like

Wenn man das so liest, klingt es schon logisch. Wenn man aber nach einer Lösung für sein Problem sucht, weiß man nicht wonach man eigentlich suchen soll… :wink:

1 Like