Let's encrypt does not work correctly


I have a new installation, Debian 10 x86_64 + curl installation.

Let’s encrypt request the certificates and they are downloded.
The apache server conrinues to use the self-signed certificates.
Everything is configured but the Apache server not.



Hello @vascocb ,

maybe you could check the following topic and solution


Did not worked
After the update and run letsencrypt the path is good but the apache server does not work

what is the output from sudo systemctl status apache2 for you?

Ihave the same issue but from within a docker container.

root@nextcloudpi:/var/log/apache2# service apache2 status
[ ok ] apache2 is running.

For me the ncp.conf did not contain the correct path to the certificates. Changing that solved it for me: Upgrading to NC21 on docker fails to add docker IP to trusted proxies - HPB cannot be enabled · Issue #1345 · nextcloud/nextcloudpi · GitHub

yes that should be fixed by now