LDAP connexion set lot of ldap control paged result response at log

Hi

I configure LDAP authentification.
All work find.

But when i look at log page i see lot of line like :

Error PHP ldap_control_paged_result_response(): No server controls in result at /var/www/html/nextcloud/apps/user_ldap/lib/LDAP.php#74

And i get lots of this line each LDAP connexion.

What can cause this problem? ( I read something about $cookie but nothing about how to debug this problem)

cordialy

Hi

I’m looking for a way to get value return by LDAP request to see why nextcloud show me this error, so i can give more information on this post about this problem.

Is there a debug mode?

Cordialy

Hi

I set 'loglevel' => 0, in /nextcloud/config/config.php file.

It seems that i get the php error when i have this in ldap result :

limit 500 offset 0

How to avoid that?

cordialy

There was a report on owncloud:

Since it’s unclear if it has been resolved, you could file a new bug report in github.com/nextcloud/server/issues and give more details about your setup. Make sure that you are running a current version of Nextcloud first (12.0.4 or 11.0.5).

Hi

Thanks for your answer.

I’ve read this bug report too.

But first i prefere to post on forum to know if the problem come from LDAP server or from Nextcloud.

I fellow advice present here https://github.com/nextcloud/server/issues/6613 and set ‘loglevel’ => 4

But i’m not sur it’s a good idea and prefer to solve this error.

I’ll go open a github ticket.

cordialy

LDAP issue often remain unanswered as it is less popular by individual users and the developers and not all checking the topics here on a regular basis.

Hi

Thanks for your advise.

I create a issue here : https://github.com/nextcloud/server/issues/7610

cordialy

1 Like

Hi,
I come back on this problem that I solve.
Our LDAP don’t support ldap_control_paged_result_response().
So i disable the “ldapPagingSize” ldap parameter from default 500 value to 0 value.
And no more problem nor log of ldap_control_paged_result_response().
cordialely