Last background job execution ran Vor 27 Tagen. Something seems wrong. Check the background job settings

Hallo ,

leider komme ich nicht mehr weiter, seit Update auf 29.0.0 RC2 funktioniert die Hintergrund Aktualisierung nicht mehr.

System ist Ubuntu 22.04
Nextcloud 29.0.0 RC2

Folgdende Fehlermeldungen sind vorhanden:

Es gibt einige Fehler bei deiner Systemkonfiguration.

  • Last background job execution ran Vor 27 Tagen. Something seems wrong. [Check the background job settings]

  • 155 Fehler in den Protokollen seit 31. März 2024, 20:28:08

  • Der Server hat keine konfigurierte Startzeit für das Wartungsfenster. Das bedeutet, dass ressourcenintensive tägliche Hintergrundaufgaben auch während deiner Hauptnutzungszeit ausgeführt werden. Wir empfehlen, das Wartungsfenster auf eine Zeit mit geringer Nutzung festzulegen, damit Benutzer weniger von der Belastung durch diese umfangreichen Aufgaben beeinträchtigt werden. Weitere Informationen findest du in der Dokumentation :arrow_upper_right:.

  • In der Datenbank fehlen einige Indizes. Auf Grund der Tatsache, dass das Hinzufügen von Indizes in großen Tabellen einige Zeit in Anspruch nehmen kann, wurden diese nicht automatisch erzeugt. Durch das Ausführen von “occ db:add-missing-indices” können die fehlenden Indizes manuell hinzugefügt werden, während die Instanz weiter läuft. Nachdem die Indizes hinzugefügt wurden, sind Anfragen auf die Tabellen normalerweise schneller. Fehlende optionaler Index “mail_messages_msgid_idx” in der Tabelle “mail_messages”. Fehlende optionaler Index “mail_messages_strucanalyz_idx” in der Tabelle “mail_messages”. Fehlende optionaler Index “mail_class_creat_idx” in der Tabelle “mail_classifiers”. Fehlende optionaler Index “mail_acc_prov_idx” in der Tabelle “mail_accounts”. Fehlende optionaler Index “mail_alias_accid_idx” in der Tabelle “mail_aliases”. Fehlende optionaler Index “oc_npushhash_di” in der Tabelle “notifications_pushhash”.

Ich hoffe ihr könnt mir weiter helfen

Für die Warnungen gibt es ja schon konkrete Hinweise, was du tun kannst. Aber auf den ersten Blick hat das nichts mit den Cronjobs zu tun. Du kannst versuchen, den Cronjob manuell auf der Konsole zu starten, dann spuckt er vielleicht direkt den Fehler aus (wenn du im Nextcloud-Verzeichnis bist):

sudo -u www-data php -f cron.php

Sonst solltest du eigentlich auch Fehler in der Logdatei finden (bei mehreren lässt sich das ggf. etwas schwerer zuordnen).

Mit den 27 Tagen, war das schon bevor du NC29 installiert hast?

Guten Tag,

wenn ich den Befehl sudo -u www-data php -f cron.php in /var/www/nextcloud ausführe erhalte ich folgende meldungen:

Doctrine\DBAL\Exception: Failed to connect to the database: An exception occurred in the driver: could not find driver in /var/www/nextcloud/lib/private/DB/Connection.php:155
Stack trace:
#0 /var/www/nextcloud/3rdparty/doctrine/dbal/src/Connection.php(452): OC\DB\Connection->connect()
#1 /var/www/nextcloud/3rdparty/doctrine/dbal/src/Connection.php(410): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /var/www/nextcloud/3rdparty/doctrine/dbal/src/Connection.php(317): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /var/www/nextcloud/lib/private/DB/ConnectionAdapter.php(200): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /var/www/nextcloud/lib/private/DB/QueryBuilder/QueryBuilder.php(121): OC\DB\ConnectionAdapter->getDatabasePlatform()
#5 /var/www/nextcloud/lib/private/AppConfig.php(1230): OC\DB\QueryBuilder\QueryBuilder->expr()
#6 /var/www/nextcloud/lib/private/AppConfig.php(262): OC\AppConfig->loadConfig()
#7 /var/www/nextcloud/lib/private/AppConfig.php(1371): OC\AppConfig->searchValues()
#8 /var/www/nextcloud/lib/private/App/AppManager.php(131): OC\AppConfig->getValues()
#9 /var/www/nextcloud/lib/private/App/AppManager.php(152): OC\App\AppManager->getInstalledAppsValues()
#10 /var/www/nextcloud/lib/private/legacy/OC_App.php(234): OC\App\AppManager->getInstalledApps()
#11 /var/www/nextcloud/lib/private/AppFramework/Bootstrap/Coordinator.php(90): OC_App::getEnabledApps()
#12 /var/www/nextcloud/lib/base.php(706): OC\AppFramework\Bootstrap\Coordinator->runInitialRegistration()
#13 /var/www/nextcloud/lib/base.php(1181): OC::init()
#14 /var/www/nextcloud/cron.php(58): require_once('...')
#15 {main}
  1. PHP upgedated, evtl. fehlen die PHP-Datenbank-Pakete?
  2. Datenbank läuft und ist nicht abgestürzt?

Hallo,

PHP ist auf 8.3.4.

Was mir noch aufgefallen ist das die 8.1.27 auch noch installiert ist.

Wie bekomme ich denn die alte Version deinstalliert?

8.3.4

Additional .ini files parsed => /etc/php/8.3/cli/conf.d/10-mysqlnd.ini,
/etc/php/8.3/cli/conf.d/20-mysqli.ini,
/etc/php/8.3/cli/conf.d/20-pdo_mysql.ini,
mysqli
Client API library version => mysqlnd 8.3.4
mysqli.allow_local_infile => Off => Off
mysqli.allow_persistent => On => On
mysqli.default_host => no value => no value
mysqli.default_port => 3306 => 3306
mysqli.default_pw => no value => no value
mysqli.default_socket => /var/run/mysqld/mysqld.sock => /var/run/mysqld/mysqld.sock
mysqli.default_user => no value => no value
mysqli.local_infile_directory => no value => no value
mysqli.max_links => Unlimited => Unlimited
mysqli.max_persistent => Unlimited => Unlimited
mysqli.rollback_on_cached_plink => Off => Off
mysqlnd
mysqlnd => enabled

8.1.27

Additional .ini files parsed => /etc/php/8.1/cli/conf.d/10-mysqlnd.ini,
/etc/php/8.1/cli/conf.d/20-mysqli.ini,
/etc/php/8.1/cli/conf.d/20-pdo_mysql.ini,
mysqli
Client API library version => mysqlnd 8.1.27
mysqli.allow_local_infile => Off => Off
mysqli.allow_persistent => On => On
mysqli.default_host => no value => no value
mysqli.default_port => 3306 => 3306
mysqli.default_pw => no value => no value
mysqli.default_socket => /var/run/mysqld/mysqld.sock => /var/run/mysqld/mysqld.sock
mysqli.default_user => no value => no value
mysqli.local_infile_directory => no value => no value
mysqli.max_links => Unlimited => Unlimited
mysqli.max_persistent => Unlimited => Unlimited
mysqli.reconnect => Off => Off
mysqli.rollback_on_cached_plink => Off => Off
mysqlnd
mysqlnd => enabled

sudo apt-get purge *php8.1*

Viel Glück,
ernolf

Hallo,

irgendwie stimmt da was mit der Version 8.3 und 8.1 nicht.

Wenn ich die 8.1 entfernen funktioniert Nextcloud nicht mehr.
Wie kann ich denn die php von 8.1 sauber auf 8.3 voll migrieren?

Leider funktioniert das Script php-updater nicht.

sudo wget -qO /usr/local/bin/php-updater https://global-social.net/script/php-updater
sudo chmod +x /usr/local/bin/php-updater

php-updater

Vielen Dank schon mal

Hallo,

ich habe die 8.3 komplett deinstalliert. Jetzt ist zumindest ein Fehler weg.

Was ich aber nicht finde ist folgender Fehler:

Failed to connect to the database: An exception occurred in the driver: could not find driver in /var/www/nextcloud/lib/private/DB/Connection.php:155

wenn ich manuell den Befehl : sudo -u www-data php -f /var/www/nextcloud/cron.php ausführe kommt der beschriebene Fehler.

Ich hoffe ihr könnt mir helfen.

Grüße

die Datenbank läuft ist aber nicht aktuell.

Was genau muss ich da ausführen?

Vielen Dank

Wo geht es denn schief?

Was ist die Ausgabe von

php-updater --list-installed

ernolf

… loading modules - integrity
First run, checking integrity:
===========================================================================
gpg: using RSA key xxxxxxxxxxx
---------------------------------------------------------------------------
- Integrity check failed. The script may have been modified or tampered with!
---------------------------------------------------------------------------
You should run:
sudo wget -O /usr/local/bin/php-updater https://global-social.net/apps/raw/s/php-updater

Das ist mir ein Rätsel weshalb das nicht funktioniert.

Könntest du mal versuchen den Key vom Keyserver zu importieren:

gpg --keyserver keyserver.ubuntu.com --recv-keys 3EE43A84D2BA635A94E1033B0B145139A170715C

Was sagt das?

Eventuell könntest du mir per PN die Ausgabe von

dpkg -l|awk '/^[hiu]i.*pgp*/{print $2}'

zukommen lassen. Das könnte mir helfen das Problem zu lokalisieren und zu beheben.

Du kannst die Prüfung ausser Kraft setzen indem du in der vorletzten Zeile des Skriptes das

v=false

in

v=true

änderst.


Viel Glück,
ernolf

die xxxxx habe ich eingetragen, da steht bei mir schon ein langer Key

gpg --keyserver keyserver.ubuntu.com --recv-keys 3EE43A84D2BA635A94E1033B0B145139A170715C
gpg: keyserver receive failed: Connection timed out

Wie bekomme ich denn das ganze Exportiert?
Leider bin ich ein absoluter Neuling im Bereich Linux.

Du kannst die Prüfung ausser Kraft setzen indem du in der vorletzten Zeile des Skriptes das

v=false

in

v=true

änderst.

Auch hier wäre ich dir dankbar wie ich an das Script hin komme.

Vielen Dank

einfach den Befehl in der Konsole eingeben und die Ausgabe mit der Maus markieren und kopieren.

Die Prüfung wird einfach mit diesem Befehl außer Kraft gesetzt:

sudo sed -i 's/^v=false$/v=true/' /usr/local/php-updater

ernolf

Aber da liegt das Problem:

Dein Server hat aus irgendwelche unerklärliche Gründe keinen Zugriff auf den Schlüsselserver.

Ich werde ein Update erstellen, bei dem der Schlüssel mitgeliefert wird.

Irgendwann im Laufe des Tages wird es verfügbar sein.

Vielen Dank für das Feedback

ernolf

1 Like

leider geht der Befehl nicht

Ich habe jetzt das Update gemacht und auch getestet.

Es geht, wie du bestimmt gemerkt hast nun auch, wenn der Keyserver nicht erreichbar ist.


ernolf