Joplin under nextcloud 18

joplin with nextcloud 18

Hi there,
can someone tell me if joplin works under nextcloud hub? I’ve been trying to sync joplin with nextcloud on Android for half a day without success. The URL that you have to enter in the app contains webdav; however, the URL that nextcloud outputs contains dav.
Joplin also offers the option in the app in the selection menu instead of synchronizing with nextcloud to synchronise with webdav. Then you can enter dav in the URL. However, that doesn’t work either.
Either it’s up to me and I don’t understand something fundamental, or Joplin doesn’t work under nextcloud hub. Can someone help me?

Thanks a lot!

What is Joplin?

I only know Janis :wink:

It is an application for notes and to-do`s

and further you can sync your data with your smartphone

Why not use Nextcloud notes- and todo-app?
And Nexcloud sync client for smartphone?

It works for me using the URL:
https://server-name/remote.php/dav/files/xxxx/Joplin

Joplin does not need any special support, it works great under Nextcloud 18 for me. What error are you getting? My guesses would be that you are either

  1. 2FA activated and need an app password
  2. Enter the wrong URL
  3. Does something wrong and try to use the “nextcloud app connection”, that does something else. It is not very clear what this means the last time I used the app

Thanks for your tips. But unfortunately it still doesn’t work. I have created a “Joplin” folder under nextcloud. Then pressed the settings button at the bottom left. There is the directory path
https: //XXX/nextcloud/remote.php/dav/files/XXX/Joplin
I entered this in the smartphone app under Configuration. Together with the user name and the corresponding nextcloud password.
Then I get an error message that the synchronization settings are incorrect:
Not a valod URL.

I don`t have a 2FA.

The Joplin manual also states that the URL should be with webdav. For this I think that is perharps due to nextcloud 18, because here the URL contains the dav in the URL.

It is not due to Nextcloud 18, I am running it on 18 as we speak.

I do however see a problem in the picture you posted. You have a certificate error. Are you using a self signed cert for the server?

As and aside, you forgot to censor your URL in that error message

Hello Kebba,

yes, that’s true. I am using a self-signed certificate.
so I have to see how to certify it.

Thank you very much for your hint. I am sure that this is the problem.

I am not sure how/if Joplin easily allow for using a self signed certificate. You will probably have similar problems with other apps.

If I where you, I would look into using letsencrypt for a real TLS certificate. Certs are free, and if you are on a supported OS (say Ubuntu), it is extremely easy to deploy. Once deployed, it is hassle free and supported by any modern browser/application. The web is full of good guides

Good Day.
I run Nextcloud 18 on my CentOS8 home server. I use Joplin on my laptop. I don’t get the sync working. I tried the following:

  1. https://www.domain/nextcloud/remote.php/dav/files/user/
    When I check the synchronization config it tell me: Success! Synchronization configuration appears to be correct.
    But further down I see this error message:
    The Joplin Nextcloud App is either not installed or misconfigured. Please see the full error message below:
    Unsupported WebDAV URL format: https://www.domain/nextcloud/remote.php/dav/files/user/

Joplin App is installed and in Nextcloud there is no configuration to be done for Joplin.
Do I need to create a Joplin folder on my server, and if so, where?

Thanks for your help, Wolfgang

That error message is a bit confusing in my opinion. The app it warning for is in development and is used to publically share a note. It seems like additonall functionallity is planned, like share for editing etc. I am avaiting a full release, it will be (hopefully) glorious

But, you don’t need it for Joplin to work with note sync and editing. Create a folder named “Joplin” in your servers root folder, and everything should “just work”.

Hi

I’m also having problems with sync from Joplin to Nextcloud!

Im running the last version of Joplin 1.0.201 (Linux Mint 19)

And running last version of NextCLoud 18.0.4

I have downloaded the “Joplin Web API” version 0.0.25 and installed / activated in nextcloud.

I have creted a folder in the root of the files called Joplin

cloud

Here is my settings from Joplin!

Any help will be good.

Kind regards

Taxick

Hi :slight_smile:

Thanks for all your answer :slight_smile:

I have found a solution to my problem. :slight_smile:

Instead of using “ Nextcloud ” in Joplin sync settings, I used “ WebDav

In the URL: I used this: https://my-site.dk/remote.php/dav/files/ MY-NEXTCLOUD- USERNAME /Joplin

And logged in with my username and password from Nextcloud!

Rember to create a folder in nextcloud called Joplin

And now it works.

1 Like

Hi

I’m also trying to sync with Joplin
Could you help me create a directory called Joplin ?
Thanks in advance
jerim

Just login in Nextcloud, select “Files” and create a folder named “Joplin”.

Because it is case-sensitive, you will need to type in “Joplin” as folder name on your mobile device, too.

Thanks for your help !