Issue after upgrading to 25.0.0

Hello everybody,
After upgrading Nextcloud to 25.0.0 i’ve an issue with Collabora Online - Built-in CODE Server.
The problem is that I can’t open the files (writer, calc) on the web browser but i must download it and then upload.
The same issue occured when I upgrade to version 23.0.0.
Thanks in advance for your support!

Hello @lanhouse.tgn, ,

Welcome to the wonderful world of Nextcloud and is it’s community.

Sadly enough your post is missing almost all specific technical information. Thanks for your post, but please take a little time to get acquainted with the forum and make a stronger effort to troubleshoot. It is the least you can do when asking others to help you:

  • Search your question as keywords on this forum. If you find something useful, link it directly into this post.
  • Search the internet using your issue as generic keywords. Specificity is king:
    • php modules missing Ubuntu Snap update
  • If you have an error message, repeat this process to search for your error on the forum and internet.
  • If you do not find an answer, you are likely using the wrong keywords. Try simplifying your search on the forum and internet even more.
    • nextcloud php modules missing
  • Once you’ve done this you should be able to edit and update your post with specific technical information we can use to help you.
  • Check Nextcloud admin documentation

Please edit and update your post to include:

  • Direct Links to any useful info pages, posts and other info you find.
  • Add screenshots to your post for context
  • If you have large log files to attach you can link to a pastebin
  • Fill out our support form and add into your post.

These are the exact same steps we volunteers will be following to help you! So, get to it!

Cheerio,
JimmyKater

I am actually having the same problem. Don’t use it a lot so not too big of a problem. Still weird. Files just download and don’t open in the editor. Using the built in collabora and the nextcloud office apps

I actually experienced this with two different setup:
Old one
Linode VPS
Ubuntu 2204 and Apache WITHOUT reverse proxy
Nextcloud 25
Worked fine before upgrade!

But I just went to docker
Fresh Linode vps. Installed docker compose, portainer, nginx proxy manager, NC 25 uses 8080 which is mapped to 80.

Must be missing something obvious :slight_smile:

version: '2'

volumes:
  nextcloud:
  db:

services:
  db:
    image: mariadb:10.5
    restart: always
    command: --transaction-isolation=READ-COMMITTED --binlog-format=ROW
    volumes:
      - /srv/nextcloud/db:/var/lib/mysql
    environment:
      - MYSQL_ROOT_PASSWORD=---
      - MYSQL_PASSWORD=---
      - MYSQL_DATABASE=---
      - MYSQL_USER=---
  app:
    image: nextcloud
    restart: always
    ports:
      - 8080:80
    links:
      - db
    volumes:
      - /srv/nextcloud/nextcloud:/var/www/html
    environment:
      - MYSQL_PASSWORD=---
      - MYSQL_DATABASE=---
      - MYSQL_USER=---
      - MYSQL_HOST=db
      - PHP_MEMORY_LIMIT=4096M
      - PHP_UPLOAD_LIMIT=4096M
      - NEXTCLOUD_TRUSTED_DOMAINS=domain.com xxx.xxx.xxx.xxx
      - TRUSTED_PROXIES=172.17.0.1 xxx.xxx.xxx.xxx

@lanhouse.tgn did you manage to fix this?

I confirm. The upgrade from 24.x (stable) to 25.0.1 (stable) has effectively killed this feature.
occ check and occ status are OK.
The install is on the VM with LAMP stack, no snap (Ubuntu 20.04 upgraded to 22.04).
I don’t find anything related to this problem in Administration settings / Logging.
What PHP modules are required for this feature?
Thanks

Update:
I have disabled and removed both “built-in CODE collabora online” and “Nextcloud office” applications, then re-downloaded and enabled them. Some time later it started working again. Very strange…

I gave it another try as well but still not opening files online. So strange.

Hi

I have the same problem here. Upgraded from 24.x stable to 25.0.1 and from that moment on document files are downloaded instead of opening the collabora editor. I did update to 25.0.2 today but same result.
My installation is: PHP 7.4 (tried also 8.0 and 8.1), no disabled_functions, no docker.

Tried to use one of the demo servers in the nextcloud office settings and then it works again. But with builtin CODE server it does not work.

Update
It seems to be an issue that Nextcloud does not recognize that a collabora server is available when using the builtin CODE server:

  1. Select to use a demo server in Nextcloud Office admin settings.
  2. Reload files app (use another browser tab).
  3. Opening documents works (collabora with demo watermarks opens).
  4. Go back to Nextcloud Office admin settings and switch to builtin CODE server.
  5. Go to files app without reloading the page.
  6. Opening documents works (collabora without demo watermarks opens).
  7. Reload file app page.
  8. Opening documents does not work (direct download instead of collabora opening the file).

Best regards,
Lars

1 Like

This is exactly the behavior I’m seeing as well. I replicated your steps exactly.

Even more frustrating for me: I run two nextcloud instances which, apart from branding, use the same setup, running the same version of nextcloud, same version of PHP, same applications, and Office works perfectly every time on one of them but not on the other.

I have the same issue with the built-in CODE server. Access to documents results in either download or a failed connection to the document. Backend checks are green.

One thing there was new after the update was an error that I needed to whitelist the IP for WOPI. I set that to 127.0.0.1 in the Office settings screen.

Error after failed loading: Nextcloud Office could not be loaded. Please retry later.

PHP Config

Version: 8.1.13
max memory: 512 MB
max execution: 3600
max upload: 200 MB
Extensions: Core, date, libxml, openssl, pcre, zlib, filter, hash, json, Reflection, SPL, session, standard, sodium, cgi-fcgi, mysqlnd, PDO, xml, apcu, bcmath, calendar, ctype, curl, dom, mbstring, FFI, fileinfo, ftp, gd, gettext, gmp, iconv, imagick, intl, exif, memcache, mysqli, pdo_mysql, Phar, posix, readline, shmop, SimpleXML, sockets, sysvmsg, sysvsem, sysvshm, tokenizer, xmlreader, xmlwriter, xsl, zip, Zend OPcache

Browser console log

[INFO] viewer: Opening viewer for file  
Object { level: 1, app: "viewer", uid: "nc-admin", path: "/Documents/test.odt" }
ConsoleLogger.js:56:18
File info for /Documents/test.odt fetched 
Object { filename: "/Documents/test.odt", basename: "test.odt", lastmod: "Tue, 13 Dec 2022 08:25:58 GMT", size: 642, type: "file", etag: null, mime: "application/vnd.oasis.opendocument.text", getlastmodified: "Tue, 13 Dec 2022 08:25:58 GMT", getcontenttype: "application/vnd.oasis.opendocument.text", resourcetype: "", … }
Viewer.vue:490:18
session heartbeat polling started session-heartbeat.js:103:9
PostMessageService.sendPostMessage parent loading postMessage.tsx:42:16
Waiting for page to render… document.js:224:12
PostMessageService.sendPostMessage parent loading postMessage.tsx:42:16
[getWopiUrl] https://domain.com/index.php/apps/richdocuments/wopi/files/448544_ocm10mcpwumd url.js:42:9
XHRPOSThttps://domain.com/apps/richdocumentscode/proxy.php?req=/cool/https://domain.com/index.php/apps/richdocuments/wopi/files/448544_ocm10mcpwumd?access_token=wFn55Ls59Wru6RLm8aZ0a21Game3NnA3&access_token_ttl=1670965578000/ws?WOPISrc=https://domain.com/index.php/apps/richdocuments/wopi/files/448544_ocm10mcpwumd&compat=/ws/open/open/0
[HTTP/2 400 Bad Request 106ms]

XHRPOSThttps://domain.com/apps/richdocumentscode/proxy.php?req=/cool/https://domain.com/index.php/apps/richdocuments/wopi/files/448544_ocm10mcpwumd?access_token=wFn55Ls59Wru6RLm8aZ0a21Game3NnA3&access_token_ttl=1670965578000&permission=edit/ws?WOPISrc=https://domain.com/index.php/apps/richdocuments/wopi/files/448544_ocm10mcpwumd&compat=/ws/open/open/0
[HTTP/2 400 Bad Request 46ms]

Uncaught TypeError: sheets[i].href is null
    <anonymous> https://domain.com/apps/richdocumentscode/proxy.php?req=/browser/a4b9c74/cool.html?WOPISrc=https://domain.com/index.php/apps/richdocuments/wopi/files/448544_ocm10mcpwumd&title=test.odt&lang=de&closebutton=1&revisionhistory=1:269
    EventListener.handleEvent* https://domain.com/apps/richdocumentscode/proxy.php?req=/browser/a4b9c74/cool.html?WOPISrc=https://domain.com/index.php/apps/richdocuments/wopi/files/448544_ocm10mcpwumd&title=test.odt&lang=de&closebutton=1&revisionhistory=1:269
    <anonymous> https://domain.com/apps/richdocumentscode/proxy.php?req=/browser/a4b9c74/cool.html?WOPISrc=https://domain.com/index.php/apps/richdocuments/wopi/files/448544_ocm10mcpwumd&title=test.odt&lang=de&closebutton=1&revisionhistory=1:269
proxy.php:269:12063
PostMessageService.sendPostMessage loolframe {"MessageId":"Host_PostmessageReady","SendTime":1670929579915,"Values":{}} postMessage.tsx:42:16
XHRPOSThttps://domain.com/apps/richdocumentscode/proxy.php?req=/cool/https://domain.com/index.php/apps/richdocuments/wopi/files/448544_ocm10mcpwumd?access_token=wFn55Ls59Wru6RLm8aZ0a21Game3NnA3&access_token_ttl=1670965578000&permission=edit/ws?WOPISrc=https://domain.com/index.php/apps/richdocuments/wopi/files/448544_ocm10mcpwumd&compat=/ws/open/open/0
[HTTP/2 400 Bad Request 50ms]

FAILED Office.vue:199
    loadingTimeout Office.vue:199
    (Async: setTimeout handler)
    n Office.vue:198
    u Office.vue:71
    _invoke Office.vue:71
    y Office.vue:71
    ge Office.vue:71
    i Office.vue:71
    _e Office.vue:71
    _e Office.vue:71
    load Office.vue:191
    t Office.vue:185
    u Office.vue:71
    _invoke Office.vue:71
    y Office.vue:71
    ge Office.vue:71
    i Office.vue:71
    (Async: promise callback)
    ge Office.vue:71
    i Office.vue:71
    (Async: promise callback)
    ge Office.vue:71
    i Office.vue:71
    _e Office.vue:71
    _e Office.vue:71
    mounted Office.vue:163
    VueJS 19
    o Viewer.vue:517
    u runtime.js:288
    _invoke runtime.js:262
    C runtime.js:83
    Bg Pencil.vue:19
    a Pencil.vue:19
[document] editorInitListener: Received post message  
Object { MessageId: "App_LoadingStatus", Values: {…} }
document.js:267:13
OC.requestToken changed eFUwIKkshBVdeBezWEapq25hM65A3q6Uaok9Im/48xY=:SzpWGJh41SNrMk7xLXDDwDknZN5zlfvFOeBEaSygmCY= index.js:323:9

I have the exact same issue running the built-in CODE serve on Nextcloud 25.0.2

Nextcloud Hub 3 - 25.0.2

Everything was working without problem on Nextcloud 24 and after successful update to NC25 AIO - Nextcoud office is not working anymore with message:

image
2023-01-08T23:00:00Z

I tried to restart docker container and it didn’t help.

Is there any fix to this annoying issue…or I should go back to NextCloud 24 AIO?
Definitely in future I will not update NextCloud so easily as new versions bring problems like this one.

Hi, can you follow How to debug problems with Collabora and/or Talk · Discussion #1358 · nextcloud/all-in-one · GitHub?

Thank you for your replay szaimen, I will try it as soon as I get home and report here what happend!


I tried right away and adding ,0.0.0.0/0 Allowed list for WOPI requests and everything works as expected!

Only downside is that this is not secure as you allow all ip-addresses to connect by doing so.

Thank you very much!

Hello,
I’m using the integrated CODE server plugin but I’m not able to open any documents, user is going to be disconnect and connection goes in loop and in logs I see a lot of 400 HTTP error code. This happens after upgrading from nextcloud 24 to nextcloud 25.

I’ve updated PHP to 8.0.27-1, now it works again.