iOS Nextcloud App and Files Manager Integration no longer works

I’ve noticed that the integration of iOS Nextcloud and Files app (and thus other apps that access Nextcloud via the Files app) no longer works as it used to. While I can see everything in the Nextcloud app, only the top-level files and directories are displayed in the Files app. If you select any directory, then 0 objects are shown, even if the directory contains files or more subdirectories.

I have the problem on both an iPhone 7 and an iPad Pro.

Software versions on the devices:

iPhone 7
Nextcloud 4.3.1
iOS 15.3.1

iPad Pro
iOS 14.8
Nextcloud 4.3.1

hello,

notice that too on my daughter aie-phone X ! synch broken/hang since last ios/app update.

Well, her birthday is next October, and i planned to buy her a new android oneplus… :rofl:

I am definitly done with any apple products for several reasons … grumpy me talking here :face_with_symbols_over_mouth:

I have done some more thinking and testing. I tried to upload the app log to a folder on Nextcloud via the iOS Files app and got the error message “File or folder does not exist”. But in fact the log file was uploaded to the selected directory (checked in Nextcloud App). This is very strange. Of course, I can’t view it in any app (except the Nextcloud App itself). I guess browsing the directory tree from level 1 doesn’t work.

After deleting and reinstalling the Nextcloud app everything works again as usual.

I also ran in to this problem when updating to 4.3.1. Nextcloud no longer showed up in the Files app.

I first tried the “Advanced->Reset application” option, which afterwards Nextcloud did start showing up in the Files app, but after logging back in, it was basically frozen. In the end I had to delete and reinstall the app in order to get it fully working again.

My guess is that the is a bug in 4.3.1 that is causing the FileProviderExtension to crash when someone upgrades from an older version.