InvalidSignatureException for all apps

Nextcloud version: 20.0.4
Using the latest docker nextcloud image (with bundled Apache)

I have been using version 20.0.3 for a month or so, experiencing no problems. Installing/using apps was without issue Today, I attempted to install a new app to my NextCloud instance and got the error: “An error occured during the request. Unable to proceed. Couldn’t update app.”. On checking the “Security & setup warnings” in the Admin settings, I can see:
“Some files have not passed the integrity check. Further information on how to resolve this issue can be found in the documentation. (List of invalid files… / Rescan…)”
The ‘List of invalid files’ can be seen at this pastebin.
As you can see, everything is showing:
OC\IntegrityCheck\Exceptions\InvalidSignatureException
Certificate is not valid.

I have since updated my Docker container to use the latest 20.0.4 but the problem persists and I cannot install any apps. In my “Logging” I can see the following entry when attempting to install a new app:

[core] Error: Exception: Could not validate CRL signature at <<closure>>

0. /var/www/html/lib/private/Installer.php line 198
   OC\Installer->downloadApp("*** sensitive parameter replaced ***", false)
1. /var/www/html/apps/settings/lib/Controller/AppSettingsController.php line 532
   OC\Installer->updateAppstoreApp("*** sensitive parameters replaced ***")
2. /var/www/html/lib/private/AppFramework/Http/Dispatcher.php line 169
   OCA\Settings\Controller\AppSettingsController->updateApp("*** sensitive parameters replaced ***")
3. /var/www/html/lib/private/AppFramework/Http/Dispatcher.php line 100
   OC\AppFramework\Http\Dispatcher->executeController(OCA\Settings\Con ... {}, "updateApp")
4. /var/www/html/lib/private/AppFramework/App.php line 152
   OC\AppFramework\Http\Dispatcher->dispatch(OCA\Settings\Con ... {}, "updateApp")
5. /var/www/html/lib/private/Route/Router.php line 308
   OC\AppFramework\App::main("OCA\\Settings\\ ... r", "updateApp", OC\AppFramework\ ... {}, {action: null,ap ... "})
6. /var/www/html/lib/base.php line 1008
   OC\Route\Router->match("/settings/apps/update/spreed")
7. /var/www/html/index.php line 37
   OC::handleRequest()

GET /settings/apps/update/spreed
from 31.125.163.105 by ************ at 2021-01-11T12:53:59+00:00

I have attempted to find solutions to this issue, but none have solved it. Any help would be appreciated.

I fixed it…
I forgot to mention I had installed the ‘Social Login’ app. Removing it solved the issue.

7 Likes

Same behaviour here. Deleting “Social login” did the trick indeed.

adding more detail
if somebody had

“Could not validate CRL signature”

when installing apps
please also delete “Social Login”
then it works
at least for me is working
perhaps if somebody had same as I had

Thanks all✌️

1 Like

On NC 21 beta I also see the signature error for all apps: mail, news, bookmarks, drop_account, data_request, …:

$ php occ app:install mail  
Error: App with id mail has invalid signature

I suspect that this has little to do with the signatures (since all above apps had been installed on that NC instance until just some minutes ago), but rather with calling an incompatible function. I already had opened a bug for that here but it received no attention yet.

Remove Social Login 4.0.2 and then reinstall 4.0.3 (you can’t update it). No more invalid signature exceptions after that. (nextcloud version: 20.0.4-fpm-alpine)

1 Like

Kinda scary that one lone App can completely destroy App installation and updating…
I never would have been able to guess which App was the culprit (or that an App is the culprit at all) if I hadn’t found this page here… thx for figuring out the problem!

So, what if I have this problem, and DON’T have the Social Login app installed?

At least in NC21beta that happens for all apps. Today, there was an update for files_accesscontrol. Update didn’t work. Removed it via occ and tried to reinstall: “wrong signature”. I don’t have any Social app installed. Maybe that’s two different issues but is smells like too much of a coincidence.

Glad it helped someone else! I think I’ll stay away from the “Social Login” app from now on.

I just installed 21beta6 – that fixes the issue for me. Maybe that was fixed not only in 21 but in 20 and 19, too. Also released today: 20.0.5 and 19.0.7. Try upgrading to latest server and then retry with the apps if that solved it.

Yeah, fixed in NC 21 beta 6

The signing issue reappeared here in 21beta7!! I tried to switch from 21beta3 to 21beta7 on command line (updater.phar) and got the InvalidSignatureException for the core and ALL apps. :frowning_face:

N.B. I don’t have Social Login!

Had this problem, too, after upgrading to 20.0.5

Solved by updating to 20.0.6rc1

Same here and have no idea what happened.

Same for me

Same with an update from nextcloud 20 to 21beta7

Same issue with 20.0.5 and 20.0.6 from nextcloud docker image, not sure how to fix it.

It doesn’t solve the issue here. Disabled social login but nothing chaged :frowning:

Nextcloud 21.0.0 beta7

I’ve tried enabling and disabling; downloaded a previous version, installed, enabled, disabled… nothing changed.
I still get “Could not validate CRL signature” when I try installing any app that has to be get from the store.
[edit]The following seems somehow disappeared. Sorry.
*It also gives another annyoing error: *
*when I try to share something giving an email address, it keeps on spinning forever and never completes the process. The same try from the app gives “cannot reach the server” or similar. *
Thank for any help or hint!