Interface unresponsive

Hi,
I run NextcloutPi on a raspberry pi 4B 8GB with the 64bit image.

I have installed Netxcloud Office and Collabora Online – Built-in CODE Server 64bit
After that I went back in nextcloud and created a document. Tried to open it to test the Nextcloud Office and than the issues started
Since the installation, I am unable to load the netxcloud interface.
After waiting long time, I eventually get the following message (when using the internal IP addres 192.168…:

Gateway Timeout

The gateway did not receive a timely response from the upstream server or application.

When trying to access it from outside with the domain name, I get the following error:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

However, the NCP panel is responsive. (or so it seems so far)
Is there a way to manually uninstall nextcloud Office and Collabora Online – Built-in CODE Server?
Thanks

UPDATE
after rebooting the server several time, finally Nextcloud is back.
However, I still dont have any sort of office feature.
I create a new document… the file appear in the folder but I dont have any Office interface to edit the document.
Any idea?

Hello,

What do your nextcloud logs say? And how did you set up Colabora?
Please make a screenshot

I followed this instructions:

only differece is that collabora app is not there. After researching, it seems replaced by Nextcloud office.
I am not sure what to look in the logs.
I started to see a number of warnings but this is a Error:

[core] Error: OC_Image::fixOrientation(): No image loaded

GET /index.php/core/preview?fileId=1749781&c=11c583c52945b74ee41fe50b33ab4898&x=250&y=250&forceIcon=0&a=0
from 192.168.x.x by <username> at 2022-03-18T12:24:43+00:00

Any correlation?

after a duckduckgo I found that it is a Collaborara related error despite it looks like an image viewing error.
The issue is documented in 2 places:

and
https://wiki.nethserver.org/doku.php?id=onlyoffice#something_s_not_working
This last message is related to onlioffice but seems to be the same issue.
Problem is that the path does not exist! The post is old
Any suggestions?

Check their github repo issues related to the office suite you installed.

Keep in mind that Collabora is extremely resource intensive and will never perform well on a current generation Raspberry Pi with even just a few users. Also, the Nextcloud CODE version has some performance issues and limitations which are not present in the full release. For these reasons I do not bother with it.

Also, if you are running all of this off a microsd card… those are stupid slow. Only so many megabytes per second. An SSD drive, attached over USB 3 will mean the USB 3 connection is the slow part, but at least it can move a few hundreds megabytes per second. Factor in your network speeds from your router and ISP as well.

If you want real speed you’ll want to get a more powerful x86 machine with higher ram and resources for Collabora. Or, install the full Collabora office suite on a VPS. Just want to be real with you on where to set expectations.

1 Like

I am getting to same conclusion…
I am running the nextcloudPi from USB thumb 3.0
I found a possible solution: ```
./occ config:system:set allow_local_remote_servers --value true --type bool
but I am not sure if there are any safety concerns… I dont know the commands well enough and allow local remote servers kinda worries me…

I foud this:

seems helping but some of the folder do not contain same files and also get me crazy

Yeah, that is going to be super shitty slow. Just cannot support that office suite off of a thumb drive. Simplest solution is to install it on a monthly VPS and plug that into Nextcloud.

I think I give up this project till I found a better options as you suggested … or move everything to a power hardware

Its a bit sad to not have my own document editing system to replace google… but again… you right… HW requirements are probably a key in all this

The solution I use is to run Libreoffice directly on my client device. Works great, then I just share the docs from Nextcloud.

If you need the full office suite and speed then consider investing money into more robust hardware. It makes a world of difference.

You mean running libreoffice in my Linux distro on my desktop and use Nextcloud as a sharing document place?
If so, yes, that is what I do. I was hoping for a sort of google like editing document so that I can use it from anywhere in the planet!
But I guess here is when a better hardware comes in play

1 Like

So, for everyone that read those posts about collabora on a NCP…
SOLUTION: dont try!
Or
Use better hardware.
I decided to give up on this project.

People are running the office suite. You’ll just need at least an SSD and good internet speeds to support it for a few users. Especially for a google like editing experience.

Thumb drive = interface unresponsive. But, of course try.

I did try… and not very successfully I must say!
I gave up ! :upside_down_face: