Installation steps explained


#1

Hello,

I try to setup fullnextsearch with the guide from Github but I can’t get it work.
The Problem for me is the setup from readonlyrest.

Has anyone setup it completely and can help me?
I download readonlyrest and would install it at /usr/share/elasticsearch but get this message:

root@panel:/etc/elasticsearch# cd /usr/share/elasticsearch                         root@panel:/usr/share/elasticsearch# ls
bin            lib      NOTICE.txt  README.textile
elasticsearch  modules  plugins     readonlyrest-1.16.14_es6.1.0.zip
root@panel:/usr/share/elasticsearch# sudo bin/elasticsearch-plugin install file://readonlyrest-1.16.14_es6.1.0.zip
-> Downloading file://readonlyrest-1.16.14_es6.1.0.zip
Exception in thread "main" java.net.UnknownHostException: readonlyrest-1.16.14_es6.1.0.zip
        at java.net.AbstractPlainSocketImpl.connect(java.base@9-internal/AbstractPlainSocketImpl.java:226)
        at java.net.Socket.connect(java.base@9-internal/Socket.java:591)
        at java.net.Socket.connect(java.base@9-internal/Socket.java:540)
        at sun.net.ftp.impl.FtpClient.doConnect(java.base@9-internal/FtpClient.java:956)
        at sun.net.ftp.impl.FtpClient.tryConnect(java.base@9-internal/FtpClient.java:916)
        at sun.net.ftp.impl.FtpClient.connect(java.base@9-internal/FtpClient.java:1011)
        at sun.net.ftp.impl.FtpClient.connect(java.base@9-internal/FtpClient.java:997)
        at sun.net.www.protocol.ftp.FtpURLConnection.connect(java.base@9-internal/FtpURLConnection.java:295)
        at sun.net.www.protocol.ftp.FtpURLConnection.getInputStream(java.base@9-internal/FtpURLConnection.java:401)
        at org.elasticsearch.plugins.InstallPluginCommand.downloadZip(InstallPluginCommand.java:328)
        at org.elasticsearch.plugins.InstallPluginCommand.download(InstallPluginCommand.java:248)
        at org.elasticsearch.plugins.InstallPluginCommand.execute(InstallPluginCommand.java:216)
        at org.elasticsearch.plugins.InstallPluginCommand.execute(InstallPluginCommand.java:202)
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:70)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134)        at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:69)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134)        at org.elasticsearch.cli.Command.main(Command.java:90)
        at org.elasticsearch.plugins.PluginCli.main(PluginCli.java:47)

#2

Try with file:///full/path/to/readonlyrestplugin.zip (note the 3 slashes)


#3

Thanks looks better, but

root@panel:/usr/share/elasticsearch# sudo bin/elasticsearch-plugin install file:///usr/share/elasticsearch/readonlyrest-1.16.14_es6.1.0.zip
-> Downloading file:///usr/share/elasticsearch/readonlyrest-1.16.14_es6.1.0.zip
[=================================================] 100%  
Exception in thread "main" java.lang.IllegalArgumentException: plugin [readonlyrest] is incompatible with version [5.6.5]; was designed for version [6.1.0]

#4

yes, you will need to install elasticsearch 6.1.0 or downgrade the readonly plugin to the right version.

I would go with elasticsearch 6.1.0


#5

Thanks, it works.
You wrote in the tutorial that I need to edit the readonlyrest.yml in /etc/elasticsearch. But I have no readonlyrest.yml file. Must I create the file?


#6

Yes. Since 6.x, all readonlyrest config needs to be out of elasticsearch.yml.


#7

Okay I create the file in /etc/elasticsearch

Must I use the usernames and passwords from each user of the cloud?


#8

No!

Just an account for your cloud


#9

Work it, or not?

sudo -u lars php occ config:app:set --value 'cloud1_index' fullnextsearch_elasticsearch elastic_index
Config value elastic_index for app fullnextsearch_elasticsearch set to cloud1_indexroot@panel:/var/www/vhosts/larsmueller.net/cloud.larsmueller.net# sudo -u lars php occ fullnextsearch:reset                                                           reset.


  [Elasticsearch\Common\Exceptions\NoNodesAvailableException]
  No alive nodes found in your cluster


fullnextsearch:reset [--output [OUTPUT]] [--] [<provider>]

root@panel:/var/www/vhosts/larsmueller.net/cloud.larsmueller.net# sudo -u lars php occ fullnextsearch:index


  [OCA\FullNextSearch\Exceptions\RunnerAlreadyUpException]
  Index is already running


fullnextsearch:index [--output [OUTPUT]]

#10

You should not need to use the occ command to configure the app, there is a page now in the Admin Settings.

You can stop the index with the stop command (it might be running in the background). The list of command is on the Wiki.

Also check this:


#11

Thanks, I think I have an other problem.

java.net.MalformedURLException: no protocol: ${codebaJan 09 14:48:12 panel.larsmueller.net elasticsearch[1085]: Exception: java.lang.SecurityException thrown from the UncaugJan 09 14:48:12 panel.larsmueller.net systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILJan 09 14:48:12 panel.larsmueller.net systemd[1]: elasticsearch.service: Unit entered failed state.
Jan 09 14:48:12 panel.larsmueller.net systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

#12

do you have this issue while indexing a specific file ? doing a search ? or during the setup ?


#13

I start the elasticsearch service with service elasticsearch start. When I view the status it says loaded but after this the process died. I don’t know why. I think I start the setup again.


#14

new Update:

when i run Elasticsearch:live i get this output:

Exception: Backends provided no user object
Exception: Backends provided no user object
 . Indexing:
Exception: {"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"}],"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"},"status":400}
 . Indexing:
Exception: {"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"}],"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"},"status":400}
 . Indexing:
Exception: {"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"}],"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"},"status":400}
 . Indexing:
Exception: {"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"}],"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"},"status":400}
 . Indexing:
Exception: {"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"}],"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"},"status":400}

Curl give me this and it seems its correct configured:

root@panel:/var/www/vhosts/larsmueller.net/cloud.larsmueller.net# curl http://cloudindex1:Fuceekewet0@localhost:9200/
{
  "name" : "lTQxhay",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "mhXzsX_xTx6JA1VsXSA9eQ",
  "version" : {
    "number" : "6.1.1",
    "build_hash" : "bd92e7f",
    "build_date" : "2017-12-17T20:23:25.338Z",
    "build_snapshot" : false,
    "lucene_version" : "7.1.0",
    "minimum_wire_compatibility_version" : "5.6.0",
    "minimum_index_compatibility_version" : "5.0.0"
  },
  "tagline" : "You Know, for Search"
}

What can i do? @Cult


#15

This is fixed in next release.

Wait for 0.5.x :relaxed:


#16

okay it seems that´s an error with hidden files?

root@panel:/var/www/vhosts/larsmueller.net/cloud.larsmueller.net# sudo -u lars php occ fulltextsearch:index
indexing.
 USER: Anja
- RAM: 20.628196716309
 . Indexing: interner Speicher Anja
  result: {"_index":"my_index","_type":"files","_id":"10","_version":2,"result":"updated","_shards":{"total":2,"successful":1,"failed":0},"_seq_no":140,"_primary_term":2}
 . Indexing: interner Speicher Anja/.ravesocial
  result: {"_index":"my_index","_type":"files","_id":"6529","_version":2,"result":"updated","_shards":{"total":2,"successful":1,"failed":0},"_seq_no":122,"_primary_term":2}
 . Indexing: interner Speicher Anja/.tmp
  result: {"_index":"my_index","_type":"files","_id":"6547","_version":2,"result":"updated","_shards":{"total":2,"successful":1,"failed":0},"_seq_no":123,"_primary_term":2}
 . Indexing: interner Speicher Anja/Alarms
  result: {"_index":"my_index","_type":"files","_id":"6530","_version":2,"result":"updated","_shards":{"total":2,"successful":1,"failed":0},"_seq_no":135,"_primary_term":2}
 . Indexing: interner Speicher Anja/Android
  result: {"_index":"my_index","_type":"files","_id":"6551","_version":2,"result":"updated","_shards":{"total":2,"successful":1,"failed":0},"_seq_no":124,"_primary_term":2}
 . Indexing: interner Speicher Anja/Android/data
  result: {"_index":"my_index","_type":"files","_id":"8017","_version":2,"result":"updated","_shards":{"total":2,"successful":1,"failed":0},"_seq_no":136,"_primary_term":2}
 . Indexing: interner Speicher Anja/Android/data/.nomedia


  [Elasticsearch\Common\Exceptions\BadRequest400Exception]
  {"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"pipeline with id [attachment] does not exist"}],"type":"illegal_argument_exception","reason":"pipeline with id [att
  achment] does not exist"},"status":400}

#17

No, it seems to be an issue when you change the content of a file.


#18

then i wait for the next release :slight_smile: