INstall guide for a newbie

Hi all,

I’m starting from scratch on a new installation: This is a manual installation vs a snap.

My Linux is better, but still “Beginner” - I can run most commends i need, the trouble i have is finding the files (And typo’s!).

It will be run from Ubuntu 16.04 LTS, with PhP 7, Apache, MySql\MariaDB, Which i am setting up now.

Does anyone have a simple\up-to date guide on how i can do this?

Try this one?

@JasonBayton - Thanks - It goes so well then i hit 2 problems -

1 - is NXDOMAIN looking up A record for “cloud.domain.com” - This is an issue i hit all the time… I’ll go back to this soon - Self signed for now

FIXED - continuing past that and creating the nextcloud.conf stops apache from starting… This was resolved by cd /etc/apache2/sites-enabled then sudo rm nextcloud.conf - SOLVED - USER (ME) Error…

2 - Editing the Nextcloud.conf with the follwing breaks my nextcloud (Internal server error):

‘memcache.local’ => ‘\OC\Memcache\Redis’, ‘memcache.locking’ => ‘\OC\Memcache\Redis’, ‘filelocking.enabled’ => ‘true’, ‘redis’ => array ( ‘host’ => ‘/var/run/redis/redis.sock’, ‘port’ => 0, ‘timeout’ => 0.0, ),

and Htacess… SOLVED - Wrong place breaks, correct place works… Learning…

https://www.c-rieger.de/
or

You need to put all of that in your config.php file, not the Apache conf file :slight_smile:

And when you do, pay special attention to formatting, making sure there are commas at the end of all but the last lines in the config file, etc

Thanks Jason! I’ve got all that done now, It was indeed a missed comma

Nextcloud is up, Apps are enabled as per PoC requirements

Now, It’s my Nemesis, which is NXDOMAIN error stopping me getting a SSL Certificate…

I may well need to post on letsencrypt for that

The guide didn’t literally want you to put “cloud.domain.com”, but rather, a DNS A or CNAME record that you’ve created for a domain you control. You’ll need to make sure you’ve got such a record that points to your server’s IP.
Example: if you own the site “thisplace.here”, then log in with your DNS provider/registrar and add an A record “nextcloud” in that domain that points to your IP, then you would replace “cloud.domain.com” from the guide with “nextcloud.thisplace.here”.

Hi,

I redacted my domain with cloud.domain.com

I have confirmed i have an A record in DNS, this resolves on both the server, and client machines.

Ok, sorry for assumptions. This A record also needs to be resolved correctly by LetsEncrypt, so it could well just be a cache timing issue. With most DNS providers, trying again in an hour or so will let it take care of itself.

No probs - I did post that i’m a newbie…

I’ll speak to a few colleagues tomorrow - both my nexctloud domains i have created do not work. They have been created for well over a week…