I'm a completely stuck and I do not know what other options are available to me

I feel like I’ve tried everything.

I’ve tried to do a manual install. I’ve tried a shell script that someone linked me. I’ve tried an ansible playbook that someone linked me. I’ve wiped my computer and reinstalled the OS more than once. I tried using the snap. I even tried to install it using the setup-nextcloud.php file.

Nothing has worked. Here’s some links to all my attempts and forum/github posts:

Here’s my current nginx logs:

Access logs

127.0.0.1 - - [27/Jul/2018:21:53:12 -0500] "\x16\x03\x01\x02\x00\x01\x00\x01\xFC\x03\x03o\x80" 400 166 "-" "-" "-" "thewize" sn="thewize" rt=0.000 ua="-" us="-" ut="-" ul="-" cs=-
127.0.0.1 - - [27/Jul/2018:21:53:12 -0500] "\x16\x03\x01\x02\x00\x01\x00\x01\xFC\x03\x03\xB3\xE9\xF9Q\x01\x9B\xEE\xBA\xBAv\xD5\x98\xEE\xA2\xDB\xDB\x11$\x18\x22U5>\x7F\x89Q\xE6\xB8\xBCQ\xB8\xB7 " 400 166 "-" "-" "-" "thewize" sn="thewize" rt=0.000 ua="-" us="-" ut="-" ul="-" cs=-
127.0.0.1 - - [27/Jul/2018:21:53:19 -0500] "\x16\x03\x01\x02\x00\x01\x00\x01\xFC\x03\x03\x97\x96\xE1Na{\x18\x1F\xA1\x2288(x`\xF5H\xA5/\xC7U\x01d\xA8*D\xC0\xE9\xB8Zx\x81 \xF1\x87h\xB6\x17\x92\xAA\xC9j\x8C\xC4\xFC$\x9C\xFC\xF19\xDE" 400 166 "-" "-" "-" "thewize" sn="thewize" rt=0.001 ua="-" us="-" ut="-" ul="-" cs=-
127.0.0.1 - - [27/Jul/2018:21:53:27 -0500] "\x16\x03\x01\x02\x00\x01\x00\x01\xFC\x03\x03\x82\xBD\x0B\x03\xA2\x81\x15\xEC$6\xB0(\x93\xAD\xA6\x18\xCC\x172\x7F\xACi\x92\x15\x14E\xD2\x06\xDB\xFD\xD0\x89 \xDC\x99\xA4\xA7I\xCA\xDF\xCB\xEF%\xD5\xFD\x90=\xE3\xFB\xC7\xDE\x10\x8F;\xA46K_\xA4v|WT$\xAD\x00\x1C\x13\x01\x13\x03\x13\x02\xC0+\xC0/\xCC\xA9\xCC\xA8\xC0,\xC00\xC0\x13\xC0\x14\x00/\x005\x00" 400 166 "-" "-" "-" "thewize" sn="thewize" rt=0.000 ua="-" us="-" ut="-" ul="-" cs=-
127.0.0.1 - - [27/Jul/2018:21:54:11 -0500] "GET / HTTP/1.1" 301 178 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.000 ua="-" us="-" ut="-" ul="-" cs=-
127.0.0.1 - - [27/Jul/2018:21:56:18 -0500] "GET /index.php HTTP/1.1" 301 178 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.000 ua="-" us="-" ut="-" ul="-" cs=-
127.0.0.1 - - [27/Jul/2018:22:14:28 -0500] "HEAD / HTTP/1.1" 301 0 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.75 Safari/537.36" "-" "thewize" sn="thewize" rt=0.000 ua="-" us="-" ut="-" ul="-" cs=-
127.0.0.1 - - [27/Jul/2018:22:54:28 -0500] "GET / HTTP/1.1" 301 178 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "localhost.localdomain" sn="thewize" rt=0.000 ua="-" us="-" ut="-" ul="-" cs=-

Error logs, le access logs, le error logs are empty

nextcloud access logs:

127.0.0.1 - - [27/Jul/2018:21:44:04 -0500] "GET / HTTP/2.0" 200 2598 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.115 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.116" ul="12649" cs=-
127.0.0.1 - - [27/Jul/2018:21:45:04 -0500] "POST /index.php HTTP/2.0" 200 2781 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.035 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.036" ul="13024" cs=-
127.0.0.1 - - [27/Jul/2018:21:48:59 -0500] "POST /index.php HTTP/2.0" 200 2659 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.028 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="12832" cs=-
127.0.0.1 - - [27/Jul/2018:21:49:09 -0500] "POST /index.php HTTP/2.0" 200 2666 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.026 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.024" ul="12832" cs=-
127.0.0.1 - - [27/Jul/2018:21:49:38 -0500] "POST /index.php HTTP/2.0" 200 2787 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.027 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="13040" cs=-
127.0.0.1 - - [27/Jul/2018:21:50:16 -0500] "POST /index.php HTTP/2.0" 200 2778 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.029 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="13024" cs=-
127.0.0.1 - - [27/Jul/2018:21:50:37 -0500] "POST /index.php HTTP/2.0" 200 2781 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.026 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.024" ul="13008" cs=-
127.0.0.1 - - [27/Jul/2018:21:51:39 -0500] "GET / HTTP/2.0" 200 2600 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.026 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.024" ul="12647" cs=-
127.0.0.1 - - [27/Jul/2018:21:52:05 -0500] "POST /index.php HTTP/2.0" 200 2786 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.029 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="13032" cs=-
127.0.0.1 - - [27/Jul/2018:21:54:11 -0500] "GET / HTTP/2.0" 200 2598 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.027 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="12648" cs=-
127.0.0.1 - - [27/Jul/2018:21:54:51 -0500] "POST /index.php HTTP/2.0" 200 2780 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.029 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="13040" cs=-
127.0.0.1 - - [27/Jul/2018:21:55:39 -0500] "GET / HTTP/2.0" 200 2600 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.029 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.032" ul="12648" cs=-
127.0.0.1 - - [27/Jul/2018:21:56:10 -0500] "POST /index.php HTTP/2.0" 200 2778 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.028 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="13024" cs=-
127.0.0.1 - - [27/Jul/2018:21:56:18 -0500] "GET /index.php HTTP/2.0" 200 2593 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.027 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="12648" cs=-
127.0.0.1 - - [27/Jul/2018:22:11:19 -0500] "POST /index.php/heartbeat HTTP/2.0" 200 2598 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.035 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.032" ul="12648" cs=-
127.0.0.1 - - [27/Jul/2018:22:14:54 -0500] "GET / HTTP/2.0" 200 2586 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.75 Safari/537.36" "-" "thewize" sn="thewize" rt=0.033 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.032" ul="12429" cs=-
127.0.0.1 - - [27/Jul/2018:22:15:17 -0500] "POST /index.php HTTP/2.0" 200 2764 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.75 Safari/537.36" "-" "thewize" sn="thewize" rt=0.029 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="12808" cs=-
127.0.0.1 - - [27/Jul/2018:22:26:20 -0500] "POST /index.php/heartbeat HTTP/2.0" 200 2598 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.035 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.036" ul="12648" cs=-
127.0.0.1 - - [27/Jul/2018:22:41:20 -0500] "POST /index.php/heartbeat HTTP/2.0" 200 2599 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.034 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.036" ul="12648" cs=-
127.0.0.1 - - [27/Jul/2018:22:54:38 -0500] "GET / HTTP/2.0" 200 2601 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "localhost.localdomain" sn="thewize" rt=0.032 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.032" ul="12649" cs=-
127.0.0.1 - - [27/Jul/2018:22:55:07 -0500] "POST /index.php HTTP/2.0" 200 2779 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "localhost.localdomain" sn="thewize" rt=0.024 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.024" ul="13040" cs=-
127.0.0.1 - - [27/Jul/2018:22:56:20 -0500] "POST /index.php/heartbeat HTTP/2.0" 200 2603 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.031 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.032" ul="12648" cs=-
127.0.0.1 - - [27/Jul/2018:23:11:20 -0500] "POST /index.php/heartbeat HTTP/2.0" 200 2600 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.029 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="12648" cs=-
127.0.0.1 - - [27/Jul/2018:23:26:20 -0500] "POST /index.php/heartbeat HTTP/2.0" 200 2602 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0" "-" "thewize" sn="thewize" rt=0.026 ua="unix:/run/php/php7.2-fpm.sock" us="200" ut="0.028" ul="12648" cs=-

Nextcloud error logs are empty.

The craziest thing about all this is that I’ve actually installed Nextcloud before! About a month ago, I sat down at my desktop. I had created a 400gb partition on it to use Linux to run neural networks as part of an art experiment. (that’s why I started learning CLI stuff). I bought a Surface Book 2 and decided to turn my Windows desktop with a Linux partition into a Linux desktop with a windows partition. I started exploring customizing it. I installex Xubuntu, and then I tried Kubuntu. Stuff was kind of a mess, But before wiping the drive a doing a new installation I decided to try out Nextcloud. It took me about 5 minutes or so. I was able to, without a domain name, create a server, and even create public links that I could access on my phone (while it was on data only so I knew it wasn’t just sharing over wifi).

I then wiped the computer, and I’ve spent the last month experimenting with various configurations before finally settling down on a normal Ubuntu 18.04 gnome desktop with some modications and themes.

And now I can’t install NextCloud no matter what I try…

The even weirder thing is… I don’t remember what tutorial I looked at, but I’m pretty sure that it made use of the setup-nextcloud.php file even though I’m not installing stuff on a shared host, I’m trying to install it on my personal local desktop machine.

I really don’t know what to do. I feel like the closest I ever got was when I tried creating a server and then just running setup-nextcloud.php off localhost.localdomain. At least that was kind of close. I managed to get past at least one screen.

So yeah. any help?

If you’re learning to be a webdev then I’d focus on that first, and not the application/service you might then run. There are hundreds of guides for installing a LAMP stack that you should be able to follow, and once you’ve got that running, adding Nextcloud should be much more difficult than downloading the latest server files into the right location.

Yes, and I’ve followed them and I’m still running into problems. I even got a LEMP stack running that I was able to test and confirm was working but then was not able to get NextCloud to properly connect to the database. I don’t know why. I’ve also used MAMP (MAMP is cross platform now) before on Windows so I have at least some basic experience with the process but for some reason this is giving me some trouble.

I always find these - https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu-16-04 - guides to be a good starting point, although I’m running FreeBSD, NGINX and Mariadb so haven’t used it myself!