Ignore folder with Nextcloud sync on Windows

Hi all

how is it possible to ignore a folder with the synchronistion client for windows ? I just want to ignore files but it should be well in the directory. “Nextcloud sync” the suppressed local folder if it does not sync

thank you in advance to all

sorry for my bad english :confused:

You can unselect specific folders (on your server) that are not synced to the client. You actually can’t exclude local folders from syncing.

Thank you @tflidd . Just one question, how cay I unselect specific folders on the server to avoid syncing with the client? I searched on the manual and on the web interface and didn’t find that option.

Thanks!

You can do it in the client itself. On the synced folder you can click on the small triangle and it shows you a list of all folders and subfolders.

I see, great thanks!

For those who are looking for the latest solution to exclude a folder from syncing (but avoid it from being deleted), this guide tells you how to do.

https://docs.nextcloud.com/desktop/2.3/architecture.html#ignored-files-label

For example, if you don’t want to include node_modules to syncing, open a setting display on the client, click Edit Ignored Files, input node_modules/ (don’t forget the slash) and hit save. That should work.

ref: https://docs.nextcloud.com/desktop/2.3/navigating.html#using-the-ignored-files-editor

4 Likes

Came here because of node_modules :laughing:
This surprised and helped me, thanks!

2 Likes

Hello

I came here for a node_modules folder too :wink:

I can’t manage it to not sync on windows… I followed the links given to the docs, but still with “node_modules/” and “node_modules/*” entries, everything is synced likke if there were no settings…

Here is the version of the client:
Version 3.0.3 (Windows)

Here is my synced folder (with the .sync-exclude.lst file):
image

Here is the content of the .sync-exclude.lst file:

node_modules/
node_modules/*

And finally the content of distant server:
image

Please help me to point out what I didn’t do well!

Thx :heart: