I can't upgrade ncp to version 25 because I have installed php7.4

I can’t upgrade ncp to version 25 because I have installed php7.4 and the system said that I would have php 8. How can I solved it?

Nextcloud version (eg, 20.0.5): 24.0.5.1
Operating system and version (eg, Ubuntu 20.04): Debian GNU/Linux 11. 5.10.103-v8+ (aarch64)
Apache or nginx version (eg, Apache 2.4.25): replace me
PHP version (eg, 7.4): 7.4

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<--! Paste this in GitHub report -->

<details>
<summary>NextcloudPi diagnostics</summary>

Nextcloud is in maintenance mode, hence the database isn’t accessible.
Cannot perform any command except ‘maintenance:mode --off’

NextcloudPi version v1.52.0
NextcloudPi image NextCloudPi_11-27-20
OS Debian GNU/Linux 11. 5.10.103-v8+ (aarch64)
automount yes
USB devices sda
datadir /media/myCloudDrive/ncdata
data in SD no
data filesystem btrfs
data disk usage 168G/1.9T
rootfs usage 3.5G/15G
swapfile /var/swap
dbdir /var/lib/mysql
Nextcloud check ok
Nextcloud version 24.0.5.1
HTTPD service up
PHP service up
MariaDB service up
Redis service up
HPB service down
Postfix service up
Internet check ok
Public IPv4 REMOVED SENSITIVE VALUE
Public IPv6 REMOVED SENSITIVE VALUE
Port 80 open
Port 443 open
IP REMOVED SENSITIVE VALUE
Gateway REMOVED SENSITIVE VALUE
Interface enxb827eb047fb4
Certificates REMOVED SENSITIVE VALUE
NAT loopback no
Uptime 5min

</details>


<details>
<summary>Nextcloud configuration</summary>

Nextcloud is in maintenance mode, hence the database isn’t accessible.
Cannot perform any command except ‘maintenance:mode --off’

{
“system”: {
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: {
“0”: “localhost”,
“5”: “nextcloudpi.local”,
“7”: “nextcloudpi”,
“8”: “nextcloudpi.lan”,
“11”: “REMOVED SENSITIVE VALUE”,
“1”: “192.168.18.9”,
“12”: “REMOVED SENSITIVE VALUE”,
“13”: “REMOVED SENSITIVE VALUE”,
“3”: “nextcloudpi”,
“14”: “nextcloudpi”,
“”: “nextcloudpi”
},
“datadirectory”: “REMOVED SENSITIVE VALUE”,
“dbtype”: “mysql”,
“version”: “24.0.5.1”,
“overwrite.cli.url”: “https://nextcloudpi/”,
“dbname”: “REMOVED SENSITIVE VALUE”,
“dbhost”: “REMOVED SENSITIVE VALUE”,
“dbport”: “”,
“dbtableprefix”: “oc_”,
“mysql.utf8mb4”: true,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“installed”: true,
“instanceid”: “REMOVED SENSITIVE VALUE”,
“memcache.local”: “\OC\Memcache\Redis”,
“memcache.locking”: “\OC\Memcache\Redis”,
“redis”: {
“host”: “REMOVED SENSITIVE VALUE”,
“port”: 0,
“timeout”: 0,
“password”: “REMOVED SENSITIVE VALUE
},
“tempdirectory”: “/media/myCloudDrive/ncdata/tmp”,
“mail_smtpmode”: “sendmail”,
“mail_smtpauthtype”: “LOGIN”,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_domain”: “REMOVED SENSITIVE VALUE”,
“preview_max_x”: “2048”,
“preview_max_y”: “2048”,
“jpeg_quality”: “60”,
“overwriteprotocol”: “https”,
“maintenance”: true,
“logfile”: “/media/myCloudDrive/ncdata/nextcloud.log”,
“loglevel”: “2”,
“log_type”: “file”,
“htaccess.RewriteBase”: “/”,
“trusted_proxies”: “REMOVED SENSITIVE VALUE”,
“data-fingerprint”: “5631d3ad7edac625bda252ba394119d5”
}
}

</details>


<details>
<summary>HTTPd logs</summary>

Are you using the NCP updater or are you trying to upgrade Nextcloud directly?

nc-update-nc