I can´t find an unwanted "extra" file named "0"

Nextcloud version (21.0.1)
Operating system and version (???)
Apache or nginx version (???):
PHP version (7.4)

I am trying to update nextcloud. I tried using the built-in updater and at the first step “Check for expected files” it says “Parsing response failed” and “500 Internal Server Error”.
I then tried to update via SSH and it says

[✘] Check for expected files failed
The following extra files have been found:

Update failed. To resume or retry just execute the updater again.

I searched for files named “0” and found many, all in a preview directory. I deleted that directory, now the search doesn´t show any results, but the error message stays the same.
I am grateful for any ideas on what to do. I guess its good to know, that I am completely new to SSH, just taking my very first steps.
I tried looking for already existing answers but couldn´t really find what to do, if the extra file can´t be found and also it was never named “0”.

Thank you in advance

Is this the first time you’ve seen this error? : No

Steps to replicate it:

  1. Start update


try this command
You must be in the …/www/nextcloud/ folder !

rm -r -f .0

Hi @kollala,
You are missing the required support template. Please actually fill this form out and edit into your post.

This will give us the technical info and logs needed to help you! Thanks.

I think 0 is not the name of the file. Maybe an error of the integrity check.
Search manually in the upper Nextcloud software folder (not data folder of users).
Search files with any eye catching name not from Nextcloud.
Not a good idea to delete something directly.

Can you go to the admin page, there is the integrity check which is perhaps more detailed:

On the admin page under " Security & setup warnings" it says “All checks passed.”.

The nextcloud is hosted on uberspace. When I login via SSH, the “highest” directory is called “~”.
In there it looks like this
bin etc html logs Maildir nextcloud_data testsftp tmp users

Nextcloud_data has all the users in it.
Could you tell me again, where to search?
And what to look for. For me, being completely new to this, pretty much everything is a bit eye catching :grimacing:

I just found, that “html” has a file called “0”. Instead of deleting, I wanted to move it to “~” to see whether this helps. This happens

mv 0 /~/0 
mv: cannot move ‘0’ to ‘/~/0’: No such file or directory

Opening the file with nano, it seems to be completely empty. Is it safe to delete it?

Well i went ahead and deletet “0” in “html”. After that the update worked! :partying_face:

Only thing I don´t understand: Why couldn´t I find that file using
find . -0
? :thinking:

The correct syntax is:
find . -name "0"

1 Like