HTTP-Transmission Error

nc14

#1

I would welcome some help.

For one of my remote folder shares, the synch does not work.

I am using client version 2.5git on a Ubuntu based system.

Here is the message:

“A HTTP transmission error happened. The server file discovery reply is missing data.
/path/to/local/folder”

or in German:
“Es hat such ein HTTP-Übertragunsfehler ereignet. Bei der Server-Dateierkennungsantwort fehlen Daten.
/path/to/local/folder”

Sorry I do not understand the message.

Please help, how can I fix this?


#2

Please check your server logfiles as well. The answer the server was giving you was perhaps incomplete or triggered an error. You can as well try to connect to a test setup (https://help.nextcloud.com/t/demo-instances-of-9-10-11-and-12-now-live) to make sure it’s not related to a client bug.


#3

Hello,

with the 2.5.1 client i get the same error.
With the 2.4.1 client everything works quite fine


#4

If a client update breaks something clearly, please create a bug report on https://github.com/nextcloud/desktop/issues


#5

I checked the client log via the --logwindow switch

what i found was:

11-28 13:52:27:054 [ warning sync.discovery ]: Missing properties: “Servicetechnik_ST1” 2 0 1543409545 “M” “” “-0000001oc3jkbyldutc”
11-28 13:52:27:054 [ warning sync.csync.updater ]: opendir failed for - errno 10011
11-28 13:52:27:055 [ warning sync.engine ]: ERROR during csync_update : “Es hat sich ein HTTP-Übertragungsfehler ereignet. Es fehlen Daten der Server-Antwort zur Dateisuche”

so i checked it via web.
i disabled the share and after then the 2.5 Client works as usual.

It seems that “Missing properties:” Causes the Error.


#6

It’s definitely a result of the upgrade to 2.5

I just cannot tell from the log which error it is throwing.
The log seems to mix the two different shares.


#7

Got 2.5 on new box form repository. Tried to find an previous version. Did not succeed.


#8

I also tried to find version 2.4 for debian / ubuntu based systems. Nowhere in sight.
A downgrade does not seem to be foreseen.
:disappointed_relieved:


#9

I managed to downgrade on Ubuntu 18.04.
I removed the current version, changed the PPA to ‘artful’ (= Ubuntu 17.10) and then installed nextcloud-client again.

Works flawlessly! This is not the first time I think of NC14 and this desktop client that they weren’t tested well enough…


#10

Here the issue for reference:

If you know what logs we need to post, please tell me.


#11

I removed the current version, changed the PPA to ‘artful’ (= Ubuntu 17.10) and then installed nextcloud-client again.

How did you do that? I can only downgrade to 2.3.3. which does not let me login to the accounts…

I can not see 2.4 on the repository:
http://ppa.launchpad.net/nextcloud-devs/client/ubuntu/pool/main/n/nextcloud-client/

This is not the first time I think of NC14 and this desktop client that they weren’t tested well enough…

I agree.

This seems to be a trend in software development. I spent some time yesterday fighting with Thunderbird. Some update in NC or Thunderbird crashed also the Sogo Connector based address book synchronisation :frowning:


#12

I just tested with the owncloud client which is in teh Ubuntu repos:

sudo apt install owncloud-client

Works like a charm. No issues!

What can is wrong with the Nextcloud client?
Does it actually need a dedicated client for Nextcloud or can both not be used?
What is the special features the Nextcloud client offers over the owncloud client?


#13

You’re right, I installed the 2.3.3 version, which works really well with my NC 14.0.4 instance!


#14

In my Scenario it doesnt matter which Client I used (Nextcloud or Owncloud), the error was the same.
with the 2.5 Clients I could fix the HTTP Transmission Error only by removing the shares via Web which had the “Missing properties” Error.

In some cases some Users could even see there files via the Webbrowser in the default view.

We downgraded our whole company back to the 2.4.3 Client (Owncloud). And its working fine again.
But this is a really strange.


#15

Yes, I confirm that 2.3.3 works.

But I had to configure the accounts & (local) folders again.

Can you please all upvote on:

I really do not understand that they keep releasing new versions to the repository albeit this issue persists.


#17

Same issue here with NC 13.0.8 and Win10 Client 2.5.1 on a new PC.

I got https://download.nextcloud.com/desktop/releases/Windows/Nextcloud-2.3.3.1-setup.exe and installed that instead.

[My server is still running on V13 as it did not propose to upgrade to V14 yet]


#18

I ran across this http transmission error (and managed to resolve it) in the following situation. Not sure if this helps to resolve the issue, but i’ll share it anyway.

What happened:

  • I shared a folder with a client
  • Client uploaded files to his root (instead of to the shared folder)
  • Nextcloud apparently put his upload in the Nextcloud root
  • I tried to move or copy the folder
    –> error message appeared in my Windows client (2.5.1).

What i tried:

  • Uncheck shares in the desktop client (root folder, shared folder) -> did not resolve the error
  • Try to move the files in the web client -> operation forbidden
  • ‘Unshare’ through the web client -> this resolved the error.

Other then this i haven’t had this error before with 2.5.1.


#19

This workaround works for me.

After unshare through the web client, desktop client starts syncing. There was one shared folder that causes the error, unfortunately I missed what folder was and I can’t imagine why it causes the error.

It’s a little wired, because those folders are shared with other users and they don’t have this issue…

Thanks a lot Wesley

P.D. I found the error. I do not know how, but some files that were shared by a user, mysteriously disappears (I cant find them, not in the logs, not in the users folder or trash),but the users who have those files shared by this first user can see like the files were there. The strange thing is that those files have the folder icon instead of the excell file icon. This causes the http error in the sync program. I unshare those files an it works again.