How to use occ commands on a Shared Hosting without SSH access

THX for help
App Installed and can open it in NC 18.0.1 RC1
what’s next

Try to execute the occ command. If it succeeds, you can try to run db:add-missing-indices (on your own risk :wink:).

Great THX

there is another message:

Can You Pls Help again?

I think you cannot run the mentioned command in a hosted environment without shell access, because it need to be run in “offline” (maintenance) mode. I would recommend to contact the support of your hoster and ask them to run the command on your database or if you’ve e.g. phpmyadmin available you can try to modify the table settings manually.

I have seen it somewhere at 1und1 interface

I’m confused which database I have used for Nextcloud
Where can I see the name of the database in Nextcloud?

In System there si only:

I started new Thread because it seems that its not possible to be solved with OCC Commands (it needs to be run in “offline” (maintenance) mode)


It worked

Great tool!

Can one or more from this also be solved with Web OCC

I tried:grafik

What can I do?
Is there a download for this App?, where to put it for installation?

  • Strict-Transport-Header” is a web server related setting. Please use the search function of the forum for further details.
  • PHP-Memory-Cache”, like Redis, need to be installed on your system. Please check the provided installation tool of your provider how to install it and the Nextcloud documentation on how to configure it.
  • PHP-Opcache”, like the Zend extension, need to be installed on your system. Please check the provided installation tool of your provider how to install it and the Nextcloud documentation on how to configure it.
  • php-imagick” is not a Nextcloud, but a system program. Please check the provided installation tool of your provider how to install it and the Nextcloud documentation on how to configure it.
1 Like

Can something be done with the other messages?

Where to check?
Is really nobody in the forum who has hosted installation on 1und1 and knows the steps?

I recommend calling the support hotline of your hoster for all the php related stuff.
I assume, that in the default installation, some php modules are missing and you cannot install them with cPanel or similar.
Ask them, if they can help you and maybe install the missing php modules.
Or they can give you some hints, how you can do this on your own.

If this is not possible by your hoster or they don’t want to do this, you have to decide wether you can live with this limitations or you need a Nextcloud installation on your own vps/dedicated server with full root access…

The author of the OCC WebApp does not longer support Nextcloud versions higher 19. Is there any possibility to run the OCC comands like the files scan without having SSH access on a shared hosting?

Does anybody have more information?

On some hosters it is possible to use a separate PHP-file to perform occ commands. It depends on the settings of the hoster though, whether that will work or not (it works with mine). It might be worth a try:

  1. create a file on your webspace called occ-command.php (or whatever you wanna call it) with the following content (adjust RELATIVE/PATH/TO/occ to point to your occ in the nextcloud-installation folder; also the path to php possibly needs to be adjusted):
       exec("/usr/bin/php -d memory_limit=1024M RELATIVE/PATH/TO/occ -n status > occ_result.txt");
       exec("echo \"Command completed!\" >> occ-result.txt");
       header('Location: occ-result.txt');
  2. visit occ-command.php with a browser
  3. after executing the command, the browser will be redirected to a logfile (occ-result.txt)
  4. for security reasons it is better to delete occ-command.php and occ-result.txt from your webserver when you are done.

Hello [rakekniven],

I installed this app on my Nextcloud which is hosted on Hetzner.

However, it is not clear to me how I should then run occ…

If I just type
then nothing happens

Once in OCCweb, which command shall I use to upgrade to the next nextcloud version ?

Thank you !

Please see and

This app is deprecated and should not be used anymore.

btw. it was never designed for upgrading an NC instance.

Hi rakekniven

Thank you for keeping us up to date on this! I am glad I read until your final post - do you know an alternative?

I have SSH-access to the managed server (Hetzner) but no sudo-rights. This means I can run occ-commands but I can’t specify the user to www-data first. I suppose it would be unsafe to simply run

php occ maintenance:mode --on
php occ db:convert-filecache-bigint

am I right?

All the best,

I think your user is the user the webserver is running as. So I would give it a try.

No - security is not an issue here.

Hi! Thank you guys for your quick replies! I just wanted to make sure I won’t mess with the permissions as the warning in the manual says. Thank you for reassuring me :slight_smile:

I found alternative options in the admin manual to set the user without sudo but haven’t successfully tried them yet (rtfm, sorry, I know…). It might help someone else, who knows.